+ Responder ao Tópico



  1. #81

    Padrão

    Citação Postado originalmente por Ramde Ver Post
    Antes de tudo, valeu CATVBRASIL

    Aqui, o que tudo indica que funcionou legal, a minha dúvida é quanto ao controle de banda, as vezes os clientes estão gastando bem acima do estipulado pelo controle de banda, mas são picos rápidos, esses picos são o acesso ao web-proxy?
    Quando acesso esse site que verificam a velocidade da banda, eles acusam uso maximo da banda, o que antes não acontecia, isso é normal?
    Opa. É normal sim e o lance do velocímetro pode ser porque a página e o teste estão em cache.

  2. #82

    Padrão

    Citação Postado originalmente por edielsonps Ver Post
    regra para fixar sempre em sima a regra no queues simples usando hotspot

    :foreach I in=[/queue simple find name="proxyfull"] do={/queue simple move $I [/queue simple find dynamic=yes]}

    com esse regra vc deixa sempre seu script de queues encima das outras
    ai é so coloca o agendamento pra ele execultar exemplo a cada 10min..
    Parabéns, CATV pelo tópico!

    O troço funciona mesmo!

    edielsonps, não tô entendendo bem essa regra, eu coloco ela do jeito que está aí no scheduler, é isso?

    Abs.



  3. #83

    Padrão

    bom, eu tava deichando para postar assim que eu tivesse uma certeza sobre o que estoou falando, e agora chequei a ela,

    Funcionou em parte, porem como muitos outros ja falaram por aqui a placa da internet continua sem controle de banda,

    como saber?

    cadastrei um cliente com 128k, baichei um arquivo que ja eestava em cacha em cerca de 200KB por segundo, nossa ótimo, sendo que meu link é de 1 MB, porem baichei mais uns 15 arquivos com uma media de 2 MB de tamanho, e eles sempre vieram na velocidade do meu link, eu baixando a 90 KB por ai, inclusive no grafico da placa de rede é o melhor jeito para se acompanhar isso.

    agora uma solução pra isso? ainda nao sei

  4. #84

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    bom, eu tava deichando para postar assim que eu tivesse uma certeza sobre o que estoou falando, e agora chequei a ela,

    Funcionou em parte, porem como muitos outros ja falaram por aqui a placa da internet continua sem controle de banda,

    como saber?

    cadastrei um cliente com 128k, baichei um arquivo que ja eestava em cacha em cerca de 200KB por segundo, nossa ótimo, sendo que meu link é de 1 MB, porem baichei mais uns 15 arquivos com uma media de 2 MB de tamanho, e eles sempre vieram na velocidade do meu link, eu baixando a 90 KB por ai, inclusive no grafico da placa de rede é o melhor jeito para se acompanhar isso.

    agora uma solução pra isso? ainda nao sei
    Cmo já falei, volto a repetir... Vcs precisam de uma qos e de um excelente firewall para o bom funcionamento do sistema... isso com ou sem cache full...



  5. #85

    Red face QOS e Firewal??

    Citação Postado originalmente por catvbrasil Ver Post
    Cmo já falei, volto a repetir... Vcs precisam de uma qos e de um excelente firewall para o bom funcionamento do sistema... isso com ou sem cache full...
    Sobre QOS certo creio q e sobre a marção de pacotes e definir prioridades certo?
    Ate ai tudo bem. E sobre o firewall??? entendo que ele tem q estar bem configurado.. senão vai causar varias dores de cabeça. não entendi o q exatamente no firewall tem q estar configurado para essa regra filtrar tudo blz.
    OK?

  6. #86

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Em testes práticos não, tendo em vista que a maioria das páginas são menos de 100k e também sabemos que é muito melhor o cara pegar um MSN de 10mb em 5 segundos, do que passar 5 minutos baixando a 30k. Pode ficar tranquilo que só fica cache full para o que está no cache. O que está na NET ele vai com a banda normal.
    cara, aqui nao tem jeito, mesmo o que nao esta em cache vem rapido, ou seja no cliente com 128k, ta dando cerca de 800 ou 900 kbps, estourando meu link direto.

    quando realmente esta em cache nao tem importancia, o prob,, é com coisas que nao estao no cache,

    lembrando que eu nunca cheguei a colocar a regra do tiago matias, ou seja coloquei direto a sua,

    no manglge, as tres regras estao contando e o contador delas sobem juntos, ou seja mesmo valor nas tres.

    na queu simles, esta no topo e marcando normalmente,


    o que nao estou intendendo é que a logica é, como tudo passa pro cliente atraves da porta 3128, como o mk sabe o que esta no proxy ou não.

    de uma luz aqui, acho que tem mais gente que nao esta conseguindo.



  7. #87

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Cmo já falei, volto a repetir... Vcs precisam de uma qos e de um excelente firewall para o bom funcionamento do sistema... isso com ou sem cache full...

    certo CATV, parabens pela regra, porem nao vejo onde o resto do firewal tem a ver, e o mesmo para o QOS, sendo assim, NAo ta fucionando aqui,
    e teve mais gente que tbem nao conseguiu,

    entao o que falta para nós? pq será que estoura o limite, afinal nao tem logica isso, se as regras estao em ordem certa, mesmo que tivesse algo errado depois, elas deveriam funcionar não é?

  8. #88

    Padrão

    Estou com problemas por aqui tb, é o seguinte:

    com somente um usuario controlado no hotspot a 128k , quando ativo o cache full ou somente o web proxy , no pppoe fica dando picos de 1Mb de download.
    Recebo o link do modem e passo para uma pl de rede no MK(ether2) onde faço pppoe e através de outra pl de rede repasso a clientes(ether1) através de um rádio



  9. #89

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    cara, aqui nao tem jeito, mesmo o que nao esta em cache vem rapido, ou seja no cliente com 128k, ta dando cerca de 800 ou 900 kbps, estourando meu link direto.

    quando realmente esta em cache nao tem importancia, o prob,, é com coisas que nao estao no cache,

    lembrando que eu nunca cheguei a colocar a regra do tiago matias, ou seja coloquei direto a sua,

    no manglge, as tres regras estao contando e o contador delas sobem juntos, ou seja mesmo valor nas tres.

    na queu simles, esta no topo e marcando normalmente,


    o que nao estou intendendo é que a logica é, como tudo passa pro cliente atraves da porta 3128, como o mk sabe o que esta no proxy ou não.

    de uma luz aqui, acho que tem mais gente que nao esta conseguindo.
    olá jhonnyp fazz sentido mesmooO eu aqui tambemmm nao consegui tudo certinho as regras contam perfeitamente as tres simultaneamente mesma
    quantidade de pacotes a queue conta tambem normal maissss continua passando
    link full e nao cachee full

    se alguem puder explicarrrr como que a marcaçãoooo vai saber o que eh HIT e o que é MISS no proxy
    daiii eu vo começar a acreditar que pode funcionar...
    porem no mik 3 isso ja funciona mais com essa analise de HIT e MISS que nessa versão nao existe
    abraços e beijoss pra todos fofinhos que postam aqui ^^

  10. #90

    Padrão

    isso mesmo, ai que ta o problema, o mk saber o que é hit e o que é miss,

    ouvi dizer que estudando o fluxo do mk de como ele trata as informações é possivel fazer isso, porem nunca ouvi alguem dizer que realmente funcionou.



  11. #91

    Padrão

    Após ler alguns post e fazer alguns testes aki, percebi realmente que o proxy atua 100%, porém o controle de banda parece não atuar nos ips cadastrados no queoes simple.

  12. #92

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Então galera. Aproveitando a dica do amigo Tiago Matias, analizei a regra e criei a solução para resolver o uso do CACHE-FULL sem estourar todo o link. Para isso incluimos mais uma regra de return, a qual irá pegar os pacotes, após analiza-los com as regras tradicionais e voltar para dentro do router. Consequentemente será encaminhado normalmente para fora da internet sem usar a banda toda. Não precisamos mais esperar até a versão 3.0, pois está testado e aprovado em alguns clientes meus que implantei. Segue as regras:

    /ip firewall mangle
    add chain=output protocol=tcp src-port=8080 action=mark-connection \
    new-connection-mark=proxyfull passthrough=yes comment="PROXY FULL" \
    disabled=no
    add chain=output connection-mark=proxyfull action=mark-packet \
    new-packet-mark=proxyfull passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyfull action=return comment="" \
    disabled=no

    Note que há uma mudança na regra de marcação de pacotes (segunda regra), na qual o passtrought fica neste caso ligado, enviando os pacotes para a próxima regra de RETURN. A regra de RETURN, terá que ficar na última linha do conjunto, pois ela pegará os pacotes analizados e marcados pelas regras anteriores e retornará a sua origem aqueles que não são do proxy full (consequentemente só colocando na queue simple do proxyfull aqueles pacotes a qual são realmente vindos do cache). Tae a dica e façam bom proveito, pois tive que me lascar durante uma semana aqui estudando manuais, firewall e regras para desenvolver esta regra. rssss

    CATVBRASIL
    Ola CATV.. amigo parabéns pela sua iniciativa e pela sua competencia..

    Olha só eu adaptei as regras de mangle e coloquei comforme a minha rede tmbém no queue, marca td direitinho mas parece q todo download vai direto pra a queue do proxyfull (rezumindo cliente faz down sem limite). pra ter certeza eu limpei todo o cache e fiz um down ai ele foi direto pra a queue do proxy full...


    obrigado e mais uma vez parabéns...


    Ueslei carvalho



  13. #93

    Padrão

    viu catv tem muitos nao conseguindo isso, da um ajudiha para nós nisso,
    sei que nao foi facil pra vc fazer isso, porem ajude-nos que isso é de uma grande utilidade

    se mais alguem que testou poste se o controle funcionou total, inclusive atuando na placa do link, pq como esta parecendo varias pessoas estao se deparando no mesmo problema, dai o que parece ser uma coisa boa acaba ficando ruim,(nao digo que sua regra é ruim, digo do jeito que ta o meu sem controle na internet dai fica ruim pra mim)

    afinal do jeito que ficou o meu, seria a mesma coisa que desabilitar o controle de banda dos usuarios, ou tbem deichar eles em unlimited, pois ta indo quase tudo pra queue cache full

    flw
    Última edição por jhonnyp; 05-11-2007 às 17:31.

  14. #94

    Padrão

    Parabéns ao CATV
    Mas realmente, existe um furo ae no controle de banda.
    Dê um conferida ae, e realize mais teste com mais minusciosidade .... vc vai ver.
    Estou experimentando umas regras .... funcionando certim, posto aqui...
    Valeu .



  15. #95

    Padrão

    É verdade, o CACHE FULL realmente funciona, porém o "LINK FULL" tb...

    Ontem eu havia implementado as regras do amigo CATV e vi que realmente estava com CACHE FULL, decidi então, fazer um download(ftp://ftp.slackware-brasil.com.br/sl...nstall-dvd.iso) pra ter certeza que era somente o CACHE FULL, e era.

    Porém, hoje pela manhã fui surpreendido por dezenas de ligações de pessoas reclamando da falta de velocidade, fui constatar e vi que era um usuário fazendo downloads de filmes pelo friendlyfiles... =(

    Resumo: Meu teste foi equivocado, pois usei a porta 21 que não passa pelo proxy, e portanto estava dentro do controle de banda, enquanto os arquivos que chegavam pelo http, ou seja, pelo proxy, estavam livre de limitações por parte do controle de banda. Enfim, o CACHE FULL funciona de verdade, porém, à ele está atrelado o "LINK FULL".

    CATV parabéns pela iniciativa, mas se vc tiver interesse, posso te dar acesso ao meu MK pra comprovar a falha do "LINK FULL".

    CATV, não desista, sinto que estamos chegando perto da solução!

    Abs.

  16. #96

    Padrão

    ola a todos,,
    implementei as regras aqui no meu mk,
    esta rodando blz, contando os pacotes,,
    fiz uns testess,,

    baixaei um jogo q estava em cache,,,
    minha velocidade em 100k e baixou na velocidade da rede,,

    mais,,

    quando vou baxar algo q nao esta em cache, ocorre a msm coisa,,
    velocidade do link,,

    ao amigo catv, pode ajudar ??
    vlw



  17. #97

  18. #98

    Padrão

    Pessoal, não sei se estou ficando maluco ou cego, mas meu Mikrotik e dos meus clientes, estão TODOS funcionando 100%. Já ressaltei aqui que é obrigatório se construir uma QoS e também um firewall decente (que chegaram até a perguntar o que isso tinha a ver). Aqui faço o serviço profissionalmente e é obrigatório ficar 100%. Mais uma vez, revejam suas regras que com certeza irá funcionar beleza.



  19. #99

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Pessoal, não sei se estou ficando maluco ou cego, mas meu Mikrotik e dos meus clientes, estão TODOS funcionando 100%. Já ressaltei aqui que é obrigatório se construir uma QoS e também um firewall decente (que chegaram até a perguntar o que isso tinha a ver). Aqui faço o serviço profissionalmente e é obrigatório ficar 100%. Mais uma vez, revejam suas regras que com certeza irá funcionar beleza.
    CATV... não se chatei nem se sente precionado, vc é um dos maiore colaboradores do forum e muita gente depende de soluções sua pra fazer um MK funciona inclusive eu sou um deles. por isso vou te pedir mais uma forçinha ai, como seria um firewall descente como você fala?? pode posta pra gente o que falta no nosso firewall???? pois eu ttestei aqui e fiquei como muitos com um link full e isso pra mim e locura por que eu uso satelitte com limite de trafego.


    Valeu aimgão.

    E parabéns mais uma vez.

  20. #100

    Padrão

    Galera a regra do catv ta otimaa
    quem acha q o controle de banda nao funciona e so presta atencao aki nao deu nenhum problema nao

    tipo
    quando coloco 128k pra min
    eu baixo o arquivo a 22k
    mais depois depender do tamanho do arquivo
    ele vai baixando
    o proxy full funciona 100%

    valeu catv