+ Responder ao Tópico



  1. #1

    Unhappy VPN conecta mas não funciona

    Oi pessoal,

    Estou aqui apanhando da instalação do strongswan.

    Eu já consegui conectar as duas pontas da vpn, mas as redes não se conversam.

    É assim que está configurada a VPN

    [10.1.1.0/24]--[200.200.200.200]===[201.201.201.201]--[10.2.2.0/24]

    Quando eu tento pingar algum endereço interno a partir de qualquer uma das redes, eu não consigo.

    Eu li nos manuais do strongswan, e já vi no iptables, que ele adiciona as regras de forward... eu tenho que fazer alguma configuração de rotas ou adicionar outras regras no iptables?

    Estou usando o kernel 2.6.23.1, iptables 1.3.8 e o strongswan 4.1.8.

    Se alguém puder me ajudar eu seria muito grata, pois estou sem saber o que fazer.

    Obrigada!!

  2. #2

    Padrão Rotas...

    Vc adicionou as rotas pras redes internas?



  3. #3

    Padrão

    Citação Postado originalmente por terencerocha Ver Post
    Vc adicionou as rotas pras redes internas?
    Oi Terence,

    Obrigada pela resposta!!!

    Você diz rotas no gateway com vpn? Se for isso, eu tentei sim... vou usar como exemplo o que eu fiz num dos gateways:
    route add -net 10.2.2.0 netmask 255.255.255.0 gw 201.201.201.201

    Nos computadores eu coloquei rotas assim:
    route add -net 10.2.2.0 netmask 255.255.255.0 gw 10.1.1.1

    10.1.1.1 é o endereço interno do gateway "left"

    É a primeira vez que eu mexo com strongswan... eu já tinha feito uma VPN com um freeswan e ele criava interfaces ipsec*... agora com o strongswan eu não estou entendendo o que está acontecendo.

    Eu vi no site do strongswan os documentos e não vi nada sobre rotas!!

    Se você puder me ajudar eu fico grata!

    Obrigada!

  4. #4

    Padrão Rotas...

    acredito que suas rotas devam ficar assim...

    maquina left
    route add -net 10.2.2.0/24 netmask 255.255.255.0 gw 201.201.201.201

    maquina right
    route add -net 10.1.1.0/24 netmask 255.255.255.0 gw 200.200.200.200



  5. #5

    Padrão

    Saudações amigos,
    Eu acho que as rotas devem ser direcionadas para a rede da vpn e não para o ip público das máquinas 200.200.200.200 201.201.201.201.
    Por exemplo, eu uso openvpn, então com o openvpn ele cria o device tap0 então eu adiciono as rotas para essa rede que eu uso no tap0. A rede que eu uso entre as máquinas da vpn é 10.1.1.0/24. Atrás da do servidor 10.1.1.10 eu tenho a rede 192.168.10.0/24, sendo assim eu adiciono a rota
    Código :
    ip route add 192.168.10.0/24 via 10.1.1.10

    Eu não conheço especificamente o strongswan mas ele deve criar alguma interface virtual e as rotas devem ser adicionadas para a rede dessa interface, mesmo que seja uma conexão ppp.

    espero que não tenha ficado muito confuso... hehe,
    abraço

  6. #6

    Wink

    Oi pessoas,

    Obrigada pelas dicas... obrigada mesmo!

    Eu acabei reinstalando todo o linux e o StrongSwan e acabou funcionando!

    Devia ter alguma coisa errada nas configs ou até mesmo no sistema.

    Ah... vale como dica... eu aprendi no tapa... o StrongSwan faz todas as rotas e adiciona as regras de iptables.

    Para ele adicionar as rotas sozinho é só colocar leftsourceip=endereco_do_gateway_interno_da_vpn que ele adiciona as rotas com o iproute2

    Para ele adicionar as regras do iptables é só adicionar leftfirewall=yes

    "brigadinha" de novo!

    beijos!



  7. #7

    Thumbs up

    Legal, mais um serviço Linux para fazer conexões remotas.
    E mais um pacote para a gente aprender.
    Sinceramente, eu gosto muito do OpenVPN. Que serviço Linux legal de configurar.
    De qualquer forma, foi bom você ter repassado os seus conhecimentos.
    Um grande abraço. Sucessos e felicidades ..............