+ Responder ao Tópico



  1. #1

    Smile como acesso o mk externamente?

    gostaria mesmo de uma passo a passo pois, já tentei seguir alguns e não obtive sucesso, seria assim, colocar um ip, ou até mesmo um dominio no conect to do winbox e acessar o mk, não tenho a minima ideia como faço isso, já instalei e tudo funciona, já fiz algumas configurações tentei seguir o tutorial do cadastro do no-ip mais mesmo assim não funciona... se puderem me ajudar eu agradeceria por demais...


    a profissão em que os profissionais são mais solidários, sentimos prazer em ajudar o próximo...

    desde já agradeço!!!!

  2. #2

    Padrão

    Citação Postado originalmente por salodosistema Ver Post
    gostaria mesmo de uma passo a passo pois, já tentei seguir alguns e não obtive sucesso, seria assim, colocar um ip, ou até mesmo um dominio no conect to do winbox e acessar o mk, não tenho a minima ideia como faço isso, já instalei e tudo funciona, já fiz algumas configurações tentei seguir o tutorial do cadastro do no-ip mais mesmo assim não funciona... se puderem me ajudar eu agradeceria por demais...


    a profissão em que os profissionais são mais solidários, sentimos prazer em ajudar o próximo...

    desde já agradeço!!!!
    Bom dia,

    Vamos para o passo a passo

    Primeiro você entra no site Dynamic DNS >> www.changeip.org > How-To, clique em Sign Up e faça seu cadastro no changeip.
    Depois você conecta pelo winbox, vai em System/Scripts, clica no + vermelho e dê um nome para sua regra, qualquer um, e depois copie e cole o script abaixo:

    ------------------------------------

    :log info "DDNS: Begin"

    :global ddns-user "login cadastrado no changeip"
    :global ddns-pass "senha cadastrada no changeip"
    :global ddns-host "*1"
    :global ddns-interface "VELOX"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"

    -----------------------------------------------

    Lembre de trocar as partes em vermelho coonforme seu cadastro no changeip e sua interface (no meu caso a pppoe).
    Outra coisa, na linha onde você vê uma carinha, corrija para [: pick, sem o espaço entre os dois pontos e a palavra pick, caso não entenda, me avise que te mando por email.

    Depois, vai em System/Scheduler, clique no mais vermelho em nome, dê o mesmo nome que deu a sua regra do script, só para facilitar, em start data, coloque uma data para começar a executar o script automaticamente, ex: (Dec/06/2007), start time coloque a hora que vai começar e em interval coloque o tempo que intervalo que vc quer que ela repita, Ex: 01:00:00, assim o script vai executar de hora em hora, renovando o seu ip, em On Event coloque o mesmo nome que vc deu a seu script, ai tem que ser igual. Acredito que com esses passos deve funcionar, ahhh, parece que na nova versão do Mikrotik isso não está funcionando perfeitamente, não tenho certeza, foi o que ouvi falar.

    Bem, é isso, espero que ajude

    Abraços

    Edmar (ramde)



  3. #3

    Padrão

    Amigo Ramde, essas regras que vc postou acima, na prática fazem a atualização do IP a cada hora pelo que entendi. Mas só poderá funcinar corretamente se eu estiver fazendo PPPoE na interface de saída do MK correto ? No meu caso o MK trabalha atrás de um modem roteado e com isso a atualização vai meu ip privado ?? existe alguma forma dele enviar a atualização do IP válido ??
    Grato, Iron.

  4. #4

    Padrão

    Citação Postado originalmente por iron Ver Post
    Amigo Ramde, essas regras que vc postou acima, na prática fazem a atualização do IP a cada hora pelo que entendi. Mas só poderá funcinar corretamente se eu estiver fazendo PPPoE na interface de saída do MK correto ? No meu caso o MK trabalha atrás de um modem roteado e com isso a atualização vai meu ip privado ?? existe alguma forma dele enviar a atualização do IP válido ??
    Grato, Iron.

    Pois é, estou passando pelo mesmo problema, acredito, toda vez q o script atualiza pelo scheduler, verifico lá na conta do changeip que o ip fica 192.168.254.254... ai nao consogo pingar de fora.
    Alguem pode dar uma luz?



  5. #5

    Padrão

    Eu tambem uso modem roteado e o script que estou usando e que está funcionando é o seguinte:
    tool dns-update name=seudominio.changeip.net address=127.0.0.255 key-name=seu_username key="sua_senha"

    Obs.: no campo key, mantenha as aspas...

    Abraços

  6. #6

    Thumbs down tambem tenho essa duvida

    cara tirei esse mesmo script de um dos meus servidores que funciona normalmente esse script de acesso remoto ai coloquei em outro servidor meu mas não funciona de forma alguma o que posso fazer para que isso funcione.
    so para caracter de informação nesse local onde funciona tenho um modem dlink 500B com um ip liberado dentro dele um que vai diretamente para porta onde o script indica
    no outro servidor onde não esta funcionando meu modem e um speed touch 510 v6 e até fiz o esquema para liberar mas nunca funcionou como posso fazer isso dentro desse modem para funcionar o se precisa mesmo fazer isso para funcionar corretamente.



  7. #7

    Padrão

    Citação Postado originalmente por diegobtp Ver Post
    cara tirei esse mesmo script de um dos meus servidores que funciona normalmente esse script de acesso remoto ai coloquei em outro servidor meu mas não funciona de forma alguma o que posso fazer para que isso funcione.
    so para caracter de informação nesse local onde funciona tenho um modem dlink 500B com um ip liberado dentro dele um que vai diretamente para porta onde o script indica
    no outro servidor onde não esta funcionando meu modem e um speed touch 510 v6 e até fiz o esquema para liberar mas nunca funcionou como posso fazer isso dentro desse modem para funcionar o se precisa mesmo fazer isso para funcionar corretamente.
    Cara.. nunca usei este modem speedtouch... nao tem como vc testar com outro modem?
    Eu uso aqui o siemens 4200.. mto bom..
    Abs

  8. #8

    Padrão

    Amigos e como eu devo proceder usando um modem d-link 500G como rotiador para eu obter o acesso remoto ao mk ?



  9. #9

    Padrão

    Citação Postado originalmente por mauriciojmjr Ver Post
    Amigos e como eu devo proceder usando um modem d-link 500G como rotiador para eu obter o acesso remoto ao mk ?
    O processo é o mesmo...

  10. #10

    Unhappy Com modem ADSL EM ROUTER

    Cara uso modens com roteamento ativado....

    tem alguma coisa nesse script que possa ser mudado e evitar que ele pegue o IP inválido da minha rede local e pegue o IP público da Internet?



  11. #11

    Padrão

    Caro amigom,

    Rodei a linha de comando... conferi no change ip e ele atualizou. Pinguei o dominio do ddns e rspodneu com o ip do meu velox e antes respondia com o ip invlido da minha interface publica. Nao usei o aspas com vc pediu, vamos esperar pra ver.
    De antemao, muito obg pela contribuição. Parabens !

  12. #12

    Padrão

    Citação Postado originalmente por PTT Ver Post
    Caro amigom,

    Rodei a linha de comando... conferi no change ip e ele atualizou. Pinguei o dominio do ddns e rspodneu com o ip do meu velox e antes respondia com o ip invlido da minha interface publica. Nao usei o aspas com vc pediu, vamos esperar pra ver.
    De antemao, muito obg pela contribuição. Parabens !

    Ola, eu conseguir fazendo o seguinte, coloquei no modem o ip da rede de entrada do mk e a porta 8291 direcionando p/ este ip, depois coloquei um ddns dentro do modem, desta forma quando eu pingo de fora ele acessa, kriando um ip e depois eu entro no winbox pelo ddns ddnsmikrotik.no-ip.co no local do mac ou ip ele aceita de primeira... blz qualquer duvida entra no meu msn irosam @ hotma pois ele aki e de um colega... blz falow