• Vulnerabilidade no OpenSSL 1.0.x

    O especialista em segurança Georgi Guninski, apontou a ocorrência de uma falha no ramo 1.0.x do OpenSSL, que permite de forma potencial, que os servidores SSL possam comprometer seriamente a segurança de seus clientes. De maneira aparente, a falha em questão pode ser explorada pelo simples envio de um certificado criado em especial para este cliente, fazendo com que haja uma desalocação da memória a ser acessada na função ssl3_get_key_exchange ( SSL \ s3_clnt.c). De um modo habitual, isso faria com que houvesse apenas uma falha no aplicativo. Entretanto, ele pode potencialmente ser explorado para executar o código injetado.



    Guninski havia incluído um certificado e um flawed key para a recriação do problema, no relatório lançado sobre a lista de discussão Full Disclosure. No momento da realização de um teste utilizando a atual versão do Ubuntu (10.04) com OpenSSL 0.9.8k, um certificado pertencente a uma chave RSA de 4006 bits de extensão, produziu apenas um aviso de que houve falha na certificação. Como praticamente nenhuma das distribuições Linux utiliza OpenSSL 1.0.x, é bastante improvável que a falha ocasione maiores transtornos. Até o presente momento, nenhuma atualização foi liberada pelos desenvolvedores do OpenSSL, mas a ocorrência já está sendo abordada em sua lista de discussão.


    Saiba Mais:

    [1] OpenSSL: http://www.openssl.org/news/
    [2] Full-Disclosure: http://archives.neohapsis.com/archiv...0-08/0085.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L