• Vulnerabilidade Crítica no VLC

    O VLC Media Player inclui um decodificador para o formato CDG que é raramente utilizado, e isso tem causado duas vulnerabilidades críticas de corrupção de pilha. Utilizando o VLC para reproduzir o vídeo manipulado neste formato, consequentemente ocasionará a corrupção de pilha, o que poderia ser explorado para injetar e executar códigos maliciosos. O bug já foi eliminado no repositório correspondente, mas não foi eliminado nos binários oficiais do media player VLC. Um patch (código-fonte) para o VLC na versão 1.1.5 está disponível a partir do Git.

    Desde que o código do decodificador sofreu apenas pequenas alterações já nas versões anteriores do VLC, o patch poderá ser utilizado para corrigir a vulnerabilidade nas versões anteriores à 1.1.5.


    Saiba Mais:

    [1] VLC: http://www.videolan.org/vlc/
    [2] Git: http://git.videolan.org/?p=vlc.git;a...4fd9fc351b4aab

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L