• RubyGems 1.5.0 com Suporte à Ruby 1.9.2

    RubyGems, o popular gerenciador de pacotes do Ruby e que se tornou o gerenciador de pacotes oficial no Ruby 1.9, foi atualizado para a versão 1.5.0. A atualização surge um mês após o lançamento do RubyGems 1.4.0, lançado em agosto 2010, que não ofereceu suporte ao Ruby 1.9.2. A nova versão permite agora que os usuários do Ruby 1.9.2 atualizem para a última versão do gerenciador.

    A atualização também considera a adição de ganchos pós-compilação que são capazes de anular as instalações do gem, um arquivo Gem.find_files 40% mais rápido para o Ruby 1.9, e documentação atualizada que abrange o Ruby 1.9. Há, de acordo com RubyInside, alguma incompatibilidade entre RubyGems 1.5 e Bundler que deverá ser corrigida "nas próximas 24 horas". Para atualizar para RubyGems 1.5.0 sobre as instalações existentes, é necessário executar gem update --system. Caso contrário, a nova versão pode ser baixado a partir do site RubyGems.org.


    Saiba Mais:

    [1] RubyGems 1.5: http://blog.segment7.net/2011/01/31/rubygems-1-5
    [2] Download RubyGems 1.5: https://rubygems.org/pages/download

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L