• Vulnerabilidade Crítica Detectada no IrfanView

    O plug-in para o popular visualizador de imagens IrfanView, está sendo atualmente disponibilizado através de uma versão vulnerável do FlashPix. O código contém uma vulnerabilidade crítica, que poderia ser explorada por um atacante para infectar um sistema com código malicioso. Essa brecha de segurança é causada devido a um buffer overflow. Para que a ação seja bem sucedida, um atacante precisa obter um aplicativo que abra uma imagem no formato especialmente criado para a finalidade maliciosa. Dessa forma, ele poderá conseguir o código a ser executado.



    Falha Crítica no IrfanView Poderia Causar um Buffer Overflow


    Evidentemente, este é um formato de arquivo relativamente raro, que não pode ser aberto de forma deliberada. Porém, a abertura do arquivo também pode ocorrer inconscientemente; por exemplo, quando se olha para uma pasta cheia de imagens e faz uma busca de seus thumbnails com IrfanView. Diante do problema ocorrido, houve a correção do mesmo na versão 4.34 do pacote de plug-in, mas a reinstalação deve ser feita manualmente.

    A diferença foi descoberta pelo pesquisador de segurança Francis Provencher, que informou (de forma confidencial) a Secunia. Desde então, ele lançou uma prova de conceito, o que significa que os usuários do IrfanView que instalaram o pacote de plugin, devem atualizar o mais rápido possível para a versão de manutenção. Vale lembrar que exatamente há um mês, um problema semelhante no visualizador de imagens XnView também foi corrigido.


    Saiba Mais:

    [1] Critical Vulnerability in IrfanView http://www.h-online.com/security/new...n-1539532.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L