• jQuery 1.8.1: Compatibilidade para Pseudo-Selectors Personalizados

    No recente lançamento 1.8.1 do jQuery, os desenvolvedores do projeto abordaram mais de 30 problemas encontrados na versão 1.8.0 da biblioteca JavaScript, no início deste mês de agosto. No jQuery 1.8, a velha API para criar pseudo-selectors personalizados foi interrompida pelos desenvolvedores, e uma nova API foi introduzida. Mas a partir do jQuery 1.8.1 em diante, a API vai oferecer a compatibilidade necessária. A atualização inclui uma solução de compatibilidade que permitirá código suficiente para trabalhar com todas as versões do motor selector SizzleCSS JavaScript; demais informações sobre isso podem ser encontrados na nova documentação oficial do Sizzle.



    Versão 1.8.1 do jQuery apresenta solução compatível para interação com o SizzleCSS


    Nessa sequência de mudanças e implementações, os desenvolvedores também aconselham os usuários a não usar o modo Quirks porque "jQuery nunca apoiou modo Quirks e não realiza qualquer tipo de testes com ele. Isso pode afetar os valores como "window").height(). Além disso, eles recomendam que os usuários utilizem a nova versão com jQuery UI 1.8.23 e jQuery Mobile 1.1.1 ou versão posterior, para que haja melhor compatibilidade.


    Saiba Mais:

    [1] Heise On-line http://www.h-online.com/open/news/it...s-1696774.html

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L