• Dados Manipulados Ocasionam Falha em Servidores BIND DNS

    Um Security Advisory (comunicado de segurança) a partir do Centro Nacional do CERT na Áustria, avisa que o servidor gratuito de DNS BIND, que é mantido pelo Internet Systems Consortium (ISC), contém uma vulnerabilidade de segurança que permite que atacantes possam travá-lo usando registros de dados especialmente criados. O ISC diz que registros de recursos com campos RDATA que excedam 65.535 bytes ocasionariam falha no name server de domínio na próxima vez que este registro fosse consultado. As seguintes versões do BIND são afetados:


    BIND 9.0.x para 9.6.x
    BIND 9.4-ESV para 9,4-ESV-R5-P1
    BIND 9.6-ESV para 9,6-ESV-R7-P2
    BIND 9.7.0 a 9.7.6-P2
    BIND 9.8.0 a 9.8.3-P2
    BIND 9.9.0 a 9.9.1-P2

    Por causa desse transtorno, o ISC recomenda que os usuários atualizem para uma das versões atuais - 9.7.7, 9.7.6-P3, 9.6-ESV-R8, 9.6-ESV-R7-P3, 9.8.4, 9.8.3-P3, 9.9.2 ou 9.9.1-P3 - o mais rapidamente possível.




    CERT alerta para problemas sérios em servidores BIND DNS e pede que usuários façam as devidas atualizações

    O CERT explica que, "selando" um servidor em sua parte externa não é o suficiente para protegê-lo contra um possível ataque. Aparentemente, uma consulta de name server pode, por exemplo, ser desencadeada por um e-mail, fazendo com que o servidor carregue o registro especialmente criado. Porém, não está claro se esta falha só pode provocar problemas no servidor ou se ela também pode ser explorada para injetar software malicioso.


    Saiba Mais:

    [1] Heise On-line http://www.h-online.com/security/new...h-1708087.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L