• ActiveMQ 5.7.0 Suporta Java 7

    A versão 5.7.0 do servidor de mensagens de código aberto Apache ActiveMQ foi lançada com correções para cerca de 200 problemas, além de diversas melhorias em todo o software. Uma das mudanças mais notáveis ​​na nova versão é a implementação de suporte para Java 7. Enquanto o ActiveMQ ainda tem sua construção feita com a utilização do JDK 6, ele foi testado para trabalhar com o JDK 7. O suporte para a versão mais recente do Java foi necessário porque o ActiveMQ agora utiliza o Apache Camel 2.10, que também adicionou suporte a Java 7.




    A mais recente atualização para ActiveMQ também introduz um suporte para Secure WebSockets, o que significa que os usuários podem agora conectar com segurança diretamente para o corretor de seu navegador. As alterações foram feitas para Pluggable Store Locks, e incluem um novo banco de dados (lease-based). Os seus desenvolvedores dizem que devido a essas novas incorporações, será possível realizar um trabalho muito melhor para cenários JDBC slave master.


    Saiba Mais:


    [1] Apache ActiveMQ https://activemq.apache.org/activemq-570-release.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L