• JRuby 1.7.0 Compatível com Ruby 1.9 por Padrão

    Com o lançamento do JRuby 1.7.0, a implementação já passou a comportar-se como o Ruby 1.9.3 (por padrão). A nova edição da implementação Java baseada na máquina virtual de Ruby, também promete trazer melhorias de desempenho em aplicativos de alto pode concorrencial, graças a um ano e meio de desenvolvimento que tem melhorado todos os subsistemas da linguagem. Os usuários ainda têm a opção de usar o "-1,8"(opção de linha de comando para o Ruby 1.8.7), no modo de compatibilidade.



    JRuby apresenta estabilidade, podendo ser utilizado para hospedagem de aplicativos de produção

    O lançamento do JRuby 1.7 é a primeira versão completa, já que os desenvolvedores do núcleo passaram da EngineYard para a Red Hat , no mês de maio desse ano. Os desenvolvedores reassaltaram que existem partes do suporte ao Ruby 1.9 que ainda estão faltando, como a 1.9.3 do Ruby Ripper Parser Ruby. Entretanto, eles sentem que estão "em um ponto estável", onde as pessoas podem utilizar o JRuby 1.9 para hospedar aplicativos de produção. Dito isso, eles também planejam estar produzindo atualizações pontuais de 1.7 a cada 2 a 3 semanas, para uma previsão sobre como corrigir os problemas e preencher as partes que faltam nas bibliotecas Ruby 1.9.


    Saiba Mais:

    [1] Heise On-line http://www.h-online.com/open/news/it...y-1734713.html

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L