• Correção de Brechas de Segurança no MySQL 5.1.47

    A próxima versão do MySQL [2] disponibilizada pela Oracle, a 5.1.47, virá com vários patches de segurança importantes. O Changelog aponta que os desenvolvedores fecharam três brechas de segurança que permitiam os atacantes de causarem uma quebra do sistema (system crash), obter acesso não-autorizado a base de dados ou, no pior caso, injetar código arbitrário e executá-lo no servidor. Mas os desenvolvedores não mencionam qual ou quais versões estariam sendo afetadas por essas brechas.


    Ainda de acordo com o Changelog, a primeira falha é causada por um argumento de nome de tabela não sendo suficientemente verificado pelo comando COM_FIELD_LIST, o que permitiria no MySQL 5.1 e superior, que os atacantes pudessem ter privilégios de DELETE e SELECT para uma tabela, para assim, ganhar acesso não-autorizado de leitura e escrita para outras tabelas. A segunda brecha permite que nomes longos de tabelas possam causar um estouro de buffer (buffer overflow) que pode ser explorado por qualquer usuário autenticado, permitindo que o mesmo possa injetar código malicioso. A terceira brecha pode ser explorada ao enviar pacotes de rede que excedam o tamanho máximo de pacotes para o servidor, o que resulta em uma quebra do próprio servidor (server crash).


    Saiba Mais:

    [1] Heise Online: http://www.h-online.com/security/new...s-1000709.html
    [2] MySQL: http://www.mysql.com/

    Sobre o Autor: tuxdahora


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L