Ver Feed RSS

underwanderson

Fazer Web proxy Básico

Avaliação: 4 votos, 2,00 média.
Bom para fazer uma rede navegar com cache proxy temos que configurar um web proxy, no mikrotik temos que ir em / ip web proxy settings na aba geral em:
  • src address: deixe em branco
  • port: coloque a porta de sua preferencia 3128(padrão) ou 3127
  • hostname: deixe como esta "proxy"
  • transparent proxy: marque esta caixa
  • parent proxy: só se for fazer cache em servidor dedicado
  • parent proxy port: escolha a porta do seu proxy parent
  • cache administrator: deixe a caixa marcada e coloque o nome que quiser, vai ser a identificação do seu proxy quando da falta de link ou uma pagina não encontrada, pode ser uma informação simples ou um email ou simplesmente deixar como esta o padrão.
  • maximum object size: coloque o tamanho maximo de um objeto a ser gravado no seu cache, mas coloque sempre na forma de bits ex.: 20mega sempre multiplique o valor inteiro que quer usar por 1024 que dara o valor em bit 20*1024=20480 então o tamanho maximo a ser gravado em bit será "20480 kib".
  • cache driver: para esolher qual o driver sera feito o cache de pagina do proxy, para que tem dois hd's um para o mikrotik e outro dedicado para o cache por exemplo, se tiver somente um hd na maquina so aparecerá system.
  • maximum cache size: tamanho maximo do hd a ser utilizado se o hd é de 80Gb por exemplo faça a mesma conta explicada acima mas nunca calcule este valor exato pois sabemos que o hd nunca da 80Gb exatos e ainda mais temos o mikrotik ja instalado entao coloque pelo menos 75Gb o que daria 75000*1024=76800000, lembrando que por estarmos falando em Gigabite temos que calcular com três Zeros a mais se não ficaria 75mega OK?
  • maximum RAM cache size: especifique o tamanho da memoria a ser utilizada para um cache temporario, lembrando que o mikrotik so reconhece 860Mb de memoria no máximo, então não adianta colocar uma máquina com 2Mb de memória que não vai nem fazer cocegas no mikrotik, e a mesma coisa é o calculo que tem que ser feito só que agora em mega bit.
Até aqui tudo bem, clique no botão ao lado "enable" e o cache será criado.

Agora temos que implementar algumas regras na aba "access" aqui você libera ou bloqueia acesso da rede local no cache.
/ ip web-proxy access
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" disabled=no
add src-address=IP DA SUA REDE LOCAL0/24 action=allow comment="" disabled=no
add action=deny comment="" disabled=no
=====================================
na aba cache é onde você libera ou bloqueia gravações no no cache, aqui estamos bloqueando gravações no cache de páginas dinamicas (páginas que são atualizadas constantemente as vezes de hora em hora) como sites bancarios e de jornalismo como o globo.com
/ ip web-proxy cache
add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages" disabled=no
add url="https://" action=deny comment="no cache dynamic https pages" disabled=no
========================================
e na aba direct onde especifica o que passa direto sem passar pelo cache web proxy
todas essas configurações pode ser feito na forma de endereços url ou ip.

Pronto este é o básico do basico pra usar o web proxy, mas para que ele seja utilizado por maquinas clientes na solicitação de paginas.

Agora temos que direcionar os clientes para o nosso proxy já que foi liberado o acesso na aba "access". Vamos em:
/ip firewall nat
e coloque a seguinte regra para os clientes passarem primeiro pelo cache se a pagina ou objeto ja tiver sido aberto por alguém ele nem sai pra internet do contrário ele será o primeiro a pegar tal informação que depois será utilizado por todos na rede via web proxy.
/ ip firewall nat
add chain=dstnat src-address=IP DA SUA REDE LOCAL.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3128 comment="redirecionamento porta 80 para webproxy 3128" disabled=no

Mas não podemos esquecer que se utilizamos ip fixo ou mesmo ip dinâmico mas que demoramos a renova-lo reiniciando o servidor temos que bloquear o acesso ao nosso proxy externamente, ou seja se deixarmos desbloqueado este acesso um dia mais cedo ou mais tarde uma maquina ou servidor que esta na internet irá acessar nosso proxy como se fosse um proxy grátis e será um turbilhão de acesso que o mesmo chega a travar, vamos em:
/ ip firewall filter
add chain=input in-interface=INTERNET protocol=tcp dst-port=3128 action=drop comment="BLOQUEIO DO PROXY EXTERNO" disabled=no
Agora sim está pronto o Básico para ser gravado o cache de página e começarmos fazer o controle de bloqueio e liberação dos acessos ao sites que quisermos via proxy.

Se eu esqueci de algo ou falei besteira em algum momento é a hora de todos ajudarem.
obrigado

Atualizado 22-10-2009 em 12:59 por underwanderson (ortografia)

Categorias
Não Categorizado

Comentários

  1. Avatar de 1929
    Bem didático. Algumas coisas que eu havia feito e sem saber o porquê, agora entendi.
    Pois alguns tutoriais não são comentados o que faz que alguém auto didata não entenda o motivo de usar determinadas configurações.
    Eu vou até revisar minhas regras destes dois artigos seus para conferir se está tudo redondinho mesmo.

    Muito bom.
  2. Avatar de Gustavinho
    Bacana....uma coisa que aqui faço diferente é na regra de direncionamento para o proxy, onde ao invés de eu marcar o IP da faixa de rede, eu deixo em branco.

    Pois aqui tenho varias redes distintas.

    / ip firewall nat
    add chain=dstnat src-address=IP DA SUA REDE LOCAL.0/24 protocol=tcp dst-port=80 action=redirect to-ports=3128 comment="redirecionamento porta 80 para webproxy 3128" disabled=no
  3. Avatar de samygon
    Cara, meu s parabéns
    estou tentando montar um servidor com microtik e vejo na net que as pessoas ensinam algumas coisas mas nunca dizem pra que serve fica ate dificil de aprender a mexer no microtik somente lendo post, mas da forma que você explicou, eu mesmo sem saber programação e nada de linux e microtik eu entendi (agora sim entendi) pra que serve o webproxy e quais suas vantagens.

    cara obrigado mesmo, isso ja me ajudou a criar um web proxy pra minha rede (que é bem pequena) apesar que outros recursos ainda não peguei direito.

    agora sem querer abusar (mas ja abusando. rssss) será que vc não teria um tutorial de tipos de servidores pra que serve cada um e como configura-los. é que eu tenho uma rede ainda dsl velox e devido a estar desempregado passei a distribuir mas se eu tiver um crescimento legal, ja estava pesquisando como conseguir um link dedicado. mas pra isso eu teria que ter um servidor e entender como funciona. minha rede é cabeada somente, mas pretendo mais a frente colocar por wireless.

    Mas esse pequeno tutorial estara impresso com certeza pra que eu possa estudar mais.

    Obs.: queria fazer um curso de linux e microtik, mas pra mim ainda está saindo muito caro.
  4. Avatar de underwanderson
    Citação Postado originalmente por samygon
    Cara, meu s parabéns
    estou tentando montar um servidor com microtik e vejo na net que as pessoas ensinam algumas coisas mas nunca dizem pra que serve fica ate dificil de aprender a mexer no microtik somente lendo post, mas da forma que você explicou, eu mesmo sem saber programação e nada de linux e microtik eu entendi (agora sim entendi) pra que serve o webproxy e quais suas vantagens.

    cara obrigado mesmo, isso ja me ajudou a criar um web proxy pra minha rede (que é bem pequena) apesar que outros recursos ainda não peguei direito.

    agora sem querer abusar (mas ja abusando. rssss) será que vc não teria um tutorial de tipos de servidores pra que serve cada um e como configura-los. é que eu tenho uma rede ainda dsl velox e devido a estar desempregado passei a distribuir mas se eu tiver um crescimento legal, ja estava pesquisando como conseguir um link dedicado. mas pra isso eu teria que ter um servidor e entender como funciona. minha rede é cabeada somente, mas pretendo mais a frente colocar por wireless.

    Mas esse pequeno tutorial estara impresso com certeza pra que eu possa estudar mais.

    Obs.: queria fazer um curso de linux e microtik, mas pra mim ainda está saindo muito caro.
    Obrigado por visitar o Blog,
    Sim é possível lançar mão dos muitos tipos de servidores existentes mas não todos pois alguns ainda não conheço e precisaria de muito tempo para descrever as varias formas de configuração.
    Mas vou postar mais pra frente os tipos existentes e pra que uso ele foi desenvolvido logo que descrever algumas das partes de configuração do mikrotik, pode ser que até lá você já tenha mais conhecimento do que terá aqui postado mas servirá para os novatos da mesma forma que serviria para você hoje, mas como todos sabem informação nunca se perde no tempo e sim defasa com tantas atualizações em nossa volta.
    obrigado

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L