Ver Feed RSS

Brain Stress

Script para verificar ACK - nova versão

Avaliação: 2 votos, 5,00 média.
Caros,

Resolvi desenvolver novamente um script para controlar o ACK nas interfaces wireless, veja o que mudou:

- Codigo totalmente reescrito.
- Script varre TODAS as interfaces do AP que estão em modo ap-bridge, não sendo mais necessário criar um script para cada interface.
- Permite desconectar ou apenas listar no log os clientes que estão acima do ACK limite.
- Testado nas versões 3.25 até 3.30 e funcionou EM TODAS !!!! provavelmente funciona em todas as versões 3.X

Para instalar, basta ir em SYSTEM -> SCRIPTS e criar um novo script com o código !! Por padrão, o script não vai derrubar os clientes, execute assim para ver se o resultado é o esperado, depois altere a configuração a seu gosto.

Depois crie um SCHEDULE para executar automaticamente !!

Sugestões ? postem nos comentários !!


codigo do script (também anexado no post arquivo com o código)

Código :
#Script ACK-Check v0.1
#
#Lista as estacoes que estao com ACK acima do limite com opcao para desconecta-las
#
# Autor: Alexandre Jeronimo Correa <ajcorrea@gmail.com>
# 20/11/2009 - 01:03am
#
#Instrucoes de uso:
#     -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
#     -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
#         configurar a variavel cut para 1, tendo certeza que o script esta OK.
#     -- O script pode ser executado pelo botao "run script" ou via linha de comando.
#        "/ system script run <nome do script>
#     -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
#     -- Testado nas versoes 3.25 até 3.30
#
#Informacoes:
#
#Variavel ack -> deve ter o valor do ack MAXIMO permitido.
#Variavel cut ->  deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
##################################################################
#Configuracoes das variaveis
:local ack 50;
:local cut 0;
 
############ Script - NAO ALTERAR #####################################
:local mac "";
:local uack "";
:local removido "";
:log warning ("[ackchk] Procurando clientes com ACK maior que " . $ack);
#pega a lista de interfaces AP wireless ativas, e que tenham ack dinamico
:foreach i in=[ / interface wireless find mode="ap-bridge" ack-timeout="dynamic" running] do={
          :local intname [ / interface wireless get $i name ];
          :log warning ("     Interface: " . $intname);
          :foreach x in=[/interface wireless registration-table find interface=$intname] do={
                    :set uack [/interface wireless registration-table get $x ack-timeout];
                    :set removido "";
                    :if ($uack > $ack) do={
                         :set mac [ / interface wireless registration-table get $x mac-address];                         
                         :if ($cut = 1) do= {
                              :set removido " removido...";
                              / interface wireless registration-table remove $x;
                         };
                    :log warning ("          mac: " . $mac . "@" . $intname . " [" . $uack . "]" . $removido);
                    };                    
          };
};
############ FIM #####################################
Miniaturas de Anexos Arquivos Anexos
Tags: ack, mikrotik, script
Categorias
mikrotik , Artigos , Noticias , Dicas

Comentários

Página 1 de 2 12 ÚltimoÚltimo
  1. Avatar de kitorkim
    Valeu, Alexandre, está funcionando direitinho, muito obrigado.
  2. Avatar de rogeriodj
    Muito bom amigo!!
  3. Avatar de Não Registrado
    Muito bom script... tem como postar num forum que participo sobre mikrotik: [url]http://www.mundomikrotik.com.br[/url] ?
    lembro de ter visto um cara perguntando por isso por lá.

    Mauricio
  4. Avatar de 14735
    alguem testou na v4.x?
  5. Avatar de SempreOnLine
    system scheduler
    add name="reboot" on-event=reboot start-date=aug/25/2009 start-time=05:00:00 interval=1d comment="" disabled=no
    add name="backup_dia" on-event=backup start-date=aug/25/2009 start-time=04:55:00 interval=1d comment="" disabled=no
    add name="queue2_sup_max" on-event=ativa_max start-date=aug/24/2009 start-time=08:30:00 interval=1d comment="" disabled=no
    add name="queue3_max_med" on-event=ativa_med start-date=aug/24/2009 start-time=09:10:00 interval=1d comment="" disabled=no
    add name="queue5_min_med" on-event=desativa_min start-date=aug/24/2009 start-time=00:30:00 interval=1d comment="" \
    disabled=no
    add name="queue51_BO" on-event=desativa_min start-date=aug/24/2009 start-time=15:00:00 interval=1d comment="" disabled=no
    add name="queue1_max_sup" on-event=desativa_max start-date=aug/24/2009 start-time=02:30:00 interval=1d comment="" \
    disabled=no
    add name="queue4_med_min" on-event=ativa_min start-date=aug/24/2009 start-time=11:00:00 interval=1d comment="" disabled=no
    add name="removehosts" on-event=removeallhostsP start-date=aug/25/2009 start-time=05:05:00 interval=10m comment="" \
    disabled=no
    add name="queue52_BO" on-event=ativa_min start-date=aug/24/2009 start-time=16:30:00 interval=1d comment="" disabled=no
    add name="queue10_med_max" on-event=desativa_med start-date=aug/24/2009 start-time=01:30:00 interval=1d comment="" \
    disabled=no
  6. Avatar de magnusrk8
    A outra versão já funcionava bem, esta mato a pau, muito bom. Valeu..
  7. Avatar de multlink
    uso a 4.2 e está normal nela valeu!
  8. Avatar de william
    aqui funcionou normal para versão 4.1, tenho uma duvida como que faço o Scheduler, pois fiz aqui e ele não roda o script.
    Segue abaixo como que fiz.

    no script coloquei o nemo de ack

    e em Scheduler coloquei assim: /system script run ack

    gostaria de saber a onde errei.
  9. Avatar de alexandrecorrea
    Código :
     / system script run ack

    NAO sei se estou certo , mas pode ser que um espaço depois da / !!

    vc definiu o intervalo de execução ?


    Citação Postado originalmente por william
    aqui funcionou normal para versão 4.1, tenho uma duvida como que faço o Scheduler, pois fiz aqui e ele não roda o script.
    Segue abaixo como que fiz.

    no script coloquei o nemo de ack

    e em Scheduler coloquei assim: /system script run ack

    gostaria de saber a onde errei.
  10. Avatar de william
    Ok Deu certo estava faltando tbm abiliar as opções do policy.
    Grato
  11. Avatar de kurtenet
    Parabens Alaxandre fico otimo, vlw
  12. Avatar de j34nsch
    parabéns amigo testado e aprovado, seria possivel modificar o arquivo para que ele guarde no file do mk um arquivo com as informações do cliente que esta com ack alto? t+ amigo valeu
  13. Avatar de UltraFox
    Seria interessante colocar para listar o nome do ACESS LIST "COMENTARIO" e ou HOST das estação clientes. Assim ficaria mais facil de achar os clientes com problema !
  14. Avatar de frednks
    gostaria de saber se deixo setado 50 nas interfaces, ou deixo dynamic??
    logico, junto com o script!

    a duvida eh, coloco o script pra rodar, de acordo q vc passou, porem em cada interface, eu deixo o ACK em dinamic?

    outra coisa, percebi aqui no meu mkt, q a maioria conecta em 30, porem alguns sao mais altos, nao seria interessante entao eu setar o script aqui em 30??? ou vc recomenda 50 msm??

    abracos
  15. Avatar de Nks
    gostaria de saber se deixo setado 50 nas interfaces, ou deixo dynamic??
    logico, junto com o script!
    a duvida eh, coloco o script pra rodar, de acordo q vc passou, porem em cada interface, eu deixo o ACK em dinamic?
    outra coisa, percebi aqui no meu mkt, q a maioria conecta em 30, porem alguns sao mais altos, nao seria interessante entao eu setar o script aqui em 30??? ou vc recomenda 50 msm??
    abracos
  16. Avatar de grandmaster
    Muito bom o script.
    ---
    Renato de Castro Henriques
    CobiT Foundation 4.1 Certified ID: 90391725
    Renato de Castro Henriques
  17. Avatar de ricardofjayme
    Pessoal,
    Já estou usando aqui na v 4.1 e tá funcionando sem problemas!
    Estive pensando se não seria possível adptar este script para fazer com os clientes com sinal abaixo de um determinado valor tb fossem desconectados... o que vocês acham? Como ainda não conheço a LP do Mk, vou dar uma analisada no excelente script do Alexandre e fazer uns testes aqui!
  18. Avatar de netosdr
    Excelente contribuição.
  19. Avatar de Kandango
    Funcionou blz no 4.2. Obrigado pela contribuição.
  20. Avatar de 14735
    na versao 3.22 nao deu certo :/
    quando da rum script no log aparece [ackchk] Procurando clientes com ACK maior que 35
    somente isso e nao derruba quem esta com ACK alto
    OBS: ja coloquei no cut o valor 1.
    alguem mais tentou na versao 3.22?
  21. Avatar de alexandrecorrea
    a interface esta com ack dinamico ? tem alguem com ack acima de 35 ?

    se ele mostrou a mensagem e nao removeu ninguem.. o script esta funcionando (sendo executado corretamente) .. mas nao tem cliente nas especificações q voce configurou !!

    Citação Postado originalmente por 14735
    na versao 3.22 nao deu certo :/
    quando da rum script no log aparece [ackchk] Procurando clientes com ACK maior que 35
    somente isso e nao derruba quem esta com ACK alto
    OBS: ja coloquei no cut o valor 1.
    alguem mais tentou na versao 3.22?
  22. Avatar de cdcm
    existem alguma forma de criar um script automatico? pq tenho clientes com 6km q so funciona com ack em media de 160 us.
    grato.
  23. Avatar de alexandrecorrea
    o script ja é automatico... basta setar o ack maximo.. ele corta o que estiver acima..


    Citação Postado originalmente por cdcm
    existem alguma forma de criar um script automatico? pq tenho clientes com 6km q so funciona com ack em media de 160 us.
    grato.
  24. Avatar de cdcm
    desculpa Alexandre me expressei errado. queria determinar um valor de ack para cada cliente pelo mikrotik. pq esse cliente q esta a 6km fica desconectando, mesmo estando com sinal bom. por isso perguntei se tem algum script q tetermine um valor fixo. esse cliente usa placa pci. e ele nao quer compra um roteador, ai teria como setar la o ack fixo.
  25. Avatar de alexandrecorrea
    nao adianta os clientes ficarem com ack 30.. mas tem um bendito com 160... entao o ack do cartao fica em 160 ...

    o que voce deve fazer eh colocar um router ou antena de maior ganho... para resolver este problema..

    voce pode ter problemas futuros com isso..

    Citação Postado originalmente por cdcm
    desculpa Alexandre me expressei errado. queria determinar um valor de ack para cada cliente pelo mikrotik. pq esse cliente q esta a 6km fica desconectando, mesmo estando com sinal bom. por isso perguntei se tem algum script q tetermine um valor fixo. esse cliente usa placa pci. e ele nao quer compra um roteador, ai teria como setar la o ack fixo.
  26. Avatar de cdcm
    Citação Postado originalmente por alexandrecorrea
    nao adianta os clientes ficarem com ack 30.. mas tem um bendito com 160... entao o ack do cartao fica em 160 ...

    o que voce deve fazer eh colocar um router ou antena de maior ganho... para resolver este problema..

    voce pode ter problemas futuros com isso..

    obrigado.
    vo colocar o router mesmo.
  27. Avatar de 14735
    Citação Postado originalmente por alexandrecorrea
    a interface esta com ack dinamico ? tem alguem com ack acima de 35 ?

    se ele mostrou a mensagem e nao removeu ninguem.. o script esta funcionando (sendo executado corretamente) .. mas nao tem cliente nas especificações q voce configurou !!
    Funcionou na versao 3.22 tbm aprovado^^
    Atualizado 22-02-2010 em 22:11 por 14735
  28. Avatar de jmathayde
    Me dis uma coisa para fazer com que o cliente com ack alto naoconecte como faço ?
  29. Avatar de eduardi
    boas , funciona bem, obrigado.

    2 questões

    1- depois de derrubar o cliente, quanto tempo fica derrubado?
    2- qual o intervalo ideal , para rodar o script no scheduler?
  30. Avatar de jwjunior
    Citação Postado originalmente por alexandrecorrea
    o script ja é automatico... basta setar o ack maximo.. ele corta o que estiver acima..
    preciso de ajuda tenho 3 clientes bem proximos usando clinte ap com o sinal -50 so que o ack ta em 240 oque pode ser?
Página 1 de 2 12 ÚltimoÚltimo

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L