Ver Feed RSS

minelli

Script´s - Amarrar MAC + IP + PPPoe + HotSpot + DHCP + Estático

Avalie este Post de Blog
Pessoal com esse script vocês poderão Amarrar IP+MAC e torná-lo estático usando IP+MAC, PPPoe, HotSpot e DHCP no Mikrotik.

Script AutoMac para IP+MAC, PPPoe, HotSpot, DHCP e Estático:

AutoMac_HotSpot
Código :
##################################################
## AutoMac HotSpot By Int21 - No Right Reserved ##
##==============================================##
# Nome: AutoMac_HotSpot                          #
# Objetivo: Capturar IP + Mac do cliente e       #
# deixa-lo fixo para que não mude.               #
# Agendamento: Use a cada 30 segundos            #
##################################################
 
:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac-address];
/ip hotspot user set $user comment=$user mac=$mac address=$address;
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};
}


AutoMac_PPPoe
Código :
##################################################
## Automac_PPPoe By Rodriog Minelli.´.          ##
##==============================================##
# Nome: AutoMac_PPPoe                            #
# Objetivo: Capturar IP + Mac do cliente e       #
# deixa-lo fixo para que não mude.               #
# Agendamento: Use a cada 30 segundos            #
##################################################
:foreach x in=[/ppp active find] do={
:global address [/ppp active get $x address];
:global user [/ppp active get $x name];
:global mac [/ppp active get $x caller-id];
/ppp secret set $user comment=$user caller-id=$mac address=$address;
:foreach xy in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $xy};
}


AutoMac_IP+MAC+DHCP
Código :
##################################################
## Automac_IP+MAC+DHCP By Rodriog Minelli.´.    ##
##==============================================##
# Nome: Automac_IP+MAC+DHCP                      #
# Objetivo: Capturar IP + Mac do cliente e       #
# deixa-lo fixo para que não mude.               #
# Agendamento: Use a cada 30 segundos            #
##################################################
:foreach ia in=[/ip arp find] do={
:global address [/ip arp get $ia address];
:global mac [/ip arp get $ia mac-address];
:foreach ix in=[/ip arp find] do={/ip arp make-static $ix};
:foreach iz in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $iz};
}


AutoMac_IP+MAC
Código :
##################################################
## Automac_IP+MAC By Rodriog Minelli.´.         ##
##==============================================##
# Nome: Automac_IP+MAC                           #
# Objetivo: Capturar IP + Mac do cliente e       #
# deixa-lo fixo para que não mude.               #
# Agendamento: Use a cada 30 segundos            #
##################################################
:foreach za in=[/ip arp find] do={
:global address [/ip arp get $za address];
:global mac [/ip arp get $za mac-address];
:foreach zx in=[/ip arp find] do={/ip arp make-static $zx};
}


Script´s:
Criar um script em /system scripts com o nome .
Para HotSpot:
Nome:
Código :
AutoMac_HotSpot
para o primeiro exemplo.


Para PPPoe:
Nome:
Código :
AutoMac_PPPoe
para o segundo exemplo.


Criar um script em /system scripts com o
Para IP+MAC+DHCP:
Nome:
Código :
AutoMac_IP+MAC+DHCP
para o terceiro exemplo.


Criar um script em /system scripts com o
Para IP+MAC:
Nome:
Código :
AutoMac_IP+MAC
para o quarto exemplo.

Copiar o conteúdo do script dentro do script criado no mikrotik.


Agendamento:
Criar o agendamento em /system scheduler com o

Para HotSpot:
Nome:
Código :
AutoMac_HotSpot
Inteval:
Código :
00:00:30
On Event:
Código :
/system script run AutoMac_HotSpot


Para PPPoe:
Nome:
Código :
AutoMac_PPPoe
Inteval:
Código :
00:00:30
On Event:
Código :
/system script run AutoMac_PPPoe


Para IP+MAC+DHCP:
Nome:
Código :
AutoMac_IP+MAC+DHCP
Inteval:
Código :
00:00:30
On Event:
Código :
/system script run AutoMac_IP+MAC+DHCP


Para IP+MAC:
Nome:
Código :
AutoMac_IP+MAC
Inteval:
Código :
00:00:30
On Event:
Código :
/system script run AutoMac_IP+MAC

Feito isso já deverá funcionar.
Matéria retirada do post do Celso "Int21" e adaptada aos outros tipos de uso no Mikrotik.

Obs.: Foi útil agradeça aos que contribuíram com informações sobre os script´s.
Obs1.: Gostaria de lembrar que somente por motivo de estética não foi incluído o "No Right Reserved" sendo assim segue-se o padrão e peço que se alterarem o script mantenham os créditos.
Obs2.: Script testado em versões 4.x e 5.x
Obs3.: Em algumas versões do Mikrotik deverá ser retirado a opção "comment"
Obs4.: Caros Moderadores, fiz questão de ler e imprimir todos os itens deste post e num vi nenhuma irregularidade aqui no Blog por isso gostaria que não o removessem se necessário move-lo.

Desde já Agradeço a todos.

Atualizado 02-09-2011 em 08:43 por minelli (Alteração de Categoria.)

Categorias
Mikrotik

Comentários

  1. Avatar de MarcusMaciel
    Parabens pelo artigo.
  2. Avatar de minelli
    Grato Marcus pelo parabéns, mas nosso amigo Celso "Int21" também está de parabéns póis baseado em seu post resolvi transformar em artigo.
    Espero que seja útil aos usuários do forum Mikrotik.
  3. Avatar de m4d3
    Parabéns minelli,

    Dúvido muito que alguém mantenha os créditos e já vi muitos destes scripts em sistemas comerciais para gerenciamento de provedor, é muito díficil dizer quem copia quem e por esse motivo eu sempre digo, copiar e colar só se for pra economizar trabalho, entender o que se esta fazendo devia ser a senha pro acesso aos sistemas que conheço, todos, afinal a chance de alguém que não sabe o que ta fazendo acessar um sistema e fazer m*** é grande.

    Abraço e nos vemos no mum.
  4. Avatar de Etagil
    parabens pelo post mineli
  5. Avatar de minelli
    Citação Postado originalmente por m4d3
    Parabéns minelli,

    Dúvido muito que alguém mantenha os créditos e já vi muitos destes scripts em sistemas comerciais para gerenciamento de provedor, é muito díficil dizer quem copia quem e por esse motivo eu sempre digo, copiar e colar só se for pra economizar trabalho, entender o que se esta fazendo devia ser a senha pro acesso aos sistemas que conheço, todos, afinal a chance de alguém que não sabe o que ta fazendo acessar um sistema e fazer m*** é grande.

    Abraço e nos vemos no mum.
    Realmente 99% da população não manterá os créditos sabemos disso.
    Mas como o script foi baseado no script do Celso ai resolvi postar com os dizeres.
    Abraços, nos vemos no MUM.
  6. Avatar de minelli
    Citação Postado originalmente por Etagil
    parabens pelo post mineli
    Opá obrigado, agradeço.
  7. Avatar de Jadir
    Minelli, em primeiro lugar parabéns. Gostaria de pedir uma coisa: existe a possibilidade de agregar um controle de hosts no script de ip/mac/dhcp? Pergunto pois tenho um cliente que faz autenticação via ip/mac e não gostaria de trocar. Agradeço desde já.
  8. Avatar de minelli
    Citação Postado originalmente por Jadir
    Minelli, em primeiro lugar parabéns. Gostaria de pedir uma coisa: existe a possibilidade de agregar um controle de hosts no script de ip/mac/dhcp? Pergunto pois tenho um cliente que faz autenticação via ip/mac e não gostaria de trocar. Agradeço desde já.
    Se entendi corretamente o que você quer então utilize o penultimo script.
  9. Avatar de wans1105
    minelli. ja tenho um server funcionando com a versao 3.30 com ppp-oe +DHCP + Hotspot com login amarrado ao mac. com esse script, oque eu vou ter que alterar para funcionar? Ah! outra pergunta como o amigo m4d3 acima citou por questões de conhecimento concordo com ele. E por esse motivo te pergunto, esse script amarrar permanentemente ip+mac do cliente? sera que ele evita que alguem consiga clonar o mac e navegar com user do cliente?
  10. Avatar de minelli
    1 - Não conheço o funcionamento da sua estrutura então não posso lhe responder mas você pode adapta-lo como necessitar.
    2 - Sim e Não tudo vai depender da sua estrutura de rede.
    3 - Não.
  11. Avatar de unibraz
    Amigos, uso PPPoE na rede. Quando o cliente se conecta na rede a placa de rede dele fica com IP 169.xxx.xxx.xx --->(PROBLEMA)<--- algum cliente colocou um roteador e o DHCP esta vindo dele para toda a rede, achei o MAC pelo IP SCAN do MK, mais esse MAC não aparece na minha lista dos conectados. Como posso solucionar? Minha rede é o seguinte tudo 5.8, NANO LOCO em BRIDGE descendo cabo até o PC do cliente, se conectando na TORRE na Base Station. O discador criei bem simples dando IP do servidor 172.19.2.x + IP do cliente 172.18.0.x.. Esse script IP+MAC+DHCP solucionaria minha vida? Obrigado desde já.
  12. Avatar de Alexsandrosn
    Amigo use um switch gerenciavel para dividir as redes dai você vai saber se onde ta vindo o poblema .
    Atualizado 25-12-2011 em 21:10 por Alexsandrosn
  13. Avatar de minelli
    Citação Postado originalmente por Alexsandrosn
    Amigo use um switch gerenciavel para dividir as redes dai você vai saber se onde ta vindo o poblema .
    Olá, se você utiliza somente PPPoe te aconselho aplicar filtros para permitir somente o trafego de PPPoe na rede.
  14. Avatar de ddirlei15
    Essa regra não funciona nem por decreto nenhum no meu mikrotik v5.14..
    O que pode ser??
  15. Avatar de minelli
    Citação Postado originalmente por ddirlei15
    Essa regra não funciona nem por decreto nenhum no meu mikrotik v5.14..
    O que pode ser??
    O que retorna de erro?
    Rodou no console para teste?
  16. Avatar de wouney
    minelli gostei muito desse script, queria saber como faço para nao prender tbm os comentarios pois ele pega o mac o ip e comenta até o mesmo usuario se poder me responder eu agradesço. sim e ele só funcionou uma vez no script ele ta dizendo q 30 e 30 segundos ele captura mais nao fez mais que uma ves. agradesço cara
  17. Avatar de WagnerS2
    como posso usar esse mesmo processo para capturar e adicionar o nome e o mac de um trial user já que toda vez que a RB reinicia (queda de energia reboot manual e automático etc) os usuários triais são apagados deixando o mesmo testar novamente.

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L