+ Responder ao Tópico



  1. #1
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Web-proxy não incrementa o Cache Size

    Pessoal, tou com um problema no web-proxy usando o Hotspot na versão 2.9.27. Tudo parece ocorrer bem, o problema é que o Cache Size não muda, embora apareçam os sites no Log e navegue tranquilamente obedecendo às regras de acesso.
    Alguem já passou por isso?

    Segue em anexo uma imagem.

    Agradeço desde já.

    Gabriel Mota
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         cache.JPG
Visualizações:	595
Tamanho: 	28,0 KB
ID:      	1485  

  2. #2

    Padrão

    Posta ai pra gente como esta a configuração do seu webproxy, vc esta definindo o proxy na configuração do hotspot ou no firewall???

    Falow



  3. #3
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão

    Bom dia, amigo. Aí vai.

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "webmaster"
    max-object-size: 3000KiB
    cache-drive: system
    max-cache-size: unlimited
    max-ram-cache-size: none
    status: running
    reserved-for-cache: 32946176KiB
    reserved-for-ram-cache: 0KiB

    No max-cache-size e o max-ram-cache-size já coloquei vários valores (inclusive unlimited) mas não funciona também. No firewall tem o redirect da porta 80 para 3128 normal. Como falei, os usuários navegam e logs são gerados, porém o cache size não incrementa. A opção de proxy transparente está desabilitada no hotspot e o IP e porta do proxy estão configurados lá.

    Resumindo, os usuários estão passando no proxy, porém não há cache sendo gerado.

    Serei muito grato por novas sugestões.

    Gabriel Mota

  4. #4

    Padrão

    amigo acho q na sua configuracao em ip-webproxy-cache no item no cache dynamic http pages esta como deny, se tiver poe allow.



  5. #5
    engenheiro eletricista
    Ingresso
    Nov 2006
    Localização
    Rio de Janeiro
    Posts
    182
    Posts de Blog
    1

    Padrão Resolvido

    Amigo Diego, muito obrigado pela dica.

    Problema resolvido.

    Agradeço a todos pela atenção.

    Gabriel Mota

  6. #6

    Padrão Cache Size ?????

    Amigo Diogo, eu tb estava com essa mesma dúvida o cache size sempre em "0" zero, eu tb segui a sua instrução e troquei o denny por allow - permitir.
    Mas no tuto que usei pra configurar o web-proxy, diz que não se deve fazer cache de páginas dinâmicas, agora estando em allow, não é o mesmo que permitir o cache de páginas dinâmicas ?? por favor me tire essa dúvida.
    Grato,

    IRON - PP2AR



  7. #7

    Padrão

    Até onde eu sei tbm nao se deve fazer cache de paginas dinâmicas, tanto que o meu está deny, e o cache size esta funcionando perfeitamente.

  8. #8

    Padrão

    esta ai amigo como deve ser a configuracao:

    0 ;;; don't cache dynamic http pages
    url=":cgi-bin \\?" action=allow

    1 ;;; no cache dynamic http pages
    url=":cgi-bin \\\\?" action=allow

    2 ;;; no cache dynamic https pages
    url="https://" action=deny



  9. #9

    Padrão

    Citação Postado originalmente por diegovilela01 Ver Post
    esta ai amigo como deve ser a configuracao:

    0 ;;; don't cache dynamic http pages
    url=":cgi-bin \\?" action=allow

    1 ;;; no cache dynamic http pages
    url=":cgi-bin \\\\?" action=allow

    2 ;;; no cache dynamic https pages
    url="https://" action=deny
    Amigos, eu tambem já tive esse problema, mas o correto não é colocar action=allow, deve deixar como action=deny, o problema é que quando a gente habilita o web-proxy uma regra é criada automaticamente, a url=":cgi-bin \\?" action=deny e quando a gente segue o tutorial de como criar um web-proxy a gente acaba criando outra regra igual, já que consta no tutorial, assim causa um conflito e ele não funciona, então se a gente deletar uma das regras repetidas, nosso web-proxy vai funcionar corretamente.

    Espero ter ajudado

    Abraços

    Edmar (ramde)

  10. #10

    Padrão web-proxy

    Valeu Ramde, vou testar aki, eu táva com essa dúvida e tinha observado realmente que além da regra que eu criei seguindo o tutorial, já tinha uma outra idêntica lá, só um detalhe: o número de barras "\\\\" é diferente, isso tem influência ??

    abçs,

    IRON - PP2AR



  11. #11

    Padrão

    Citação Postado originalmente por iron Ver Post
    Valeu Ramde, vou testar aki, eu táva com essa dúvida e tinha observado realmente que além da regra que eu criei seguindo o tutorial, já tinha uma outra idêntica lá, só um detalhe: o número de barras "\\\\" é diferente, isso tem influência ??

    abçs,

    IRON - PP2AR
    Amigo, deixei o meu só com uma barra, na verdade, deixei o que foi criado pelo Mikrotik

    Edmar (ramde)