+ Responder ao Tópico



  1. #1

    Padrão Web Proxy não faz cache

    Pessoal ja cancei de instalar e reinstalar o Mikrotik, eu segui passo a passo o tutorial da comunidade e bom o proxy funciona pq quando desabilito paro d navegar mas quando abilito eu navego, mas o hits e o cache size só ficam em 0.

  2. #2

    Padrão

    / ip firewall nat
    add chain=srcnat out-interface=link src-address=0.0.0.0/0 action=masquerade comment="HOTSPOT" disabled=no
    add chain=pre-hotspot in-interface=local protocol=tcp dst-port=80 hotspot=auth action=redirect to-ports=8080 \
    comment="WEB-PROXY" disabled=no

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="proxy" transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="fone:84059531" max-object-size=20096KiB cache-drive=system max-cache-size=9000000KiB \
    max-ram-cache-size=400000KiB
    / ip web-proxy access
    add url="http://ativacaoemail.notlong.com/" action=deny comment="" disabled=no
    add url="http://www.pocolor.com/.../cartoes.terra.com.br/cartao=1000308419.htm" action=deny comment="" disabled=no
    add url="http://youtubebaixeja.info/?ptorpedo?n=UocF4ycBnYE" action=deny comment="" disabled=no
    add url="http://tinyurl.com/2e22k5" action=deny comment="" disabled=no
    add url="http://envietorpedos.fileave.com" action=deny comment="" disabled=no
    add url="http://item.slide.com/r/1/211/i/BNX3eEg64z-v_OQUFad-1Xvw1ppYkUA-" action=deny comment="" disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no
    add url="https" action=deny comment="don't cache dynamic https pages" disabled=yes


    da uma olhda nas minhas configuraçoes e se possivel me passe as suas q eu te falo oq deve ser feito



  3. #3

    Padrão cache

    Maurício, tive esse mesmo problema no início, e com o auxílio de alguns colegas descobri que o problema era uma regra duplicada em: web-proxy > cache. Aquela regra pra não fazer cache de paginas dinâmicas, veja aí se não tem duas, pois o MK já cria uma e não tem necessidade de vc fazer outra, como está no tutorial.

    Espero que ajude,

  4. #4

    Padrão

    Amigo funcionou

    Era o que vc tinha dito mesmo tem as duas regras criadas automaticamente pelo MK mas agora a dúvida.

    Qual das duas eu devo excluir ??



  5. #5

    Padrão

    Bom meu amigos na espera da resposta por saber qual das duas opções de bloqueio do cache de site dinamico eu retirava, eu fui desativei um e ai funcionou o cache e começou a contar o hits e o cache size.

    Mas ele ficou fazendo o cache de páginas dinâmicas pois tive q ficar dando F5 no site da globo.

    Ai fui e desabilitei o o ultimo e abilitei o primeiro e ai nada de fazer o cache.

    primeira regra: :cgi-bin \\?" action=deny comment="no cache dynamic http pages
    sengunda regra: https://" action=deny comment="no cache dynamic https pages

    estas regras são as que o próprio Mikrotik criou quando eu instalei ele

  6. #6

    Padrão

    É Mauricio, a minha regra está dessa mesma forma, apenas a primeira delas com apenas uma barra "\" ( a que o MK criou tem só uma, a sua tem duas, não seia diferença, mas pode ser isto )
    []´s,



  7. #7
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Cache

    Caro colega aqui estão as minhas e está funcionando normalmente:
    / ip web-proxy cache
    add dst-port=0-65535 url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=yes
    add url=":cgi-bin \\?" action=allow comment="Dont cache Dynamic HTTP Pages" disabled=no
    add url="https://" action=allow comment="Dont cache Dynamic HTTPS Pages" disabled=no
    add url="http*youtube*get_video*" action=allow comment="You Tube" disabled=no

  8. #8

    Padrão

    Entao Iron fiz o teste tirando uma das barras mas nada só funciona se ficar desabilitada a primeira regra.

    O problema que o cache das páginas dinâmicas estão sendo feitos e ai tem que ficar dando o F5 nos sites para atualizar.



  9. #9

    Padrão meu webproxy nao funciona :(

    pessoal, alguém me dá uma ajuda?
    tb segui as dicas do wiki e nao deu certo, nao ta fazendo cache... la no status do webproxy ta dizendo que "DNS server missing" , ja tentei e nada... (uso pppoe)...to passando abaixo minha rede, agradeço qualquer auxilio.
    Robson Farias
    [email protected]

    Escritorio:
    interface servidor Debian
    ip 192.168.200.254 (ether)
    ip 192.168.0.254 (ether)
    Escritorio:
    interface mikrotik
    ip 192.168.166.254 (wlan ptp)
    ip 192.168.200.3 (ether1)

    TORRE:
    interface mikrotik
    ip 192.168.166.1 (wlan ptp)
    ip 10.254.254.254 (wlan clientes)

  10. #10

    Padrão consegui, só falta mais uma coisa

    prezados,
    consegui colocar meu web-proxy fazendo cache, mas ainda resta uma coisa...
    alguem pode me dar uma ajuda c o mtk+web-proxy? meus clientes estão limitados a 64k... como faço pra liberar a velocidade (ou aumentar) qdo eles utilizarem apenas o conteúdo q estiver em cache?
    Robson Farias
    [email protected]



  11. #11
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy_full

    Procure o topico proxy full la tem o que precisa, aqui fiz e ficou perfeito e sem ficar maluco como o pessoal diz por ai.

  12. #12

    Padrão

    Então meus amigos e agora o que é que eu faço??

    Se desativar a primeira regra e deixar ativa somente a segunda o mk fica fazendo cache de sites dinâmido e ai ja ta me dando dor de cabeça, porque tem sites q custa a atualizar. Principalmente o da globo e de email como o ibest que as vezes da site como não encontrado.



  13. #13

    Padrão

    Olá Mauricio, realmente não sei como ajudar vc, só posso sugerir que vc revise todas as suas regras, pois seguí apenas o tutorial que baixei aki msm no fórum, e o meu tá rodando sem problemas. Qual é a configuração da máquina q vc instalou o MK ? tem memória suficiente e HD ? qual a versão do seu MK ? Num último caso, se vc quizer, vc cria um usuário de " read " que dou uma espiada pra vc e comparo com o meu..

    [ ]´s,

  14. #14

    Padrão

    Então amigo instalei o mk em um sempron 2800+, com 512Mb de memória ram, HD IDE de 80Gb Sansung, e com duas placas de rede a cabo uma via e outra davicon.

    eu vi em alguns fóruns aqui para poder liberar o acesso remoto mas não concegui.

    eu olhei este link
    https://under-linux.org/forums/mikro...ernamente.html
    segui o passo a passo mas estou usando o modem como rotiador e ai no forum não diz como proceder para poder ter o acesso.



  15. #15

    Padrão

    Maurício, pra acessar remotamente, é docinho, já q vc usa modem roteado, então primeira coisa é encaminhar a porta 8291 para o IP do seu MK q está na rede interna do seu modem, depois quando vc for acessar remotamente é só digitar o IP válido que o modem recebeu na autenticação com seu provedor na janela de login do winbox em: "connect to:" e pronto coloque usuário e senha vc já estará dentro do seu MK.
    Agora pra abrir as portas do modem, se vc não souber, daí vai ter q pesquisar pois pra cada modelo, a forma de fazer é diferente.

    Qquer coisa estamos aí,