+ Responder ao Tópico



  1. #1

    Question PPPoE com limite de horario.

    Amigos, alguem sabe se tem como implementar o controle de uso por horario no mikrotik usando PPPoE? Aqui eu uso o PPPoE e muitos clientes me pedem uma solução mais em conta e de preferencia com controle de uso por horario exemplo. O cliente que trabalha durante o dia não vai usar a internet em casa neste horario ai ele me sugeriu que fizesse um plano noturno, tipo ele chega em casa as 18h e usa sem problema ate as 6h da manha e durante o dia fica bloqueado e nos fins de semana fica liberado tanto dia quanto a noite. Alguem sabe como coloca isso no Mikrotik usando autenticação via PPPoE?

    Obrigado.
    Última edição por Bender; 14-01-2008 às 19:49. Razão: correção de digitação

  2. #2

    Padrão

    Citação Postado originalmente por Bender Ver Post
    Amigos, alguem sabe se tem como implementar o controle de uso por horario no mikrotik usando PPPoE? Aqui eu uso o PPPoE e muitos clientes me pedem uma solução mais em conta e de preferencia com controle de uso por horario exemplo. O cliente que trabalha durante o dia não vai usar a internet em casa neste horario ai ele me sugeriu que fizesse um plano noturno, tipo ele chega em casa as 18h e usa sem problema ate as 6h da manha e durante o dia fica bloqueado e nos fins de semana fica liberado tanto dia quanto a noite. Alguem sabe como coloca isso no Mikrotik usando autenticação via PPPoE?

    Obrigado.

    Moleza amigo, vc vai criar um script pra este usuário igual ao que criei aqui no meu pppoe

    / system script
    add name="desabilitar eletron antenas" source="/ppp secret disable eletron
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
    add name="habilitar eletron antenas" source="/ppp secret enable eletron
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    / system scheduler
    add name="habilitar eletron" on-event="habilitar eletron antenas" \
    start-date=jan/01/2008 start-time=18:00:00 interval=1d comment="HABILITAR \
    ELETRON" disabled=no
    add name="DESABILITAR ELETRON" on-event="desabilitar eletron antenas" \
    start-date=jan/01/2008 start-time=06:00:00 interval=1d \
    comment="DESABILITAR ELETRON" disabled=no


    Assim vc vai habilitar o usuario para 18:00 da noite e desabilita-lo as 06:00 da manha
    Faz as alteraçoes ai que vai da tudo certo abraços


    Configuração mikrotik Servidor/cliente, web proxy e Cache de DNS
    msn: [email protected]



  3. #3

    Question

    Opa amigo, muito obrigado.

    Só estou com uma duvida.

    Este eletron antenas seria o usuario criado nos secrets, certo?

    Mas o usuario criado no secrets é o eletron?

    Ai basta eu criar um script para cada secrets?

    E para definir os dias da semana teria como? Minha necessidade seria definir de segunda a sexta com controle de horario e sabado e domingo liberado.

    Mais uma vez obrigado.

  4. #4

    Padrão

    Aja script hein... ai vc vai precisar se for usar a opção do amigo acima, vc tera q criar por usuario mais uma regra liberando aos sabados e domingos... mas vem ka... vc sabe que existem clientes q nao conseguir conectar, fuçam em tudo, e gerando depois atendimento a ele, e xateação pq sempre é problema nosso pq nao funciona internet, nunca é o cliente q desativo uma placa, ta colocando senha errada, nao digita certo o end. da pagina, sendo assim, pq vc nao cria controle de banda... limitando o acesso por ex. de dia.. e deixando o trafico funcionar depois das 6 e aos sabados e domingos. Veja os anexo q mandei como modelo, vc pode tbm dessa forma aumentar a banda do usuario em determinado horario. assim o cliente nao mexe em nada pq conecta.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         das 6 as 18.jpg
Visualizações:	504
Tamanho: 	33,9 KB
ID:      	1618   Clique na imagem para uma versão maior

Nome:	         das 18 as 00.jpg
Visualizações:	380
Tamanho: 	37,2 KB
ID:      	1619  

    Clique na imagem para uma versão maior

Nome:	         das 00 as 6.jpg
Visualizações:	349
Tamanho: 	36,1 KB
ID:      	1620   Clique na imagem para uma versão maior

Nome:	         sabado e domingo.jpg
Visualizações:	347
Tamanho: 	36,0 KB
ID:      	1621  




  5. #5

    Post

    Caro Aka, obrigado pela dica.

    Mas eu tenho que bloquear mesmo, pois eu uso Ap nos clientes e eu deixo bem claro que o acesso ate a hora combinada fica bloqueado.
    Eu tb queria ver um meio de exibir uma mensagem na tela do cliente mas ainda nao achei nada sobre isso.

  6. #6

    Padrão

    Citação Postado originalmente por Bender Ver Post
    Opa amigo, muito obrigado.

    Só estou com uma duvida.

    Este eletron antenas seria o usuario criado nos secrets, certo?

    Mas o usuario criado no secrets é o eletron?

    Ai basta eu criar um script para cada secrets?

    E para definir os dias da semana teria como? Minha necessidade seria definir de segunda a sexta com controle de horario e sabado e domingo liberado.

    Mais uma vez obrigado.

    Vamos por partes

    O desabilitar eletron antenas é o nome do Script
    O usuário criado no secrets é eletron

    ja no system scheduler o Script que ele esta executando e o desabilitar eletron antenas e o habilitar eletron antenas


    E sendo assim basta vc cliar sim um script para cada secret um pouco trabalhoso mais se vc quer desabilitar o usuario por horario essa é uma boa solução.

    Abraços e espero ter ajudado


    Configuração mikrotik Servidor/cliente, web proxy e Cache de DNS
    msn: [email protected]



  7. #7

    Padrão

    Citação Postado originalmente por Bender Ver Post
    Caro Aka, obrigado pela dica.

    Mas eu tenho que bloquear mesmo, pois eu uso Ap nos clientes e eu deixo bem claro que o acesso ate a hora combinada fica bloqueado.
    Eu tb queria ver um meio de exibir uma mensagem na tela do cliente mas ainda nao achei nada sobre isso.
    Blz, vc usando radio os clientes fuçam menos..
    Bom ai vc vai ter q usar Script mesmo....
    Sobre a Pagina de aviso, ai complica, vc tera q hospedar uma pagina num ip valido, e no mikrotik fazer redirecionamento dos clientes nas horas para esse ip.. complica um poco mas da..

  8. #8

    Question

    Amigos eu denovo.

    A dica de bloqueio por PPP funfou beleza agora eu to com outra necessidade eu tb preciso bloquear o MAC Address junto com o user teria como fazer isso no mesmo script.

    Olha o script de exemplo.

    / system script
    add name="desabilitar ClienteTESTE" source="/ppp secret disable teste
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="habilitar teste" source="/ppp secret enable teste
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword

    / system scheduler
    add name="habilitar teste" on-event="habilitar teste" \
    start-date=jan/01/2008 start-time=18:00:00 interval=1d comment="HABILITAR \
    teste" disabled=no
    add name="DESABILITAR teste" on-event="desabilitar teste" \
    start-date=jan/01/2008 start-time=06:00:00 interval=1d \
    comment="DESABILITAR teste" disabled=no

    Valew pessoal.



  9. #9

    Padrão

    Citação Postado originalmente por Bender Ver Post
    Amigos eu denovo.

    A dica de bloqueio por PPP funfou beleza agora eu to com outra necessidade eu tb preciso bloquear o MAC Address junto com o user teria como fazer isso no mesmo script.

    Olha o script de exemplo.

    / system script
    add name="desabilitar ClienteTESTE" source="/ppp secret disable teste
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword
    add name="habilitar teste" source="/ppp secret enable teste
    \n" \
    policy=ftp,reboot,read,write,policy,test,winbox,pa ssword

    / system scheduler
    add name="habilitar teste" on-event="habilitar teste" \
    start-date=jan/01/2008 start-time=18:00:00 interval=1d comment="HABILITAR \
    teste" disabled=no
    add name="DESABILITAR teste" on-event="desabilitar teste" \
    start-date=jan/01/2008 start-time=06:00:00 interval=1d \
    comment="DESABILITAR teste" disabled=no

    Valew pessoal.
    Se vc coloca o mac no CALED ID quando ta cadastrando o usuario vc nao precisa bloquear o mac, pois desabilitando o usuario o mac nao navegara de qualquer forma ok.

    Espero que minhas dicas tenham sido uteis

    Abraçosss

  10. #10

    Thumbs up

    Blz, fiz aqui e funcionou perfeitamente.

    Muito obrigado.



  11. #11

    Padrão PPPoE com controle de MAC

    bom dia galera,

    ve ae alguem consegue me ajudar ae....

    queria saber se tem como usar pppoe com controle de mac, assim, saber se ele consegue validar o mac da placa de rede do pc de onde parte a discagem do pppoe...no caso do hotspot ja uso, só q consigo validar o mac da ap e nao do pc, pq ela nao faz o tal do proxy-arp, algo assim, ehjehe....mas queria ter um jeito de validar o mac do pc...

    alguem ?

    obrigado..t+

  12. #12

    Padrão

    Citação Postado originalmente por infantefox Ver Post
    Se vc coloca o mac no CALED ID quando ta cadastrando o usuario vc nao precisa bloquear o mac, pois desabilitando o usuario o mac nao navegara de qualquer forma ok.

    Espero que minhas dicas tenham sido uteis

    Abraçosss

    Você leu a resposta do colega?

    Se não, para cadastrar o mac no usuario e senha é só colocar o mac do usuario no espaço CALLED ID.

    Dai fica "amarrado" mac, usuario e senha!!
    Última edição por ZeXP; 03-03-2008 às 14:39.