+ Responder ao Tópico



  1. #1
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Ddns Mk 2.9.27

    Alguem tem um script DDNS que realmente funcione???

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Script

    Vi aqui no forum um script mas o problema que ele funciona só quando quer, vou posta-lo aqui.

    :log info "DDNS: Begin"
    : global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-host "endereço DDNS escolhido"
    :global ddns-interface "Nome da interface de saida - Link"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"



  3. #3
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão DDNS Script

    Pessoal acho que esse deu certo pelo menos atualiza de 1 em 1 minuto sem problemas e atualiza todas as vezes.
    Lembrem este script é para o changeip.com não sei se funciona com outro, tb tem de alterar as variaveis :
    ddns-user ; ddns-pass ; ddns-interface ; ddns-host

    :log info "DDNS Begin"
    :global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-interface "Interface Link"
    :global ddns-host "seuid.changeip.org"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

  4. #4
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por minelli Ver Post
    Pessoal acho que esse deu certo pelo menos atualiza de 1 em 1 minuto sem problemas e atualiza todas as vezes.
    Lembrem este script é para o changeip.com não sei se funciona com outro, tb tem de alterar as variaveis :
    ddns-user ; ddns-pass ; ddns-interface ; ddns-host

    :log info "DDNS Begin"
    :global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-interface "Interface Link"
    :global ddns-host "seuid.changeip.org"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

    esse script funciona legal estou usando ele faz mais de um mes e nunca falhou



  5. #5
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Script

    Mas só pra saber vc consegue sempre acessar o mk pelo ddns fora da rede tipo, teste.changeip.org ou vc entra no site pra ver o ip e entra pelo ip. Pq aqui nunca consigo entrar pelo ddns, mas pelo ip blz.

  6. #6
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por minelli Ver Post
    Mas só pra saber vc consegue sempre acessar o mk pelo ddns fora da rede tipo, teste.changeip.org ou vc entra no site pra ver o ip e entra pelo ip. Pq aqui nunca consigo entrar pelo ddns, mas pelo ip blz.

    Sim, tanto me conecto no mk fora da rede pelo winbox como pelo navegador,

    da uma olhada pra vc ver

    ctinformatica.changeip.net

    user: teste
    senha: teste



  7. #7
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Ddns

    É o meu nao funciona assim nao, mas diga ai como vc faz para criar os diretorios e por os arquivos em file???

  8. #8
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por minelli Ver Post
    É o meu nao funciona assim nao, mas diga ai como vc faz para criar os diretorios e por os arquivos em file???
    Para criar os diretorios e por os arquivos em file eu acessa via ftp, pelo windows explorer é bem facil, tipo eu abro o windows explorer coloco o endereço la do mk so que em vez de www coloco ftp:// ai eu faço as modificaçoes como se fosse um diretorio do windows, so nao pode esquecer de fechar o servidor ftp para internet senao fica um monte de neguin querendo invadir o server com aqueles programa força bruta.
    ah nao esquecendo pra montar esse mk tive a ajuda do faiepp e do bsnet que sao firmeza

    falow ate mais



  9. #9

    Padrão conf. MK

    Amigo edcomrocha, me desculpe a intromissão, mas aproveitei q vc disponibilizou seu endereço e senha read do MK, e entrei pra dar uma espiadinha e ver se aprendo algumas coisas com sua configuração, já que sou bem cru ainda no assunto kkkk....
    gostaria de perguntar como o amigo criou o canal "virus" no seu firewall pois o meu aki não tem, e eu gostaria de implementar algumas regras de proteção aki tb..
    verifiquei tb que sua regra de "CONTROLE DE CONEXÕES SIMULTÂNEAS" está sem /24, com isso acho q não está valendo pra toda rede, se é que era isso q vc pretendia fazer ...
    ainda sobre o canal virus, ví q vc fechou as portas 135-139 tanto em forward quanto em virus, nesse caso tem alguma diferença ??

    Puxavida, vc nem usa web-proxy, seu HD de 80 está quase sem uso hehehe..

    Grande abraço,

  10. #10
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por iron Ver Post
    Amigo edcomrocha, me desculpe a intromissão, mas aproveitei q vc disponibilizou seu endereço e senha read do MK, e entrei pra dar uma espiadinha e ver se aprendo algumas coisas com sua configuração, já que sou bem cru ainda no assunto kkkk....
    gostaria de perguntar como o amigo criou o canal "virus" no seu firewall pois o meu aki não tem, e eu gostaria de implementar algumas regras de proteção aki tb..
    verifiquei tb que sua regra de "CONTROLE DE CONEXÕES SIMULTÂNEAS" está sem /24, com isso acho q não está valendo pra toda rede, se é que era isso q vc pretendia fazer ...
    ainda sobre o canal virus, ví q vc fechou as portas 135-139 tanto em forward quanto em virus, nesse caso tem alguma diferença ??

    Puxavida, vc nem usa web-proxy, seu HD de 80 está quase sem uso hehehe..

    Grande abraço,
    Ola, bom eu tbm nao manjo nada de mk, o que esta la foi com a juda do amigo Under-Linux.org Fóruns - Ver Perfil: bsnet e o nosso amigo Under-Linux.org Fóruns - Ver Perfil: faieppi ok

    as regras de firewall foi o bsnet que fez por isso nao sei como ele fez o chain virus, mas se nao me engano essas regras tem num post daki mesmo fo forum.
    Agora sobre a regra de conexoes simultaneas esta certo sim e pra rede toda la na aba extra tem a opçao netmask ai vc coloca o valor 24 que fica pra rede toda pelo menos foi o que entendi quando li um post pra fazer esse controle.
    Voltando sobre a regra de firewall eu acho que nao tem diferença nao alguem que manja mais pode dar uma olhada la e dizer pra nos se esta certo ou nao
    sobre o web-proxy ate implementei aki mas nao consegui fazer o cache-full ai desisti mas vou por ainda pra rodar, no momento só estou usando o hd para arquivos para minhya rede tipo quando formato um pc baixo os programas do meu mk.

    sei que nao esclareci muito mais é como eu dsse nao manjo muito tabem

    e quem quiser pode dar uma olhada la ok

    valew abraços