+ Responder ao Tópico



  1. #21

    Padrão E se setar um valor fixo para o ACK

    Galera, neste caso o ack timeout ficando com um valor muito alto fica ruim pra todo mundo, certo?
    E se setar um valor fixo para o ack, tipo, 150. Quem está com sinal para ficar entre 1 e 150 conectaria e quem está com sinal ruim, ou seja, teria um ack acima disso nao conectaria?
    Ou somente conectaria aqueles em que o ack batesse exatamente nos 150?


    Carlos Picioli

  2. #22

    Padrão

    seta o ack pra 61

    61 = 6km ... eh um valor bom ..



  3. #23

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    seta o ack pra 61

    61 = 6km ... eh um valor bom ..
    alexandre estou colocando um ap cliente, nele tem a opção de ack devo colocar o mesmo do meu cartão? o sinal lá é bom (-60) porem ele quer aumentar e muito a distancia do computador até a antena e deixar varios pontos para ele conectar su notbook.
    grato pela atenção.

  4. #24

    Padrão

    Pow galera to com esse proplema tb, estou Usando uma RB532 + Cartão EnGenius EMP-8602, antes usava 1 Ovislink com AProuter, e os clientes conectavem numa boa com Ack timeout = 91, padrão do aprouter, queria definir o mesmo no MK só só está em dinamic, como faço pra definir valor fix no ack no MK não estou achando essa config.

    Obrigado pela ajuda.



  5. #25

    Padrão

    Citação Postado originalmente por theothers Ver Post
    Pow galera to com esse proplema tb, estou Usando uma RB532 + Cartão EnGenius EMP-8602, antes usava 1 Ovislink com AProuter, e os clientes conectavem numa boa com Ack timeout = 91, padrão do aprouter, queria definir o mesmo no MK só só está em dinamic, como faço pra definir valor fix no ack no MK não estou achando essa config.

    Obrigado pela ajuda.
    sou novato em mikrotik mas essa opção fica em <interface> depois clica na interface que está seu cartão, (exemplo: wan1) depois na aba <advanced>.
    Eu acho esse valor de 91 muito alto isso daria em torno de 10 km, mas cada caso é um caso e quem acha não sabe nada.

  6. #26

    Padrão

    Citação Postado originalmente por patrickmiranda Ver Post
    sou novato em mikrotik mas essa opção fica em <interface> depois clica na interface que está seu cartão, (exemplo: wan1) depois na aba <advanced>.
    Eu acho esse valor de 91 muito alto isso daria em torno de 10 km, mas cada caso é um caso e quem acha não sabe nada.

    Obrigado pela ajuda amigo + mesmo assim permanece o proplema, só tem duas opções dynamic e indoors não tem a opção pra eu fixar 1 valor ou é só digitar nesse campo q fixa o valor.



  7. #27

  8. #28

    Padrão

    Vlw amigo foi isso mesmo que fiz, fixei o valor nesse campo, + meu proplema persisti tem 1 cliente meu q tá + ou - 1,5 Km tá pegando 75% de sinal e outro a 400mts q ta pegando 46%, antes com Ovislink com ack timeout = 91, os 2 clientes funcionava numa boa + agora qnd defino esse valor fica ruim pro + proximo e bom pro + longe, qual seria o valor ideal pra eu fixar pra ficar pros 2, acho tb q minha antena é culpada disso estou usando aquele DotWarp(Uma mer... é 1 cano com RGC 215 dentro) do ML, estou pra comprar uma Hypertec 12,5dBi ( http://www.snetcommerce5.com.br/ecommerce_site/index.php?pg=t1_ex_prod&codprd=84918&cd=ljndbh1.BUche&cat=hefbcd88/Ofhi&cats1=hiheZb9!}Pifi&cdgc=ghhZgd9![Sgj&sid=r6plg6t7lprbtiln88l4kevuj4-1210606937 ), algum já usou essa antena ? + uma nota meu MK tá dando -91dBm de noise margin isso é bom ?

    Desde já agradeço a grande ajuda por parte do forum.
    Última edição por theothers; 12-05-2008 às 13:04. Razão: Consertar Link postado



  9. #29

    Talking

    Olá Pessoal,

    Seguindo a dica de nosso amigo thenet, fiz um script que mosta quantos estão acima de um determinado ACK e se definir a varíavel ele bloqueia o cliente e dropa ele. Testado em PC-AP com MKT 2.9.27 e RB com MKT 3.0rc6. Segue abaixo:

    Código :
    # Defina abaixo o valor mínimo de ACK
    :global ack 35;
    # Defina abaixo 1 para bloquear/dropar e 0 para não bloquear/dropar o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo a Interface
    :global interf "AP-Master";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
      :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
        :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
        :if ($block = 1) do={
          :set mac [/interface wireless registration-table get $i mac-address];
          :set cliente [/interface wireless access-list find mac-address=$mac];
          /interface wireless access-list disable $cliente;
          /interface wireless registration-table remove $i;
        };
        :set total total+1;
      };
    };
    :if ($total = 0) do={
      :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };

    Abraços !

  10. #30

    Padrão

    eu estava montando um desses.. mas o teu funcionou blz aqui.. hehe !!

    vlww cara. !!



  11. #31

    Padrão

    contribuindo mais... fiz uma alteração...

    voce pode definir.. se vai apenas DROPAR o cliente, forçando uma reconexão. em alguns casos.. o cliente volta com ack baixo

    Código :
    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;
     
    # Defina abaixo a Interface
    :global interf "wlan1";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
     :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
       :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
         :set mac [/interface wireless registration-table get $i mac-address];
         :set cliente [/interface wireless access-list find mac-address=$mac];
       :if ($block = 1) do={
         /interface wireless access-list disable $cliente;
       };
       :if ($drop = 1) do={
         /interface wireless registration-table remove $i;
       };
       :set total total+1;
     };
    };
    :if ($total = 0) do={
     :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };

  12. #32

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    contribuindo mais... fiz uma alteração...

    voce pode definir.. se vai apenas DROPAR o cliente, forçando uma reconexão. em alguns casos.. o cliente volta com ack baixo
    Disso eu não sabia oO... bom... vou fazer isso então... pq tem uns clientes que vai de 35 pra 400 as vezes, mas to mandando o técnico ir la ver a instalação.

    Valew !



  13. #33

    Padrão

    exato.. eu desconecto todos que estao acima de 30 ... na maioria das vezes.. 80% volta com ack em 30 ... e os que novamente ficam com ack alto.. eu ja mando o tecnico urgente arrumar...

    as vezes um cliente ficou com ack alto por causa de algum outro cliente.. (alguma coisa momentanea) ...

    o ideal eh.. acima de 100 .. desconectar... rodar um script de 1 em 1 hora.. que cliente com ack acima de 100 .. seja desconectado..

  14. #34

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    exato.. eu desconecto todos que estao acima de 30 ... na maioria das vezes.. 80% volta com ack em 30 ... e os que novamente ficam com ack alto.. eu ja mando o tecnico urgente arrumar...

    as vezes um cliente ficou com ack alto por causa de algum outro cliente.. (alguma coisa momentanea) ...

    o ideal eh.. acima de 100 .. desconectar... rodar um script de 1 em 1 hora.. que cliente com ack acima de 100 .. seja desconectado..
    Ah tah ! Saquei



  15. #35

    Padrão

    Olá Pessoal,

    Segue abaixo o script para RouterOS 2.9.x ou inferior:

    Código :
    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "AP-Master";
     
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " ms:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
      :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
        :set mac [/interface wireless registration-table get $i mac-address];
        :set cliente [/interface wireless access-list find mac-address=$mac];
        :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
        :if ($block = 1) do={
          /interface wireless access-list disable $cliente;
        };
        :set total total+1;
      };
    };
    :if ($total = 0) do={
      :log info ("Nenhum Cliente com ACK acima de " . $ack . " ms encontrado.");
    } else {
      :if ($intdis = 1) do={
        /interface wireless disable $interf;
        /interface wireless enable $interf;
      };
    };

    Obs.: Infelizmente nesta versão não é possível derrubar o cliente sem ter que derrubar todos os outros, sendo assim use a função por sua conta e risco.

    Abraços.
    Última edição por youngrp; 18-05-2008 às 02:04.

  16. #36

    Padrão

    O script nao executou aqui, MK 2.9.27! Por que sera? Coloquei a interface correta e configurei somente para dropar. Mas nao executou!

    O que pode ser?



    Citação Postado originalmente por alexandrecorrea Ver Post
    contribuindo mais... fiz uma alteração...

    voce pode definir.. se vai apenas DROPAR o cliente, forçando uma reconexão. em alguns casos.. o cliente volta com ack baixo

    Código :
    # Defina abaixo o valor mínimo de ACK
    :global ack 30;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;
     
    # Defina abaixo a Interface
    :global interf "wlan1";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
     :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
       :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
         :set mac [/interface wireless registration-table get $i mac-address];
         :set cliente [/interface wireless access-list find mac-address=$mac];
       :if ($block = 1) do={
         /interface wireless access-list disable $cliente;
       };
       :if ($drop = 1) do={
         /interface wireless registration-table remove $i;
       };
       :set total total+1;
     };
    };
    :if ($total = 0) do={
     :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };



  17. #37

    Padrão

    Citação Postado originalmente por netleandromt Ver Post
    O script nao executou aqui, MK 2.9.27! Por que sera? Coloquei a interface correta e configurei somente para dropar. Mas nao executou!

    O que pode ser?
    Olá Leandro,

    De uma olhadinha no post https://under-linux.org/forums/mikro...tml#post321341

    Abçs.

  18. #38

    Padrão

    Estamos nele e ja li ...

    Citação Postado originalmente por youngrp Ver Post
    Olá Leandro,

    De uma olhadinha no post https://under-linux.org/forums/mikro...tml#post321341

    Abçs.



  19. #39

    Padrão

    Citação Postado originalmente por netleandromt Ver Post
    Estamos nele e ja li ...
    Passa o mouse em cima do nome do post que eu coloquei em cima que verá que é um link. Basta clicar que vai cair no último post da página 7, aonde deixei o código para versões 2.9.x.

    Grato.

  20. #40

    Padrão

    Citação Postado originalmente por Mr_Dom Ver Post
    opa..blz

    isso é pq algum de seus clientes conectados nesse cartão ta com sinal ruim, sendo assim o mt assimila ack de 408 pra todos os clientes..ele pega o maior ack, no caso o 408. Entao resumindo, se tiver 1 cliente com sinal ruim e com ack alto...pode acabar interferindo em todos os outros clientes....aqui estamos começando a passar em todos os ruins e revisando...é a unica forma..

    abraços..t+
    amigo,

    isso prossegue em caso de AP2000 tambem? ou seja se eu tiver ap2000 ao inves de mk RB ?,

    valeu galera.