+ Responder ao Tópico



  1. #1

    Padrão Acesso remoto ao MK pelo Winbox de Qualquer lugar.

    Boa Galera, bom logo que postei meu primeiro topico. https://under-linux.org/forums/mikro...-clientes.html

    Rapidamente acessando a area tutorias daki consegui sanar e configurar corretamente meu Futuro Provedor.

    Bom agora tenho mais uma duvida.

    Digamos que eu esteja no trabalho, e precise adicionar um cliente novo no MK que fika no meu condominio, como configuro o acesso remoto para que eu consiga acessa-lo pelo Winbox, e ai cadastrar os clientes.

    Obrigado a todos desde já pela ajuda.

  2. #2

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Boa Galera, bom logo que postei meu primeiro topico. https://under-linux.org/forums/mikro...-clientes.html

    Rapidamente acessando a area tutorias daki consegui sanar e configurar corretamente meu Futuro Provedor.

    Bom agora tenho mais uma duvida.

    Digamos que eu esteja no trabalho, e precise adicionar um cliente novo no MK que fika no meu condominio, como configuro o acesso remoto para que eu consiga acessa-lo pelo Winbox, e ai cadastrar os clientes.

    Obrigado a todos desde já pela ajuda.
    Boa noite;
    Basta liberar a porta 8291 no seu roteador direcionando para o mk.



  3. #3

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    Boa noite;
    Basta liberar a porta 8291 no seu roteador direcionando para o mk.
    Ok SH, mas eskeci de avisa, desculpa, Minha conexao é velox Bridge autenticada pelo proprio MK.

  4. #4

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Ok SH, mas eskeci de avisa, desculpa, Minha conexao é velox Bridge autenticada pelo proprio MK.
    oche então é mais facil.. ja ta tudo liberado... basta vc fazer um cadastro no ddns e criar um ecript para atualizar de 5 em 5 min....

    da uma olhada nesses post.. funciona blz.. Under-Linux.org Fóruns - Resultados da Pesquisa
    Última edição por Shturbo Internet; 08-02-2008 às 08:51.



  5. #5

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    oche então é mais facil.. ja ta tudo liberado... basta vc fazer um cadastro no ddns e criar um ecript para atualizar de 5 em 5 min....

    da uma olhada nesses post.. funciona blz.. Under-Linux.org Fóruns - Resultados da Pesquisa
    Desculpe - sem resultados. Por favor tente outros termos.


    Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki

  6. #6

    Thumbs up

    Citação Postado originalmente por Shturbo Internet Ver Post
    oche então é mais facil.. ja ta tudo liberado... basta vc fazer um cadastro no ddns e criar um ecript para atualizar de 5 em 5 min....

    da uma olhada nesses post.. funciona blz.. Under-Linux.org Fóruns - Resultados da Pesquisa
    Valew mesmo kra, aki ja ta funcionando atraves do post que voce enviou. valew mesmo.



  7. #7

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Valew mesmo kra, aki ja ta funcionando atraves do post que voce enviou. valew mesmo.
    ola amigo como vc conseguil me explica , pois tem 2 scripts . tem que colocar eles junots separados como funciona ?
    Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki
    obriago

  8. #8

    Smile

    Citação Postado originalmente por airtonveiga Ver Post
    ola amigo como vc conseguil me explica , pois tem 2 scripts . tem que colocar eles junots separados como funciona ?
    Dynamic DNS Update Script for ChangeIP.com - MikroTik Wiki
    obriago
    Kra, muito facil, mas antes de tudo acesse o site Enhanced Dynamic DNS Solutions e cadastre um dominio p/ voce. grave seu login / senha / e dominio q escolheu.

    depois usando o winbox
    va em: system / scripts clique em + para adicionar de o nome q voce kiser e cole esse script abaixo, NAO deixe espaços em branco entre o inicio e o fim dele.

    :global ddns-user "coloque seu login do changeip"
    :global ddns-pass "sua senha do changeip"
    :global ddns-host "o seu dominio por exemplo: mikrotik.changeip.net"
    :global ddns-interface "aki é o adaptador ethernet q da o acesso a internet ao MK - Link de internet"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info [ /tool dns-update name=$ddns-host address=[..pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    }
    }

    OK deixe o resto como esta. Quase Pronto, script criado agora crie a atualizaçao automatica abaixo:

    va em system/schedule + para adicionar

    e apenas cole esse script:

    / system scheduler
    add name="Changeip" on-event="/system script run ChangeIp" start-time=startup \
    interval=10m comment="" disabled=no

    Ok e é so testar.

    Meu MK é a versao 2.9.27

    Uso o link velox como Bridge que é authenticado pelo proprio MK entao nao sei se uma conexao diferente da minha funciona tb, creio q sim. e so colocar o 4 dados corretos No primeiro script.

    Vlw

    Informe se funcionou.
    Fui
    Última edição por letec2000; 08-02-2008 às 11:47.



  9. #9

    Padrão

    valew amigo muito obrigado , tah bem mastigado rssss
    vou testar a noite e depois falo se funcionou
    T+

  10. #10

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Kra, muito facil, mas antes de tudo acesse o site Enhanced Dynamic DNS Solutions e cadastre um dominio p/ voce. grave seu login / senha / e dominio q escolheu.

    depois usando o winbox
    va em: system / scripts clique em + para adicionar de o nome q voce kiser e cole esse script abaixo, NAO deixe espaços em branco entre o inicio e o fim dele.

    :global ddns-user "coloque seu login do changeip"
    :global ddns-pass "sua senha do changeip"
    :global ddns-host "o seu dominio por exemplo: mikrotik.changeip.net"
    :global ddns-interface "aki é o adaptador ethernet q da o acesso a internet ao MK - Link de internet"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info [ /tool dns-update name=$ddns-host address=[..pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    }
    }

    OK deixe o resto como esta. Quase Pronto, script criado agora crie a atualizaçao automatica abaixo:

    va em system/schedule + para adicionar

    e apenas cole esse script:

    / system scheduler
    add name="Changeip" on-event="/system script run ChangeIp" start-time=startup \
    interval=10m comment="" disabled=no

    Ok e é so testar.

    Meu MK é a versao 2.9.27

    Uso o link velox como Bridge que é authenticado pelo proprio MK entao nao sei se uma conexao diferente da minha funciona tb, creio q sim. e so colocar o 4 dados corretos No primeiro script.

    Vlw

    Informe se funcionou.
    Fui
    Galera, restartei o meu MK, e esse schedule que fiz acima nao esta atualizando o scrip changeip. alguem conhece um comando que atualize na boa ?



  11. #11

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Galera, restartei o meu MK, e esse schedule que fiz acima nao esta atualizando o scrip changeip. alguem conhece um comando que atualize na boa ?

    Brow post como vc fez o schedule pra vermos pois ele funcionar blz... deve ter algo errado

  12. #12

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    Brow post como vc fez o schedule pra vermos pois ele funcionar blz... deve ter algo errado
    ta desta forma:

    / system scheduler
    add name="changeip" on-event="/system script run changeip" start-time=startup \
    interval=10m comment="" disabled=no



  13. #13

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    ta desta forma:

    / system scheduler
    add name="changeip" on-event="/system script run changeip" start-time=startup \
    interval=10m comment="" disabled=no

    Obs: o add name tem que ser iguazinho o nome do script que vc criou.. ex. meu script é DDNS então o meu Scheduler ficou assim:

    / system scheduler
    add name="DDNS" on-event="/system script run DDNS" start-date=jan/31/2008 \
    start-time=21:55:00 interval=5m comment="" disabled=yes

  14. #14

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    Obs: o add name tem que ser iguazinho o nome do script que vc criou.. ex. meu script é DDNS então o meu Scheduler ficou assim:

    / system scheduler
    add name="DDNS" on-event="/system script run DDNS" start-date=jan/31/2008 \
    start-time=21:55:00 interval=5m comment="" disabled=yes
    Ok, acho que entendi irei testar. No caso entao onde esta DDNS eu troco pelo nome do meu script !? certo ?



  15. #15

    Padrão

    Citação Postado originalmente por letec2000 Ver Post
    Ok, acho que entendi irei testar. No caso entao onde esta DDNS eu troco pelo nome do meu script !? certo ?

    Sim............

  16. #16

    Padrão

    Citação Postado originalmente por Shturbo Internet Ver Post
    oche então é mais facil.. ja ta tudo liberado... basta vc fazer um cadastro no ddns e criar um ecript para atualizar de 5 em 5 min....

    da uma olhada nesses post.. funciona blz.. Under-Linux.org Fóruns - Resultados da Pesquisa

    Esse link deste post ñ funga +, teria como enviar outro post ou tuto, por favor ? Tks



  17. #17

    Padrão

    Faça com este script:

    :log info "DDNS: Begin"
    :global ddns-user "login de acesso ao changeip"
    :global ddns-pass "senha"
    :global ddns-host "dominio criado no changeip"
    :global ddns-interface "Placa de rede com Conexao a internet"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"


    a Carinha q aparece é um : e o p juntos.
    Última edição por letec2000; 10-03-2008 às 09:12.

  18. #18

    Padrão

    Como eu acesso ele de fora agora, acesso o site pego o ip e digito no winbow ?