+ Responder ao Tópico



  1. #1
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Cache Full MK3.x

    Olá Alexandre, estou com problemas. Enquanto estava com a versão 2.9.27 do MK o cache full do seu video tava funcionando blz, mas agora com MK3.2 ou 3.3 nao funciona mesmo no log aparecendo como HIT ele nao faz cache full. Gostaria de saber se pode me ajudar, precisava solucionar esse problema. Creio que deve ser alguma configuração que deve mudar. Aguardo restorno e desde já agradeço.

  2. #2

    Padrão opa

    ola minelli tava com o mesmo problema ai resolvi fazer testes e mais testes e cheguei a isso

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content=!X-Cache:HIT \
    disabled=no new-connection-mark=cache_hit passthrough=yes protocol=tcp \
    src-port=3126
    add action=mark-packet chain=output comment="" connection-mark=cache_hit \
    disabled=no new-packet-mark=cachefull passthrough=no



  3. #3
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy Full MK 3.x

    Ai parece que vc marca td q ñ for HIT qd na verdade temos de marcar td que for HIT. Mas vou testar.....
    E resolveu 100%, la pelas 20:00 vou fazer a alteração e depois posto o resultado....
    Última edição por minelli; 18-02-2008 às 18:18.

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy Full MK 3.x

    Valeu agradeço mesmo....., pessoal realmente com essas modificações funcionou blzinha...... Mas que ñ entendi pq ñ entendi pois a logica foi alterada....



  5. #5

    Padrão Finalmente Funcionou

    Eniak cara MUITO OBRIGADO, Finalmente vi esse tal Cache Full Funcionando. voce poderia postar aqui suas regras ou enviarme por email para [email protected] para a versão 2.9.50 pois até hj assisto o video do alexandre todo dia mas nao vi isso funcionar ainda...

  6. #6

    Padrão

    Citação Postado originalmente por eniak Ver Post
    ola minelli tava com o mesmo problema ai resolvi fazer testes e mais testes e cheguei a isso

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content=!X-Cache:HIT \
    disabled=no new-connection-mark=cache_hit passthrough=yes protocol=tcp \
    src-port=3126
    add action=mark-packet chain=output comment="" connection-mark=cache_hit \
    disabled=no new-packet-mark=cachefull passthrough=no


    Olá!!


    E o resto da regra...isso é só a marcação do mangle...


    Queria o resto da regra para analizar, você pode postar


    Abração.



  7. #7
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy Full - Alexandre

    Roberto vc quer para o MK 2.9.xx ou MK 3.xx pq tem diferença.

  8. #8

    Padrão Proxy Full

    Citação Postado originalmente por minelli Ver Post
    Roberto vc quer para o MK 2.9.xx ou MK 3.xx pq tem diferença.
    Cara vc poderia postar ambas as versoes, aqui testei a que tinha com o seu mangle e funcionou em parte depois tive alguns problemas e tive de desativar.... por favor poderia postar as 2 pois tnho 1 maquina com a 2.9.50 e outra com a 3.3... POR FAVOR..

    Estou aguardando sua ajuda....

    Fiz como o video manda mas nao funcionou na minha 2.9.50..

    OBRIGADO



  9. #9

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Roberto vc quer para o MK 2.9.xx ou MK 3.xx pq tem diferença.


    Olá Rodrigo!!


    Eu também tenho os dois, pode ser...

  10. #10
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Proxy Full MK 2.9.xx e MK 3.x

    Ai pessoal ta na mão.

    MK 2.9.xx
    /ip firewall mangle
    add action=mark connection chain=output coment=X-Cache: Hit disable=no new-connection-mark=squid_hit passthrough=yes protocol=tcp src-port=8080

    add action=mark packet chain=output connection-mark=cache_hit disable=no new-packet-mark=cache full passthrough=yes

    /ip queue tree
    name=Squid parent=global-out packet-mark=cachefull queue-type=ethernet-default Priorit=8

    MK 3.x

    /ip firewall mangle
    add action=mark-connection chain=output content=!X-Cache:HIT disabled=no new-connection-mark=cache_hit passthrough=yes protocol=tcp src-port=8080

    add action=mark-packet chain=output connection-mark=cache_hit disabled=no new-packet-mark=cachefull passthrough=no

    /ip queue tree
    name=squid parent=global-out packet-mark=cachefull queue type=ethernet-default Priorit=8

    ***Obs.:
    1 - Pessoal onde tá 8080 vc deve colocar a porta que vc selecionou no seu web-proxy.
    2 - O valor da Prioridade dada no Queue Tree depende de cada estrutura.
    3 - Pessoal fiquem atento quanto a velocidade no QUEUE TREE notem que no meu casso está unlimited, mas cada um deve adaptar a regra ao sua estrutura.


    Última edição por minelli; 20-02-2008 às 11:22.