Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Cenário: tenho um fedora 7 com postfix + dovecot instalado.
    Esse servidor está atras de um link speedy, roteado por um router da linksys. Nesse router existe um direcionamento de ip para a porta 25 e porta 110, os dois, apontados para o ip inválido do server.
    Se precisar de mais algum detalhe, me avise...

    Abaixo, o arquivo de configuração:

    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.4.5/samples
    readme_directory = /usr/share/doc/postfix-2.4.5/README_FILES
    smtpd_sasl_local_domain =
    broken_sasl_auth_clients = yes
    smtp_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8, 192.168.0.0/24, 200.206.136.5
    smtpd_tls_auth_only = no
    smtpd_use_tls = yes
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    smtpd_sasl_authenticated_header = yes
    home_mailbox = Maildir/
    mailbox_command =
    mydestination = $myhostname, localhost.$mydomain, $mydomain
    smtpd_recipient_restrictions = permit_mynetworks reject_unauth_destination reject_unknown_reverse_client_hostname check_relay_domains
    smtpd_sasl_auth_enable = yes

    De 0 a 10, meus conhecimentos em Linux é 1, só consegui fazer essa configuração seguindo um tuto q achei na internet.
    Obrigado....

  2. Parece que seu arquivo me parece okay, assim em termos de relay pelo menos e algumas configurações... qual é a configuracao do seu dominio? o encaminhamento de porta no router esta realmente funcionando? Verifique as configurações de DNS para o seu dominio, uma das formas pode ser esta. Acho que tem um site bacana para testar algumas coisas de dominio... é www.dnsstuff.com se nao me falha a memoria.



  3. poderia ser problema de dns reverso?
    testei no Terra - Postmaster e diz q há um erro... olha o resultado do teste:

    1) Verificando o DNS reverso do IP [200.206.136.5]:
    $ host 200.206.136.5
    5.136.206.200.in-addr.arpa domain name pointer 200-206-136-5.speedyterra.com.br.


    Resultado: OK, o IP [200.206.136.5] resolve para um host válido [200-206-136-5.speedyterra.com.br.].

    2) Verificando o DNS direto do host [200-206-136-5.speedyterra.com.br.]:
    $ host 200-206-136-5.speedyterra.com.br.
    Host 200-206-136-5.speedyterra.com.br not found: 3(NXDOMAIN)


    Resultado: ERRO, o host [200-206-136-5.speedyterra.com.br.] não resolve para o IP [200.206.136.5].

  4. O reverso esta okay, o "direto" (okay nao eh esse nome, mas vai dar para entender) que nao esta... geralmente se nao resolver o dns o servidor de email nao aceita.. os relativamente bem configurados... e se o dns reverso nao bater com o host tambem nao aceita (esses sao os mais enjoados... o meu nao caso )

    Entao muitos problemas podem ser esses no seu caso. Quanto ao seu IP tudo tranquilo, mas assim, para qual dominio o seu postfix esta recebendo mensagens? Se voce nao tiver um dominio o negocio nao funcionaria bem assim... nao sei mais talvez voce esteja fazendo de uma maneira erronea a configuracao do postfix para o seu setup... o qual eu ainda nao sei qual é de fato.



  5. o meu servidor recebe emails do dominio esquemauniversitario.com.br.
    o host do meu servidor é mail.esquema...
    mas esse host não existe criado.
    No entando, o MX está apontando para o ip do meu servidor (na verdade aponta para o ip válido da minha rede, e chega até meu servidor através de um direcionamento, lembra?)
    o mais estranho é q, por exemplo, pro hotmail envia normal, para o terra não, para o gmail não....
    será q é por causa do "direto" então? e como resolver isso?






Tópicos Similares

  1. Qmail nao envia e nao recebe
    Por pixe00 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-05-2007, 14:38
  2. POSTFIX não envia emails nem recebe
    Por LinuxKids no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-10-2006, 14:39
  3. Postfix não envia e nem recebe emails
    Por PDP-7 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-01-2005, 20:39
  4. Servidor nao envia e nem receb E-mails
    Por Kernel-Panic no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-06-2004, 13:40
  5. postfix não envia e nem recebe e-mail acima de 10MB, como eu
    Por Leyzem no fórum Servidores de Rede
    Respostas: 4
    Último Post: 16-03-2003, 11:51

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L