Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    problema resolvido.

    ip firewall mangle
    chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=rota_http passthrough=yes
    chain=prerouting routing-mark=rota_http action=mark-routing new-routing-mark=rota_http passthrough=yes

    ip route
    add gateway=seu gateway mark=rota_http

    pulo do gato:
    se adicionar essa regra no servidor e tiver rodando hotspot na interface onde deseja marcar os pacotes entao eh necessario desmarcar o proxy transparente no users profiles... abraços

  2. #22

    Padrão

    Pra mim funcionou aqui desse jeito, na tabela mangle criei a marcação da rota como bancos e na tabela Nat criei um Nat pra rota default que ja existe lá em ip routes só que marcando a tabela "bancos" dessa forma funcionou todos os bancos aqui:

    ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=bancos passthrough=no comment="bancos" disabled=no

    ip firewall nat
    add chain=srcnat routing-mark=bancos action=masquerade comment="Bancos" disabled=no

    Espero ter ajudado!!



  3. #23

    Padrão

    Amigo, me interessei no seu LB, como ele funciona?
    vc tem que adicionar os gateways manualmente para cada cliente, ou ele é automático?

    Citação Postado originalmente por cleciorodrigo Ver Post
    Amigos boa tarde, pessoal tenho um balanceamento rodando aqui com 2 ADSL, funcionando td perfeito, MSN, orkut, navegação porem agora tenho um cliente usando o site do Bradesco e não consegui, pois o IP muda durante a sessão de acesso ao Site. Alguem tem uma dica ai pra poder me ajudar, abaixo segue as informações de configuração do meu servidor Mikrotik

    ENDEREÇAMENTO IP


    ROTAS


    MANGLE


    NAT


    Abraços

    Clecio

  4. #24

    Padrão

    Amigos,
    Estou tentando fazer um LoadBalance a cerca de uns 3 dias... rs.. to meio perdido.. já li bastante coisa no fórum e este post foi até agora o mais específico para o meu caso. Olhei as configurações do nosso amigo Clecio, que abriu o post, e fiz exatamente igual (claro que adaptando à minha rede), mas não consigo fazer o balanceamento funcionar.
    Entretanto, vale dizer que há alguns ítens diferentes na minha rede:
    - tenho 3 links dedicados de 2Mbs da Telefonica, que já estão balanceados no meu roteador, então utilizo em meu servidor um IP público e fixo por onde já trafego os 6Mbs.
    - estou adicionando em minha rede + 2Mbs de outra prestadora, que também me fornecerá um IP público e fixo.
    - preciso juntar esses 6Mb que já tenho com mais esses 2Mb novos no meu server Mk.
    - meu pc que está com Mk só está com 2 placas de rede: uma para clientes e outra para o link. Estou adicionando os dois IPs públicos dos links na mesma interface.. será que isso pode estar impedindo o balanceamento de funcionar?
    - utilizo PPPoE para os clientes... teria algum problema?

    Serei muito grato a quem puder me ajudar... estou realmente muito perdido...
    Obrigado a todos,
    Att
    Ricardo



  5. #25

    Padrão

    Amigo mande o seguinte aqui pra nois

    Link 1
    IP
    Mascara
    Gateway

    Link 2
    IP
    Mascara
    Gateway

    Servidores de DNS
    DNS
    DNS

    Clientes
    Range do Pool PPPoE

    Abraços

    Clecio

    Citação Postado originalmente por ricardofjayme Ver Post
    Amigos,
    Estou tentando fazer um LoadBalance a cerca de uns 3 dias... rs.. to meio perdido.. já li bastante coisa no fórum e este post foi até agora o mais específico para o meu caso. Olhei as configurações do nosso amigo Clecio, que abriu o post, e fiz exatamente igual (claro que adaptando à minha rede), mas não consigo fazer o balanceamento funcionar.
    Entretanto, vale dizer que há alguns ítens diferentes na minha rede:
    - tenho 3 links dedicados de 2Mbs da Telefonica, que já estão balanceados no meu roteador, então utilizo em meu servidor um IP público e fixo por onde já trafego os 6Mbs.
    - estou adicionando em minha rede + 2Mbs de outra prestadora, que também me fornecerá um IP público e fixo.
    - preciso juntar esses 6Mb que já tenho com mais esses 2Mb novos no meu server Mk.
    - meu pc que está com Mk só está com 2 placas de rede: uma para clientes e outra para o link. Estou adicionando os dois IPs públicos dos links na mesma interface.. será que isso pode estar impedindo o balanceamento de funcionar?
    - utilizo PPPoE para os clientes... teria algum problema?

    Serei muito grato a quem puder me ajudar... estou realmente muito perdido...
    Obrigado a todos,
    Att
    Ricardo

  6. #26

    Padrão

    Obrigado pela atenção amigo. Segue abaixo o que vc solicitou:

    Link 1
    IP 201.63.25.254
    Mascara 255.255.255.252
    Gateway 201.63.25.253

    Link 2
    IP 200.196.84.10
    Mascara 255.255.255.0
    Gateway 200.196.84.1

    Servidores de DNS
    DNS 201.63.25.253
    DNS 200.196.66.30

    Clientes
    Range do Pool PPPoE: 30.20.10.0/24



    Estive pensando.. como meus links são de temanhos diferentes.. será que seria melhor eu balancear por serviços, isto é, destinar algumas portas para o link2?

    Mais uma vez muito obrigado,
    Abs



  7. #27

    Padrão

    Estou analisando este post:

    https://under-linux.org/forums/mikro...e-2-links.html

    referente ao balanceamento por serviços.... estou até criando as regras... e até agora está funcionando.. mas o problema é que não sei se realmente está saindo pelo outro link, devido ao fato de estar td na mesma eth e não ter como eu ver o tráfego separado...

  8. #28

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Estou analisando este post:

    https://under-linux.org/forums/mikro...e-2-links.html

    referente ao balanceamento por serviços.... estou até criando as regras... e até agora está funcionando.. mas o problema é que não sei se realmente está saindo pelo outro link, devido ao fato de estar td na mesma eth e não ter como eu ver o tráfego separado...

    essa forma ae acima normalmente eh feita antes do balance para poder rodar os sites seguros e entre outros, e detalhe desse tipo de balance postado pelo clecio amigao meu ae, estudei um pouco sobre o script e consegui rodar links de operadoras distintas e de velocidades diferentes tambem, basta somente por exemplo se 2 link de 2 megas e 1 de 4 megas, por 1 regra pra cada link fazendo marcacao por igual no caso seria 3 links 3 regras no mangle, adicionando 1 regra a mais e dando a mesma rota para o link de 4 megas entao seria o seguinte, para melhor entender, nesse script estou usando 4 links 3 de 2 megas e 1 de 8 megas:


    0 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,0
    action=mark-connection new-connection-mark=primeiro passthrough=yes
    1 chain=prerouting in-interface=Proxy connection-mark=primeiro
    action=mark-routing new-routing-mark=primeira_rota passthrough=no
    2 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,1
    action=mark-connection new-connection-mark=segundo passthrough=yes
    3 chain=prerouting in-interface=Proxy connection-mark=segundo
    action=mark-routing new-routing-mark=segunda_rota passthrough=no
    4 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,2
    action=mark-connection new-connection-mark=terceiro passthrough=yes
    5 chain=prerouting in-interface=Proxy connection-mark=terceiro
    action=mark-routing new-routing-mark=terceira_rota passthrough=no
    6 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,3
    action=mark-connection new-connection-mark=quarto passthrough=yes
    7 chain=prerouting in-interface=Proxy connection-mark=quarto
    action=mark-routing new-routing-mark=quarta_rota passthrough=no
    8 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,4
    action=mark-connection new-connection-mark=quinto passthrough=yes
    9 chain=prerouting in-interface=Proxy connection-mark=quinto
    action=mark-routing new-routing-mark=quinta_rota passthrough=no
    10 chain=prerouting in-interface=Proxy connection-state=new nth=5,1,5
    action=mark-connection new-connection-mark=sexto passthrough=yes
    11 chain=prerouting in-interface=Proxy connection-mark=sexto
    action=mark-routing new-routing-mark=sexta_rota passthrough=no


    ip route


    2 ADC dst-address=10.110.0.0/16 pref-src=10.110.0.2 interface=wlan0 scope=10 target-scope=0
    3 ADC dst-address=10.111.0.0/16 pref-src=10.111.0.2 interface=wlan1 scope=10 target-scope=0
    4 ADC dst-address=10.112.0.0/16 pref-src=10.112.0.2 interface=wlan2 scope=10 target-scope=0
    5 ADC dst-address=10.113.0.0/24 pref-src=10.113.0.2 interface=wlan3 scope=10 target-scope=0
    6 A S dst-address=0.0.0.0/0 gateway=10.111.0.1 interface=wlan1 gateway-state=reachable scope=255 target-scope=10
    routing-mark=segunda_rota
    7 A S dst-address=0.0.0.0/0 gateway=10.112.0.1 interface=wlan2 gateway-state=reachable scope=255 target-scope=10
    routing-mark=terceira_rota
    8 A S dst-address=0.0.0.0/0 gateway=10.110.0.1 interface=wlan0 gateway-state=reachable scope=255 target-scope=10
    routing-mark=primeira_rota
    9 A S dst-address=0.0.0.0/0 gateway=10.113.0.1 interface=wlan3 gateway-state=reachable scope=255 target-scope=10
    routing-mark=quarta_rota
    10 A S dst-address=0.0.0.0/0 gateway=10.113.0.1 interface=wlan3 gateway-state=reachable scope=255 target-scope=10
    routing-mark=sexta_rota
    11 A S dst-address=0.0.0.0/0 gateway=10.113.0.1 interface=wlan3 gateway-state=reachable scope=255 target-scope=10
    routing-mark=quinta_rota
    12 A S dst-address=0.0.0.0/0 gateway=10.112.0.1 interface=wlan2 gateway-state=reachable scope=255 target-scope=10

    deu pra entender ae ?? dessa forma o peso maior fica em cima do 10.113.0.1, qualquer duvida pergunte pois nao sei se compliquei ou expliquei algo por aqui
    abraços



  9. #29
    Avatar de evil_inside
    Ingresso
    Aug 2004
    Localização
    Bagé, Rio Grande do Sul, Brazil, Brazil
    Posts
    275

    Padrão

    nao consegui entender direito o nth
    aqui eu tenho 3 links de 2mb, usei nth=2,1,0, nth=2,1,1 e nth=2,1,2
    aparentemente está balanceando ok, usa parelho os 3 links, acompanhei o uso por snmp nos modems, só q tem horas que parece q trava tudo, estou usando mk 2.9.27

    depois de ficar meio travado abre umas paginas rapido e depois volta a se perder

    minhas regras:
    /ip firewall mangle
    0 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,0 action=mark-connection new-connection-mark=link1 passthrough=yes
    1 chain=prerouting in-interface=bridge1 connection-mark=link1 action=mark-routing new-routing-mark=link1 passthrough=no
    2 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,1 action=mark-connection new-connection-mark=link2 passthrough=yes
    3 chain=prerouting in-interface=bridge1 connection-mark=link2 action=mark-routing new-routing-mark=link2 passthrough=no
    4 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,2 action=mark-connection new-connection-mark=link3 passthrough=yes
    5 chain=prerouting in-interface=bridge1 connection-mark=link3 action=mark-routing new-routing-mark=link3 passthrough=no


    o resto está como todos estao fazendo nos posts anteriores

  10. #30

    Padrão

    Citação Postado originalmente por evil_inside Ver Post
    nao consegui entender direito o nth
    aqui eu tenho 3 links de 2mb, usei nth=2,1,0, nth=2,1,1 e nth=2,1,2
    aparentemente está balanceando ok, usa parelho os 3 links, acompanhei o uso por snmp nos modems, só q tem horas que parece q trava tudo, estou usando mk 2.9.27

    depois de ficar meio travado abre umas paginas rapido e depois volta a se perder

    minhas regras:
    /ip firewall mangle
    0 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,0 action=mark-connection new-connection-mark=link1 passthrough=yes
    1 chain=prerouting in-interface=bridge1 connection-mark=link1 action=mark-routing new-routing-mark=link1 passthrough=no
    2 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,1 action=mark-connection new-connection-mark=link2 passthrough=yes
    3 chain=prerouting in-interface=bridge1 connection-mark=link2 action=mark-routing new-routing-mark=link2 passthrough=no
    4 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,2 action=mark-connection new-connection-mark=link3 passthrough=yes
    5 chain=prerouting in-interface=bridge1 connection-mark=link3 action=mark-routing new-routing-mark=link3 passthrough=no


    o resto está como todos estao fazendo nos posts anteriores
    cara, com essa versão do mikrotik é duro, hein?

    não por ser pirata, mas pelo tanto de bug existente.

    as vezes as configurações podem até estar corretas, mas por algum bug no sistema elas não funcionam.



  11. #31

    Padrão

    Citação Postado originalmente por evil_inside Ver Post
    nao consegui entender direito o nth
    aqui eu tenho 3 links de 2mb, usei nth=2,1,0, nth=2,1,1 e nth=2,1,2
    aparentemente está balanceando ok, usa parelho os 3 links, acompanhei o uso por snmp nos modems, só q tem horas que parece q trava tudo, estou usando mk 2.9.27

    depois de ficar meio travado abre umas paginas rapido e depois volta a se perder

    minhas regras:
    /ip firewall mangle
    0 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,0 action=mark-connection new-connection-mark=link1 passthrough=yes
    1 chain=prerouting in-interface=bridge1 connection-mark=link1 action=mark-routing new-routing-mark=link1 passthrough=no
    2 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,1 action=mark-connection new-connection-mark=link2 passthrough=yes
    3 chain=prerouting in-interface=bridge1 connection-mark=link2 action=mark-routing new-routing-mark=link2 passthrough=no
    4 chain=prerouting in-interface=bridge1 connection-state=new nth=2,1,2 action=mark-connection new-connection-mark=link3 passthrough=yes
    5 chain=prerouting in-interface=bridge1 connection-mark=link3 action=mark-routing new-routing-mark=link3 passthrough=no


    o resto está como todos estao fazendo nos posts anteriores


    qual modem vc esta usando ? pois tenho notado nesse tipo de balance que quando 1 dos modens trava a navegacao fica lenta, pq o trafego tenta sair pelo modem travado dando perda no pacote, mas no proximo pacote consegue resposta pois o outro modem esta de pe, avendo trafego em todos os modens fica normal o balance. esperimenta usar os speedtremm 4200 que eh show de bola. abraços

  12. #32
    Avatar de evil_inside
    Ingresso
    Aug 2004
    Localização
    Bagé, Rio Grande do Sul, Brazil, Brazil
    Posts
    275

    Padrão

    tenho uma rb aqui c/ mikrotik 3, vou configurar e fazer com ela p/ testar
    uso modems speedstream 4200, quando usava eles separados nunca teve problema de travamento