+ Responder ao Tópico



  1. #1

    Padrão Acessar meu MK via Winbox usando um cadastro no DDNS.

    Bom dia a todos..
    Gostaria de saber como eu faço para estar acessando meu servidor MK da minha empresa, estando em minha residencia usando o meu cadastro DDNS "escritorio.ddns.com.br" por eu nao ter ip fixo.
    Estou precisando bastante dessa ajuda.

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Winbox DDNS

    No lugar do IP no winbox vc põe seu endereço DDNS. Por Ex.: escritorio.ddns.com.br



  3. #3

    Padrão

    Muito obrigado.
    E no MK como eu faço para configurar, como eu faço para configurar as regras para eu poder acessar?.

    Citação Postado originalmente por minelli Ver Post
    No lugar do IP no winbox vc põe seu endereço DDNS. Por Ex.: escritorio.ddns.com.br

  4. #4

    Padrão script

    faz ai uma busca no forum

    tem um script para rodar ddns no mk



  5. #5

    Padrão

    Eu vi um e fiz mas nao deu certo..

    Citação Postado originalmente por iceboxrj Ver Post
    faz ai uma busca no forum

    tem um script para rodar ddns no mk

  6. #6

    Padrão

    DNS - Dinamico_acesso_remoto
    --------------------------------------------------------------------
    Dynamic DNS Update Script for ChangeIP.com
    From MikroTik Wiki
    Jump to: navigation, search
    The following script should be created when you wish to update your ChangeIP.com Dynamic DNS account. Once created you should schedule this to run once in a while. The :global variables should be edited to include your unique username and password, interface name, etc.
    :log info "DDNS: Begin"
    :global ddns-user "YOURUSERID"
    :global ddns-pass "YOURPASSWORD"
    :global ddns-host "*1"
    :global ddns-interface "EXACTINTERFACENAME"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"



  7. #7

    Padrão

    vc tem de ter atenção
    existem dos scripts para o mikrotik

    um para a versao 2.0
    que é esse que o amigo postou ai anteriormente


    e um outro para a versao 3.0


    :global ddnsuser "USER"
    :global ddnspass "PWD"
    :global ddnshost "my.dyn.ip"
    :global ddnsip
    :global ddnslastip [:tostr [:resolve $ddnshost] ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface "SUA_INTERFACE_PPOE"
    :global ddnssystem ("mt-" . [/system package get system version] )

    :local int

    :local ddnsipfn [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    :global ddnsip [ick $ddnsipfn 0 [:find $ddnsipfn "/"]]

    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }


    Abraços

  8. #8

    Padrão

    Blza agora onde eu coloco esse scripts..

    Citação Postado originalmente por iceboxrj Ver Post
    vc tem de ter atenção
    existem dos scripts para o mikrotik

    um para a versao 2.0
    que é esse que o amigo postou ai anteriormente


    e um outro para a versao 3.0


    :global ddnsuser "USER"
    :global ddnspass "PWD"
    :global ddnshost "my.dyn.ip"
    :global ddnsip
    :global ddnslastip [:tostr [:resolve $ddnshost] ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface "SUA_INTERFACE_PPOE"
    :global ddnssystem ("mt-" . [/system package get system version] )

    :local int

    :local ddnsipfn [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    :global ddnsip [ick $ddnsipfn 0 [:find $ddnsipfn "/"]]

    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }


    Abraços



  9. #9
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão

    Pessoal pra nao aparecer essas carinhas o texto (smiles) qdo for postar marquem em baixo de opçoes diversas a ultima caixa desativar smiles fica mais facil de entender o script, que ai nao aparece akela carinha chata no script falow abraços

  10. #10
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Olá,

    se você estiver usando ADSL ou banda larga terá problemas se o modem estiver roteado, pois o NAT pode está fechando o acesso externo ao Mikrotik. Além das regras de acesso externo no Mikrotik terá abrir a porta do NAT no modem e redirecioná-la ao Mikrotik.



  11. #11

    Padrão

    Muito obrigado, qual porta no modem eu abro para o Mikrotik. Vou ter que fazer alguma configuração no nat do MK ou é somente fazer oq falaram anteriormente sobre o script?

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Olá,

    se você estiver usando ADSL ou banda larga terá problemas se o modem estiver roteado, pois o NAT pode está fechando o acesso externo ao Mikrotik. Além das regras de acesso externo no Mikrotik terá abrir a porta do NAT no modem e redirecioná-la ao Mikrotik.

  12. #12
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Olha,

    terá de redirecionar do modem as portas que o seu Mikrotik for usar para acesso remoto (as que estiverem no script do MK), por exemplo: 8291, 4040 (radios), 23 (telnet).



  13. #13

    Padrão

    Citação Postado originalmente por jwjunior Ver Post
    Bom dia a todos..
    Gostaria de saber como eu faço para estar acessando meu servidor MK da minha empresa, estando em minha residencia usando o meu cadastro DDNS "escritorio.ddns.com.br" por eu nao ter ip fixo.
    Estou precisando bastante dessa ajuda.

    brow segue ecripr disponibilizado no site da MK e no forum

    segue o script

    :log info "DDNS: Begin"
    : global ddns-user "meu usuario"
    :global ddns-pass "minha senha"
    :global ddns-host "meu domínio"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    va no site do changerip se cadastre...

  14. #14

    Padrão

    Muito obrigado, quando chegar em casa vou fazer..

    Citação Postado originalmente por Shturbo Internet Ver Post
    brow segue ecripr disponibilizado no site da MK e no forum

    segue o script

    :log info "DDNS: Begin"
    : global ddns-user "meu usuario"
    :global ddns-pass "minha senha"
    :global ddns-host "meu domínio"
    :global ddns-interface "pppoe-out"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    va no site do changerip se cadastre...



  15. #15

    Padrão

    Citação Postado originalmente por jwjunior Ver Post
    Muito obrigado, quando chegar em casa vou fazer..
    De nada, abraços