+ Responder ao Tópico



  1. #1

    Exclamation Script no MK 3.7 Não Funciona Socorro !!!

    Atualizei meus 2.9.51 para 3.7 e meus scripts não funcionaram
    mais !
    no terminal funciona
    /ip route enable 3
    ou
    /ip route set 3 disable=yes
    Mas no Run Script eles não funcionão !!!

    usei o comando export
    a regra esta assim
    add name="enablelink" policy=ftp,reboot,read,write,policy ,test,winbox,password,sniff source="/ip firewall mangle \
    set 31 disable=no\r\n\r\n\r\n"

    ou assim pelo print

    name="enablelink" owner="admin" policy=ftp,reboot,read,write,policy ,test,winbox,password,sniff
    last-started=apr/30/2008 22:35:35 run-count=123 source=
    /ip firewall mangle set 31 disable=no



    Eu preciso que o intem 31 seja abilitado e desabilato pelo gerenciador de script pois uso netwatch

    Nenhum dos Amigos pode tirar um tempinho para me ajudar a resolver meu problema com esse meu miKrotik
    na Verdade são 3 !

    Ja recorri ate o site da representate do mikrotik no Brasil
    Mas so me deram um retorno generico

    Mandaram eu procurar na documentação do 3.x mas acontece que la nao tem nada sobre o 3.x sobre a parte do script !

    ja to a uma semana garimpado no google e nada so o que eu acho são mais outros com esse mesmo problema !

  2. #2

    Padrão

    amigo script funciona sim, é que teve uma grande mudança dos script da versao 2.9 para a versao 3, vou posta pra vc 2 regras aki pra vc entender como funcionar agora pra vc ativar e desativa as regras no mk 3

    /ip route enable [find comment="link2"]
    /ip route disable [find comment="link2"]



  3. #3

    Thumbs up

    Citação Postado originalmente por edielsonps Ver Post
    amigo script funciona sim, é que teve uma grande mudança dos script da versao 2.9 para a versao 3, vou posta pra vc 2 regras aki pra vc entender como funcionar agora pra vc ativar e desativa as regras no mk 3

    /ip route enable [find comment="link2"]
    /ip route disable [find comment="link2"]

    Amigo valeu por ter tirado um tempinho e postado a solução!
    São pessoas como voce que fazem o Forum crescer
    Acabou meus problemas
    Brigadão ai !

  4. #4

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Amigo valeu por ter tirado um tempinho e postado a solução!
    São pessoas como voce que fazem o Forum crescer
    Acabou meus problemas
    Brigadão ai !
    blz amigo precisando estaremos aki pra ajuda..



  5. #5

    Padrão

    Edielson c pode tirar uma duvida pra mim ???


    Eu queria saber o comando pra aumentar e diminuir a velocidade de uma simple queue por script ... tentei varios comandos mas naum funfa !

  6. #6

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Edielson c pode tirar uma duvida pra mim ???


    Eu queria saber o comando pra aumentar e diminuir a velocidade de uma simple queue por script ... tentei varios comandos mas naum funfa !
    como assim um comando?..
    vc quer saber um comando pra muda a controla de banda do cliente via script?

    mais vc cadastra manual o queues dos cliente ou é dinamic
    especifique sua necessidade para que eu posso ajuda



  7. #7

    Padrão

    Cada cliente tem uma queue q eu cadastro manualmente eu to tentando criar um script que faça a velocidade do cliente oscilar... ex: Durante 20min ela eh 200k e de 20 em mudar entre 300k e 200k, pq tem uns fominhas de link q fica 300k 24hrs sacou??? Soh consegui alterar a velocidade da queue pelo Edit no terminal, por script ainda naum !

  8. #8

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Cada cliente tem uma queue q eu cadastro manualmente eu to tentando criar um script que faça a velocidade do cliente oscilar... ex: Durante 20min ela eh 200k e de 20 em mudar entre 300k e 200k, pq tem uns fominhas de link q fica 300k 24hrs sacou??? Soh consegui alterar a velocidade da queue pelo Edit no terminal, por script ainda naum !

    /queue simple set teste max-limit=300000/300000

    teste = o nome do login
    300000 = 300k

    seria esta sua duvida?
    caso se vc quizer fazer alteração de tudo os cliente vc faz assim, comenta tudo com o mesmo comentario, e em vez de usa o nome do cliente vc coloca o nome do comentario ai ele altara tudo de uma vez que tem o mesmo nome do comentario.
    ai vc faz um agendamento pra execultar quando vc quizer...

    espero ter ajudado..