Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    Nao sei o que e GW me explica melhor pra mim poder de falar o que e?

    Por que hoje tenho um servidor de autenticação ligado no meu LINK DE DADOS, quero colocar esse servidor MK separado antes do servidor de Autenticação me explica o que precisa que te passo e o XXX e 202.

  2. #22

    Padrão

    eth0
    REDE
    10.0.0.9
    255.0.0.0
    Saida para meu servidor de Autenticação

    eth1
    LINK 2MB
    IP: 201.88.52.xxx
    GW: 201.88.52.201
    MASK: 255.255.255.252
    Portas de Navegação, DNS e VOIP

    eth2
    ADSL 8MB
    IP: 192.168.2.2
    GW: 192.168.2.1
    MASK: 255.255.255.0
    Todas as demais portas

    Assim tem todas as informações?



  3. #23

    Padrão

    Citação Postado originalmente por rfsilvagyn Ver Post
    eth0
    REDE
    10.0.0.9
    255.0.0.0
    Saida para meu servidor de Autenticação

    eth1
    LINK 2MB
    IP: 201.88.52.xxx
    GW: 201.88.52.201
    MASK: 255.255.255.252
    Portas de Navegação, DNS e VOIP

    eth2
    ADSL 8MB
    IP: 192.168.2.2
    GW: 192.168.2.1
    MASK: 255.255.255.0
    Todas as demais portas

    Assim tem todas as informações?

    balance de cargas entre os modens para a interface
    cliente que vc vai ter que alterar para sua intreface do ip 10.x.x.x

    / ip firewall mangle
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="LB Odd" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="Odd LB" disabled=no
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="LB Even" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="Even LB" disabled=no


    os links com marcaçã ode pacotes

    / ip firewall nat
    add chain=srcnat connection-mark=even action=src-nat to-addresses=201.88.52.201 to-ports=0-65535 comment="LB Redirect Even" disabled=no
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.2.1 to-ports=0-65535 comment="LB Redirect Odd" disabled=no


    as rotas e o modem patrão é o de 8 megas

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=even comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=odd comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment="LB Route No Mark" disabled=no



    aqui estou colocando o link que vc pediu para o dns que vai para o link do ip 201.x.x.x

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=DNS comment="Market packets redirect to port DNS" disabled=no



    aqui esta a marcação de pacotes dele para vc acompanhar tudo


    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=DNS passthrough=yes in-interface=clientes comment="Redirect port to DNS" disabled=no
    add chain=prerouting routing-mark=DNS action=mark-packet new-packet-mark=DNS passthrough=yes comment="Market packets to DNS" disabled=no



    se for isso mesmo que eu entendi no seu pedido

    não esquecer de agradecer...

  4. #24

    Padrão

    Meu mikrotik esta recem instalado instalei ele agora, basta rodar esse script e pronto? ou tem que fazer mais alguam coisa.

    Qual meu LINK principal nesse scprit ou nao tem LINK Principal, por que se tiver como escolher o principal quero o 201.88.52.xxx para principal?

    Tenho que fazer alguma alteração nesse script ou so rodar?



  5. #25

    Padrão

    Djjean2006, essa é a minha solução que procuro a algum tempo. MAs no meu caso o mangle não está sendo criado da forma que vc postou, uso o mikrotik versão 3.2, e no parametro nth ele só aceita 1,0 e 1,1, não aceita 1,1,0, no caso criei um com 1,0 e o segundo 1,1. Só que ele só marca o 1,0, não chega a marcar o segundo pacote, portanto ele não faz o balanceamento.. toda a carga cai em um único link e o outro fica zerado. Segue o meu script

    / ip firewall mangle
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="LB Odd" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=odd nth=1,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="Odd LB" connection-mark=odd \
    disabled=yes in-interface=clientes new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="LB Even" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=even nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="Even LB" \
    connection-mark=even disabled=yes in-interface=clientes \
    new-routing-mark=even passthrough=no

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules \
    here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=50.10.10.0/24
    add action=src-nat chain=srcnat comment="LB Redirect odd" connection-mark=odd \
    disabled=yes nth=0,0 to-addresses=201.48.16.198 to-ports=0-65535
    add action=src-nat chain=srcnat comment="LB Redirect even" \
    connection-mark=even disabled=yes to-addresses=192.168.254.254 \
    to-ports=0-65535

    /ip route
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 routing-mark=odd scope=255 target-scope=10
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=192.168.254.254 routing-mark=even scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10
    add comment="LB Route No Mark" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10

    Citação Postado originalmente por djjean2006 Ver Post
    balance de cargas entre os modens para a interface
    cliente que vc vai ter que alterar para sua intreface do ip 10.x.x.x

    / ip firewall mangle
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="LB Odd" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="Odd LB" disabled=no
    add chain=prerouting in-interface=clientes connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="LB Even" disabled=no
    add chain=prerouting in-interface=clientes connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="Even LB" disabled=no


    os links com marcaçã ode pacotes

    / ip firewall nat
    add chain=srcnat connection-mark=even action=src-nat to-addresses=201.88.52.201 to-ports=0-65535 comment="LB Redirect Even" disabled=no
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.2.1 to-ports=0-65535 comment="LB Redirect Odd" disabled=no


    as rotas e o modem patrão é o de 8 megas

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=even comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=odd comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment="LB Route No Mark" disabled=no



    aqui estou colocando o link que vc pediu para o dns que vai para o link do ip 201.x.x.x

    / ip route
    add dst-address=0.0.0.0/0 gateway=201.88.52.201 scope=255 target-scope=10 routing-mark=DNS comment="Market packets redirect to port DNS" disabled=no



    aqui esta a marcação de pacotes dele para vc acompanhar tudo


    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=DNS passthrough=yes in-interface=clientes comment="Redirect port to DNS" disabled=no
    add chain=prerouting routing-mark=DNS action=mark-packet new-packet-mark=DNS passthrough=yes comment="Market packets to DNS" disabled=no



    se for isso mesmo que eu entendi no seu pedido

    não esquecer de agradecer...
    Última edição por dougdoidao; 28-05-2008 às 17:46. Razão: inclusão de script

  6. #26

    Padrão Ajuda Load 4 ADSL 1 MB

    opa, aproveitando o tópico, tenho algumas dúvidas sobre este caso, ao colocar 4 ADSL os modens devem ficar em modo Router?
    não acontece problemas como queda de msn, site de bancos e casos tipicos de balanceamento mal feito? ja testei um equipament planet e me deu dor de cabeça, estou precisando de uma solução que funcione perfeitamente, e com o servidor configurado em pppoe para o cliente, e DHCP fixando IP pelo mac do cliente...
    se alguem tiver uma solução que funcione sem problemas ja testado em uso deixe sua experiencia



  7. #27

    Padrão

    Citação Postado originalmente por Majorred Ver Post
    opa, aproveitando o tópico, tenho algumas dúvidas sobre este caso, ao colocar 4 ADSL os modens devem ficar em modo Router?
    não acontece problemas como queda de msn, site de bancos e casos tipicos de balanceamento mal feito? ja testei um equipament planet e me deu dor de cabeça, estou precisando de uma solução que funcione perfeitamente, e com o servidor configurado em pppoe para o cliente, e DHCP fixando IP pelo mac do cliente...
    se alguem tiver uma solução que funcione sem problemas ja testado em uso deixe sua experiencia
    Meu loadbalance funciona perfeito...
    3 links... 2mb / 1mb / 1mb
    o primeiro com peso 2 e os outros com peso 1
    ou seja, o primeiro link absorve 50% do trafego e os outros 2 25% cada...
    Não tenho problemas com banco e nem com MSN...
    Os modem estão em modo router...
    Diga o que vc já fez e o que exatamente vc precisa pra gente ajudar...
    Abraços...

  8. #28

    Padrão

    dougdoidão coloque mais estas regras ai para ficar com os dois modens trabalhando.... deve ser isso que vc quer ver hehe


    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=32.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=65.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=66.232.99.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=96.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=96.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=128.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=128.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=170.66.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=189.38.18.122/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="ABUSAR" disabled=no
    add dst-address=160.0.0.0/3 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.0.0.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=200.101.81.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.128.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.140.120.29/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="MEDIDOR GRATIS" disabled=no
    add dst-address=200.141.254.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.159.128.189/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="RJ NET" disabled=no
    add dst-address=200.184.179.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.199.252.68/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.199.252.72/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.203.191.8/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.204.154.42/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.221.2.45/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.221.2.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.253.251.32/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=201.24.134.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.34.35.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.38.128.49/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK2 N REMOVER - Catolica" disabled=no
    add dst-address=201.67.44.177/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="TESTE LINK1 N REMOVER - Catolica" disabled=no
    add dst-address=206.57.4.13/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="MERCADO LIVRE" disabled=no
    add dst-address=207.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=208.65.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="YOU TUBE" disabled=no
    add dst-address=208.67.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="GOOGLE" disabled=no
    add dst-address=209.0.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="ORKUT" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link2" disabled=no


    não esquecer de agradecer isso fica bom para todos



  9. #29

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Meu loadbalance funciona perfeito...
    3 links... 2mb / 1mb / 1mb
    o primeiro com peso 2 e os outros com peso 1
    ou seja, o primeiro link absorve 50% do trafego e os outros 2 25% cada...
    Não tenho problemas com banco e nem com MSN...
    Os modem estão em modo router...
    Diga o que vc já fez e o que exatamente vc precisa pra gente ajudar...
    Abraços...

    Amigo Froyer, eu não tenho load balance aki, mas tenho acompanhado vários posts sobre esse assunto pra poder aprender um pouco mais e testar depois.
    Portanto te pergunto: vc fez utilizando o contador nth ? quais daqueles algarismos definem o peso que devo colocar em tal link ? ( no seu caso deve ter sido: 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3 ? ) ou o peso é conseguindo repetindo a regra de mark-routing ? Por favor ainda não conseguí captar e entender muito bem o mecanismo de funcinamento do nth em função do peso.
    Se puder contribuir com meu estudo, ficaria muito grato.

    Abç,

  10. #30

    Padrão

    Citação Postado originalmente por iron Ver Post
    Amigo Froyer, eu não tenho load balance aki, mas tenho acompanhado vários posts sobre esse assunto pra poder aprender um pouco mais e testar depois.
    Portanto te pergunto: vc fez utilizando o contador nth ? quais daqueles algarismos definem o peso que devo colocar em tal link ? ( no seu caso deve ter sido: 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3 ? ) ou o peso é conseguindo repetindo a regra de mark-routing ? Por favor ainda não conseguí captar e entender muito bem o mecanismo de funcinamento do nth em função do peso.
    Se puder contribuir com meu estudo, ficaria muito grato.

    Abç,
    Exatamente....
    No mangle vc marca cada nova conexão e rota com os contadores 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3....
    No Nat vc faz o seguinte:
    chain=srcnat connection-mark=con310 action=src-nat to-addresses=172.16.1.1 to-ports=0-65535
    chain=srcnat connection-mark=con311 action=src-nat to-addresses=172.16.2.1 to-ports=0-65535
    chain=srcnat connection-mark=con312 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    chain=srcnat connection-mark=con313 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    Esses endereços ips são os endereços que vc atribuiu para cada interface em que está ligado cada link (no meu caso tenho 3 placas de rede, uma para cada link, mas vc pode tbm ligar os 3 links num hub e ligar em uma interface apenas no mkt loadbalance.. a vantagem de vc ter uma placa para cada link é que vc pode monitorar o consumo de cada link independentemente)
    Observe que os contadores nth 312 e 313 estao apontando para a mesma interface 172.16.3.1 (é aqui e depois no /ip route que ele faz o peso 2)...
    Entendeu?
    Abs



  11. #31

    Padrão

    Citação Postado originalmente por djjean2006 Ver Post
    balanciamento

    / ip firewall mangle
    add chain=prerouting in-interface=ether1 connection-state=new nth=3,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="LB Odd" disabled=no
    add chain=prerouting in-interface=ether1 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="Odd LB" disabled=no
    add chain=prerouting in-interface=ether1 connection-state=new nth=3,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="LB Even" disabled=no
    add chain=prerouting in-interface=ether1 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="Even LB" disabled=no
    add chain=prerouting in-interface=ether1 connection-state=new nth=3,1,2 action=mark-connection new-connection-mark=odd1 passthrough=yes comment="LB Odd1" disabled=no
    add chain=prerouting in-interface=ether1 connection-mark=odd1 action=mark-routing new-routing-mark=odd1 passthrough=no comment="Odd LB1" disabled=no
    add chain=prerouting in-interface=ether1 connection-state=new nth=3,1,3 action=mark-connection new-connection-mark=even1 passthrough=yes comment="LB Even1" disabled=no
    add chain=prerouting in-interface=ether1 connection-mark=even1 action=mark-routing new-routing-mark=even1 passthrough=no comment="Even LB1" disabled=no

    os modems

    / ip firewall nat
    add chain=srcnat connection-mark=even action=src-nat to-addresses=192.168.1.1 to-ports=0-65535 comment="LB Redirect Even" disabled=no
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.2.1 to-ports=0-65535 comment="LB Redirect Odd" disabled=no
    add chain=srcnat connection-mark=even1 action=src-nat to-addresses=192.168.3.1 to-ports=0-65535 comment="LB Redirect Even1" disabled=no
    add chain=srcnat connection-mark=odd1 action=src-nat to-addresses=192.168.4.1 to-ports=0-65535 comment="LB Redirect Odd1" disabled=no

    e a net lembrando que o modem padão é o 192.168.1.1 que vai ser o principal
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark=even comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=odd comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 routing-mark=even1 comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.4.1 scope=255 target-scope=10 routing-mark=odd2 comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 comment="LB Route No Mark" disabled=no

    não esqueça de agradecer
    obrigado
    Otimo topico irmão, voce poderia me ajudar com o meu loadbalace eu quero usar dois Adsl no meu serve.

    Ele esta com autentição para os usuarios e o IP e 10.0.0.2 modem 01 e 10.0.0.3 modem 02, ele tem que esta roteados ou nao?

    Muito grato Deus te faça feliz.

  12. #32

    Padrão

    Citação Postado originalmente por lucart Ver Post
    Obrigado amigo!
    Os IPS dos 4 modens são o seguinte:

    Modem 1 Adsl 2.272mb 192.168.1.1
    Modem 2 Adsl 2.272mb 192.168.2.1
    Modem 3 Adsl 2.272mb 192.168.3.1
    Modem 4 Adsl 1024mb 192.168.4.1

    Interface de Rede Local 192.168.0.1/24

    Obs. O link 1 fica vairando de 2 a 4mb e por isso coloquei ele a 2mb.

    Obrigado!
    Amigao, quantos clientes vc consegue atender com esses 4 links???



  13. #33

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Exatamente....
    No mangle vc marca cada nova conexão e rota com os contadores 3,1,0 / 3,1,1 / 3,1,2 / 3,1,3....
    No Nat vc faz o seguinte:
    chain=srcnat connection-mark=con310 action=src-nat to-addresses=172.16.1.1 to-ports=0-65535
    chain=srcnat connection-mark=con311 action=src-nat to-addresses=172.16.2.1 to-ports=0-65535
    chain=srcnat connection-mark=con312 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    chain=srcnat connection-mark=con313 action=src-nat to-addresses=172.16.3.1 to-ports=0-65535
    Esses endereços ips são os endereços que vc atribuiu para cada interface em que está ligado cada link (no meu caso tenho 3 placas de rede, uma para cada link, mas vc pode tbm ligar os 3 links num hub e ligar em uma interface apenas no mkt loadbalance.. a vantagem de vc ter uma placa para cada link é que vc pode monitorar o consumo de cada link independentemente)
    Observe que os contadores nth 312 e 313 estao apontando para a mesma interface 172.16.3.1 (é aqui e depois no /ip route que ele faz o peso 2)...
    Entendeu?
    Abs

    Maravilha Froyer, só faltava isso pra clarear as coisas aki, fiquei matutando muito tempo pra pra achar isso em posts de outros colegas, que a pesar de terem link de velocidades diferentes observei q estão dividindo a carga de forma igual em todos kkk, daí acabei ficando confuso nessa questão.
    Quanto a utilizar uma interface pra cada link, realmente fica fácil de "ver" o consumo de cada um, massss, por outro lado, se eu tiver apenas uma interface com os links ligados pelo switch, posso acreditar tb que o que aparece lá tá pesando igual em todos eles...
    Enfim meu muito obrigado pela contribuição, a cada dia aprendo um pouquinho por aki.
    Grande abraço,

  14. #34

    Padrão

    Citação Postado originalmente por djjean2006 Ver Post
    dougdoidão coloque mais estas regras ai para ficar com os dois modens trabalhando.... deve ser isso que vc quer ver hehe


    / ip route
    add dst-address=16.0.0.0/4 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=32.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=65.0.0.0/8 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=66.232.99.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=64.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=96.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=96.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=128.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="SITES INTERNACIONAIS" disabled=no
    add dst-address=128.0.0.0/3 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=170.66.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=189.38.18.122/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="ABUSAR" disabled=no
    add dst-address=160.0.0.0/3 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.0.0.0/24 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=200.101.81.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.128.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.140.120.29/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="MEDIDOR GRATIS" disabled=no
    add dst-address=200.141.254.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.159.128.189/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="RJ NET" disabled=no
    add dst-address=200.184.179.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.199.252.68/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.199.252.72/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.203.191.8/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.204.154.42/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=200.221.2.45/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.221.2.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=200.253.251.32/32 gateway=192.168.254.254 scope=255 \
    target-scope=10 comment="link2" disabled=no
    add dst-address=201.24.134.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.34.35.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=201.38.128.49/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="TESTE LINK2 N REMOVER - Catolica" disabled=no
    add dst-address=201.67.44.177/32 gateway=192.168.1.254 scope=255 \
    target-scope=10 comment="TESTE LINK1 N REMOVER - Catolica" disabled=no
    add dst-address=206.57.4.13/32 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="MERCADO LIVRE" disabled=no
    add dst-address=207.0.0.0/8 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="link2" disabled=no
    add dst-address=208.65.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="YOU TUBE" disabled=no
    add dst-address=208.67.0.0/16 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="GOOGLE" disabled=no
    add dst-address=209.0.0.0/24 gateway=192.168.254.254 scope=255 target-scope=10 \
    comment="ORKUT" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.1.254 scope=255 target-scope=10 \
    comment="link1" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 distance=2 scope=255 \
    target-scope=10 comment="link2" disabled=no


    não esquecer de agradecer isso fica bom para todos
    Djjean2006, só pra ver se eu entendi, nesse caso, eu dividir algum tráfego de alguns servidores e enviar cada um para um link específico, isso? E nesse caso eu não precisaria daquelas marcações de pacotes que fiz anteriormente.
    Seria isso? E no caso, o restante não marcado, cai no link principal normalmente.
    ps: Uso autenticação via hotspot para meus clientes.
    Grato.



  15. #35

    Padrão

    Citação Postado originalmente por dougdoidao Ver Post
    Djjean2006, só pra ver se eu entendi, nesse caso, eu dividir algum tráfego de alguns servidores e enviar cada um para um link específico, isso? E nesse caso eu não precisaria daquelas marcações de pacotes que fiz anteriormente.
    Seria isso? E no caso, o restante não marcado, cai no link principal normalmente.
    ps: Uso autenticação via hotspot para meus clientes.
    Grato.

    correto serão divididos. as marcação são obrigatorias. sim os demais sempre vai cair no principal

  16. #36

    Padrão

    Citação Postado originalmente por iron Ver Post
    Maravilha Froyer, só faltava isso pra clarear as coisas aki, fiquei matutando muito tempo pra pra achar isso em posts de outros colegas, que a pesar de terem link de velocidades diferentes observei q estão dividindo a carga de forma igual em todos kkk, daí acabei ficando confuso nessa questão.
    Quanto a utilizar uma interface pra cada link, realmente fica fácil de "ver" o consumo de cada um, massss, por outro lado, se eu tiver apenas uma interface com os links ligados pelo switch, posso acreditar tb que o que aparece lá tá pesando igual em todos eles...
    Enfim meu muito obrigado pela contribuição, a cada dia aprendo um pouquinho por aki.
    Grande abraço,
    De nada amigo.. precisando é só falar...



  17. #37

    Thumbs up Load com 4 links de 1MB

    na verdade eu tenho hoje 6 links de 1MB ADSL, e uso um link para cada servidor, cada um com uma nat diferente na rede como por exemplo 10.1.1.0/24, 10.2.2.0/24, 10.3.3.0/24, faço controle de MAC amarrado ao IP, etc, desta forma fica complicado de trabalhar pois tenho varios computadores para gerenciar e alimentar com no-break, mais manutenção, tentei utilizar o equipamento planet com 4 wan mas tive diversos problemas com quedas de msn e bancos.
    Outro problema que verifiquei é que os modens configurados como router travam, hoje eu uso em todos Speed Stream 4200 ADSL2 em bridge com discagem pelo MK, tem servidor que esta a 3 meses sem cair a internet. Minha dúvida é a seguinte, como não existe placa mãe com 7 slot pci para fazer tudo em um servidor só, queria saber qual a solução para concentrar esses links em um ou dois servidores no máximo, e se possivel como configurar em um servidor PPPoE para atender todos os meus clientes em uma maquina única com ou sem cache full sem ocorrer lentidão no servidor devido a requisição de dados a um único HD. Qual configuração de hardware ideal para um servidor para 300 clientes, hoje tenho 105 mas pretendo chegar a 300 ou mais, o que vocês aconselham eu fazer. Obrigado por me ajudarem...

  18. #38

    Padrão

    Olha Majorred, realmente, se não fosse esse problema dos modems travarem seria muito simples, apenas colocá-los como router e juntar tudo com um switch + a interface de entrada do MK, pronto vc só teria um server fazendo tudo blz..
    Muito curioso, sempre ouví falar maravílhas desse speed stream mas nunca experimentei usar um, tenho aki dois D-link roteados, que há muitos meses não travam ( deve ser sorte ) kkk.
    Então pelo q entendí cada link seu atende a um grupo de clientes ??
    Comenta aí como estão suas configurações..

    Abç,



  19. #39

    Padrão

    Majorred
    isso mesmo amigo posta ai suas regras de configuraçoes
    pq esta ai seria muito legal aqui no forum poste as regras para estudar este caso seu
    eu tenho dois servidores com 4 links mais todos estão em load...
    e estou com 78 clientes mais tenho bagagem para mais 160 pelo que eu ja testes de meus link.

    exemplo:
    link de 1mega com proxy cada usuario com 256k= 36
    link de 2mega sem proxy cada usuario com 256k= 22
    link de 2mega com proxy cada usuario com 256k= 56

    estes testes foi realizados com clientes online durante 7 dias corridos e o maximo de clientes logados simultaneos foi 46 clientes
    para estes testes...

    imagine 4 links de 8 megas cada um

    lembrando que as maquinas que me deu o melhor desempenho foi de processadores amd os da intel chegou a força muito o processador
    devido as regras de controle usuarios....

    amd com 46 clientes processador chegou a dar 13%
    intel com 43 clientes processador chegou a dar 76%

    amd processador 3.2 939
    intel porcessador 3.0 ht

    espero ter ajudado com estes testes

  20. #40

    Padrão

    sinceramente eu ja usei D-link o 500G IV funcionava perfeito, porém os 500B ADSL 2+ um lixo, dps q mudei tudo para speed stream nunca mais tive problemas, melhor modem ADSL dps de cisco na minha opinião... bom minha configuração n tem segredo não, cada servidor fica com um link de 1MB, cada um com uma nat diferente, eu coloco um grupo de cliente em cada gateway individual, mas isso me traz muito trabalho e dispesa com energia afinal tenho 6 servidores ligados na rede, se alguem tiver experiência com load balance com ADSL e puder me ajudar a configurar um servidor só para 6 links eu faço isso e testo de madrugrada para ver se funciona bem, qual configuração recomendam usar para 300 clientes, ou melhor eu usar 6 servidores individuais mesmo?