Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #7

    Padrão

    Vc ja esta com o mikrotik com o cache ativado e funcionando?

  2. #8

    Padrão Cache Ativado

    Está ativado e funcionando. Só uma coisa, a porta ethernet do mikrotik que eu to usando para cache tem que estar enable??? Tem mais alguma regra que eu tenho que adicionar no MK que vai fazer o cache???



  3. #9

    Padrão

    Olá amigo,
    Fiz uma breve introdução de como ficaria a configuração no mikrotik. O resto é tudo normal, só seguir direitinho que tudo dá certo.

    Vamos lá:

    Para melhor organização, costumo renomear as ethers:

    /interface set ether3 name=squid
    /interface set ether2 name=internet
    /interface set ether1 name=network


    Configuramos os ips:

    /ip address add address=201.x.x.2/x interface=internet
    /ip address add address=192.168.1.254/24 interface=network


    Configuramos o gateway e o dns:

    /ip route add gateway=201.x.x.1
    /ip dns set primary-dns=201.x.x.x
    /ip dns static add name="DNS Local" address=192.168.1.254


    Configuramos o nat:

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 action=masquerade

    Configura deixo por sua conta.

    Com isto já estará funcionando para a rede 192.168.1.0/24

    Vamos fazer a rede para o linux-mikrotik:

    /ip address add address=10.1.0.1/30 interface=squid

    /ip firewall nat add chain=srcnat src-address=10.1.0.0/30 action=masquerade


    Configuração do linux:

    ifconfig eth0 10.1.0.2 netmask 255.255.255.252
    route add default gw 10.1.0.1

    No squid.conf, se estiver dando erro por causa do ip 10.1.0.1, troque:
    acl redelocal src 10.1.0.0/30
    http_access allow redelocal

    Quando ele falou em ip válido, quis dizer que o ip 201.x.x.1 não será o destino da rede quando for acessar o proxy, então deve colocar o ip 201.x.x.1 em dst address quando for fazer o redirecionamento da rede:
    /ip firewall nat add chain=dstnat src-address=10.1.1.0/24 dst-address=!201.x.x.1 protocol=tcp dst-port=80 in-interface=network action=redirect to-ports=3128

    Qualquer coisa...

  4. #10

    Padrão Nao Deu Certo

    Eu fiz o que vc disse mas nao deu certo, minha dúvida é a seguinte, como devo configurar o outro mikrotik que vai ser proxy remoto???
    Valeu!!!



  5. #11

    Padrão Agora funcionou!!!

    Pequenos detalhes.

    Eu nao havia desabilitado o cache da rb por isso nao tava funcionando, e a porta ethernet do pc que ta fazendo o cache ta configurada como enable, eu coloquei como reply-only mas n funcionou. Obrigado a todos!!!