Página 2 de 7 PrimeiroPrimeiro 123456 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    Eu tbm gostaria de saber se o ip q fica no log do squid é do cliente ou do MK, ainda mais q eu uso 2 faixas de ips nos clientes.

  2. #22

    Padrão

    Olá amigos,
    O ip que fica registrado no squid linux é o do interface ligada ao linux.



  3. #23

    Padrão

    Como deve ser a configuração para que o ip do cliente seja registrado no linux(squid), pois estou montando um squid em paralelo com MK, mais se os ips dos clientes não ficar registrado nos logs do squid, em vez de montar uma super máquina, vou montar um pczinho com windows e instalar o SysLog do MK!

  4. #24

    Padrão

    boa tarde.
    Seu tutorial esta muito bom mesmo sem palavras.
    SO ESTOU COM UM DUVIDA EM RELAÇÃO COM IP VALIDO
    PODERIA ME DAR UM EXEMPLO, MEU MK ESTA ENTRANDO LINK ATRAVES DE UM MODEM ROUTER.
    ESTA PARTE FICOU VAGA PARA MIM
    MEUS PARABENS PELO TUTORIAL

    Redirecionar a rede mikrotik-clientes para o proxy:

    /ip firewall nat chain=dstnat in-interface=network src-address=10.10.1.0/24 dst-address=!192.168.1.4 protocol=tcp dst-port=80 action=redirect to-ports=3127

    Note: A parte destacada acima indica que toda rede 10.10.1.0/24 com destino à... pela porta 80 será redirecionada para o proxy exceto o ip da interface de internet. Isto se dá porque você poderá acessar o seu servidor ou outro aparelho na rede remotamente e ser redirecionado para o proxy.



  5. #25

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Como deve ser a configuração para que o ip do cliente seja registrado no linux(squid), pois estou montando um squid em paralelo com MK, mais se os ips dos clientes não ficar registrado nos logs do squid, em vez de montar uma super máquina, vou montar um pczinho com windows e instalar o SysLog do MK!
    Configure o syslog ou o dude e veja se o proprio mikrotik não está armazenando estes dados na memoria.

  6. #26

    Padrão

    Citação Postado originalmente por angelino Ver Post
    ...
    SO ESTOU COM UM DUVIDA EM RELAÇÃO COM IP VALIDO
    PODERIA ME DAR UM EXEMPLO, MEU MK ESTA ENTRANDO LINK ATRAVES DE UM MODEM ROUTER.
    ESTA PARTE FICOU VAGA PARA MIM
    ...
    Agradeço o reconhecimento de todos.

    Ex:

    A interface que está ligada ao modem tem o seguinte endereço ip:

    /ip address add address=192.168.1.2 internet=link

    O ip da interface link que é chamado de ip válido no tutorial, mesmo que ele receba um ip que não seja. Na regra vai o ip da interface link que está conectada à Internet.

    Espero ter lhe ajudado.



  7. #27

    Padrão

    caro Mr. RG, otimo Tutor, mim esclareça so uma duvida, no caso aqui eu tenho dois links validos, fazendo um loadbalance por interface, um modem roteado e um em bridge. como devo proceder? meus clientes estao separados tb por faixa de ip 192.168.1.0 e 172.16.0.0. valeu.

  8. #28

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Deve-se observar isto:

    #Localizacao do diretorio do cache
    cache_dir ufs /var/spool/squid/ 2048 16 256

    # Localizacao do log de acesso do Squid
    cache_access_log /var/log/squid/access.log
    Parceiro digitei esse comando e apareceu um monte de "pastas"
    00 12 24 36 48 5A 6C 7E 90 A2 B4 C6 D8 EA FC
    01 13 25 37 49 5B 6D 7F 91 A3 B5 C7 D9 EB FD
    02 14 26 38 4A 5C 6E 80 92 A4 B6 C8 DA EC FE
    03 15 27 39 4B 5D 6F 81 93 A5 B7 C9 DB ED FF
    04 16 28 3A 4C 5E 70 82 94 A6 B8 CA DC EE swap.state
    05 17 29 3B 4D 5F 71 83 95 A7 B9 CB DD EF swap.state.last-clean
    06 18 2A 3C 4E 60 72 84 96 A8 BA CC DE F0
    07 19 2B 3D 4F 61 73 85 97 A9 BB CD DF F1
    08 1A 2C 3E 50 62 74 86 98 AA BC CE E0 F2
    09 1B 2D 3F 51 63 75 87 99 AB BD CF E1 F3
    0A 1C 2E 40 52 64 76 88 9A AC BE D0 E2 F4
    0B 1D 2F 41 53 65 77 89 9B AD BF D1 E3 F5
    0C 1E 30 42 54 66 78 8A 9C AE C0 D2 E4 F6
    0D 1F 31 43 55 67 79 8B 9D AF C1 D3 E5 F7
    0E 20 32 44 56 68 7A 8C 9E B0 C2 D4 E6 F8
    0F 21 33 45 57 69 7B 8D 9F B1 C3 D5 E7 F9
    10 22 34 46 58 6A 7C 8E A0 B2 C4 D6 E8 FA
    11 23 35 47 59 6B 7D 8F A1 B3 C5 D7 E9 FB
    Mais entro nelas e aparecem outras... gostaria de saber como faço pra ver esses arquivos se relamente estao no debian e se meu proxy está funcionando. Outra pergunta é: por exemplo fiz um donwload e armazenou no cache, qdo faço denovo o mesmo donwload, se eu tirar o cabo do link do mk ele deve continuar fazendo o donwload?...ja que ele está no proxy!!
    Obrigado pela Atençao de todos e desculpa a ingenuidade...



  9. #29

    Padrão

    Citação Postado originalmente por zipfile Ver Post
    caro Mr. RG, otimo Tutor, mim esclareça so uma duvida, no caso aqui eu tenho dois links validos, fazendo um loadbalance por interface, um modem roteado e um em bridge. como devo proceder? meus clientes estao separados tb por faixa de ip 192.168.1.0 e 172.16.0.0. valeu.
    /ip firewall nat add chain=dstnat dst-address=192.168.20.1-200.223.3.4 protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    O negrito representa os endereços vindo do modem.

  10. #30

    Padrão

    Citação Postado originalmente por simprao Ver Post
    ...
    gostaria de saber como faço pra ver esses arquivos se relamente estao no debian e se meu proxy está funcionando.
    ...
    Sugiro instalar um analisador de logs para o debian, sarg por exemplo.



  11. #31

    Padrão o meu fica sem controle de banda

    pessoal o negocio meu é o seguinte, eu consigo redirecionar e todos os meus clientes conseguem navegar, porem perco o controle de banda, ou seja, o pessoal fica sem controle fazendo downloads da velocidade do meu link e não do link que setei na no queues que esta setado na interface all. Poderiam me dar uma ajuda, o meu também configurei igual esta no tutorial, porem uso ip+mac não uso hotspot e nem pppoe. uso o mk versão 2.9.6

    obrigado

  12. #32

    Padrão

    Citação Postado originalmente por byosni Ver Post
    ...
    ip+mac não uso hotspot e nem pppoe. uso o mk versão 2.9.6
    ...
    Como tá a disposição dos seus endereços de rede e de sua rede?



  13. #33

    Padrão

    Colegas...como sou iniciante em linux, instalei o debian com inface grafica para facilitar meu aprendizado e instalação.
    Então achei um pacote para o squid em modo grafico tmb só q não consigo instalar ele. Dá erro na instalação...alguém pode me ajudar.
    Links:
    Linux: Configuração do Squid via modo gráfico [Dica]

    Gadmintools - GADMIN-SQUID

  14. #34

    Padrão

    Citação Postado originalmente por kryseck Ver Post
    ...
    o squid... Dá erro na instalação...alguém pode me ajudar.
    ...
    No debian você pode instalar o squid pelo comando apt-get install squid:

    Ficaria assim:
    $ sudo vi /etc/apt/sources.list
    Tire os comentários # deb... ficando deb...

    $ sudo apt-get update

    $ sudo apt-get install squid

    Depois é só configurar.



  15. #35

    Padrão esta assim

    Citação Postado originalmente por Mr. RG Ver Post
    Como tá a disposição dos seus endereços de rede e de sua rede?
    interface wan 200.xxx.xxx.xxxx
    interface LAN 192.168.32.0/24
    192.168.65.0/24
    interface proxy 10.10.10.0/30

    seria isto que vc esta perguntando?
    obrigado.

  16. #36

    Padrão

    Citação Postado originalmente por byosni Ver Post
    interface wan 200.xxx.xxx.xxxx
    interface LAN 192.168.32.0/24
    192.168.65.0/24
    interface proxy 10.10.10.0/30
    ...
    Tem alguma coisa de errado na maneira de controlar a banda. Dá um

    /queue simple print detail

    Para vermos suas configurações



  17. #37

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Tem alguma coisa de errado na maneira de controlar a banda. Dá um

    /queue simple print detail

    Para vermos suas configurações
    name="jose renato" dst-address=192.168.32.3/32 interface=all parent=none priority=1 queue=default/default limit-at=512000/512000
    max-limit=512000/512000 total-queue=default

    acho que nao tem nada de errado.

  18. #38

    Padrão

    Ola...
    Meus Parabens ....segui as configurações acima e estão funcionando aki...

    Obrigado pela contribuição



  19. #39

    Padrão

    certamente meu amigo, aqui inclusive salvo meus logs assim, so que por exemplo, se eu botar um proxy no linux e por ele pra trabalhar junto com o mikrotik acho que as requisições de sites vão chegar com o ip do mikrotik e não com o ip dos clientes não é isso?

  20. #40

    Padrão

    Citação Postado originalmente por iuredaluz Ver Post
    certamente meu amigo, aqui inclusive salvo meus logs assim, so que por exemplo, se eu botar um proxy no linux e por ele pra trabalhar junto com o mikrotik acho que as requisições de sites vão chegar com o ip do mikrotik e não com o ip dos clientes não é isso?
    tente redirecionar para seu proxy por rota
    dê uma olhada:

    https://under-linux.org/forums/mikro...tml#post327832