+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por iuredaluz Ver Post
    certamente meu amigo, aqui inclusive salvo meus logs assim, so que por exemplo, se eu botar um proxy no linux e por ele pra trabalhar junto com o mikrotik acho que as requisições de sites vão chegar com o ip do mikrotik e não com o ip dos clientes não é isso?
    Isto mesmo.
    Digo para configurar o syslog porque as requisições vindas da rede podem estar na memória, já que o web-proxy está fazendo o uso da mesma.

    Depois vou fazer uns testes aqui e vejo como isto irá ficar...

  2. #42

    Padrão

    Citação Postado originalmente por byosni Ver Post
    name="jose renato" dst-address=192.168.32.3/32 interface=all parent=none priority=1 queue=default/default limit-at=512000/512000
    max-limit=512000/512000 total-queue=default

    acho que nao tem nada de errado.
    Qual sua versão do MikroTik?

    Dá uma olhada nisto

    https://under-linux.org/forums/attac...ple_queues.jpg

    Pelo que vi, você deve tá fazendo o controle pela aba advanced, certo?



  3. #43

    Padrão

    Boa Noite Mr. RG

    É possivel informar-me se existe a possibilidade de utilizar as configurações postadas, utilizando MK v3.10 + squid?

    Tenho uma config. loadbalance entre dois links que, por sinal, infelizmente um deles ñ responde.

    Enfim, ando um tanto frustrado quanto a versão 3.10.

    Podes ajudar-me?

    Se estiver faltando alguma informação diga-me por favor.

  4. #44

    Padrão

    Citação Postado originalmente por phoenixassiste Ver Post
    ...
    É possivel informar-me se existe a possibilidade de utilizar as configurações postadas, utilizando MK v3.10 + squid?
    ...
    É possível sim,
    O que não funciona, pelo que eu leio, é o cache full, mas o web-proxy sim, tanto é que muitos que usam o 3.x faz isto.



  5. #45

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Qual sua versão do MikroTik?

    Dá uma olhada nisto

    https://under-linux.org/forums/attac...ple_queues.jpg

    Pelo que vi, você deve tá fazendo o controle pela aba advanced, certo?
    amigo. meu MK é versao 2.9.6 cracked e meu queues é assim:
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         queues.JPG
Visualizações:	189
Tamanho: 	38,1 KB
ID:      	2363  

  6. #46

    Padrão

    Citação Postado originalmente por byosni Ver Post
    amigo. meu MK é versao 2.9.6 cracked e meu queues é assim:
    Mude de interface all para a interface onde o cliente tá conectado.



  7. #47

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    /ip firewall nat add chain=dstnat dst-address=192.168.20.1-200.223.3.4 protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    O negrito representa os endereços vindo do modem.
    no caso tenho que criar duas nat direcionando o endereço local para cada ip do modem no caso:
    /ip firewall nat add chain=dstnat dst-address=internface dos clientes 1- endereço do modem roteado protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    /ip firewall nat add chain=dstnat dst-address=internface dos clientes 2- endereço do modem brigid protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    agradeço

  8. #48

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Mude de interface all para a interface onde o cliente tá conectado.
    cara mudei e olha o que acontece, ele não faz o controle de banda, na queues list fica mostrando 300 bps, uma coisas de louco, eu fazia o controle de banda em interface WAN - chegada do meu link na net, ja troquei pra All pra poder fazer o controle em todas as interfaces, será que podera ter algo de errado no meu debian? alguma coisas setada errada? me add no msn pra gente se falar
    [email protected]

    Falows... segue a imagem.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         queues.JPG
Visualizações:	124
Tamanho: 	55,9 KB
ID:      	2365  



  9. #49

    Padrão

    Mr. MG

    olá, estava pensando comigo o seguinte, seria melhor ligar o squid,bfw etc.. em paralelo mandando as requisições direto pra o servidor proxy, em paralelo parenty proxy como proxy do mkt ou ligando o servidor proxy linux como roteador em bridge como o Mikrotik fazendo controle P2P(controlando o limite de conexão) e controle de banda etc..?? oou todas as opões terião o mesmo efeito que é cechear as paginas!!!

    no meu ponto de vista direcionado as requisições da porta 80 pra um servidor independente talvez ficaria melhor???não???

    valews e esse topico ficou show!!!!

  10. #50

    Padrão

    pessoal sera que ficaria melhor a navegacao ativar o servidor dns interno no proxy linux?



  11. #51

    Padrão

    Citação Postado originalmente por byosni Ver Post
    cara mudei e olha o que acontece, ele não faz o controle de banda, na queues list fica mostrando 300 bps
    ...
    Se ele estiver setado uma velocidade e baixando em outra, há sim problemas com o servidor. Você já experimentou usar a 2.9.27 ou 2.9.50?

    Citação Postado originalmente por byosni Ver Post
    uma coisas de louco, eu fazia o controle de banda em interface WAN - chegada do meu link na net, ja troquei pra All pra poder fazer o controle em todas as interfaces, será que podera ter algo de errado no meu debian? alguma coisas setada errada?
    Uma coisa que se pode fazer é deixar apenas o mikrotik funcionando para vê se é realmente alguma regra que foi setada para o debian e pode tá causando isto.

  12. #52

    Padrão

    Citação Postado originalmente por zipfile Ver Post
    no caso tenho que criar duas nat direcionando o endereço local para cada ip do modem no caso:
    /ip firewall nat add chain=dstnat dst-address=internface dos clientes 1- endereço do modem roteado protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    /ip firewall nat add chain=dstnat dst-address=internface dos clientes 2- endereço do modem brigid protocol=tcp dst-port=80 action=redirect to-ports=0-65535

    agradeço
    Pode sim.



  13. #53

    Padrão

    Citação Postado originalmente por georgegomes Ver Post
    ...
    no meu ponto de vista direcionado as requisições da porta 80 pra um servidor independente talvez ficaria melhor???não???

    ...
    Você pode deixar o mikrotik fazendo todo o QoS e o linux só para cachear as requisições vindas da porta 80.

  14. #54

    Padrão

    Como colocar um balanceamento com o proxy externo.



  15. #55

    Padrão

    Citação Postado originalmente por EdilsonLSouza Ver Post
    Como colocar um balanceamento com o proxy externo.
    Como tá o seu lb?

  16. #56

    Padrão

    Eu ainda não fiz, tenho um SQUID rodando externamente, mas eu coloquei em paralelo de forma diferente deste, funciona normalmente.

    O que fiz: criei uma rede para a máquina do squid com ARP, DHCP Client.... etc....

    No NAT eu faço assim:

    8 ;;; REGRA DO NAT
    chain=srcnat action=masquerade out-interface=LINK1

    9 ;;; SERVIDOR FEDORA: CACHE SQUID
    chain=dstnat action=dst-nat to-addresses=192.168.40.254 to-ports=3128
    src-address=192.168.20.0/24 dst-address=!192.168.40.0/24 dst-port=80
    protocol=tcp

    Até ai tudo bem, mas se coloco um LB por exemplo por rotas "nth=1,1,0 e nth=1,1,1" etc... tudo para de funcionar.... eu é que não sei mesmo fazer LB com Cache externo.



  17. #57

    Smile projetoxsquid

    oi

    da certo utilizar o proxy paralelo no projeto abaixo
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         projeto rib_ptb (squid).jpg
Visualizações:	248
Tamanho: 	62,0 KB
ID:      	2528  

  18. #58

    Padrão

    Citação Postado originalmente por jucielly Ver Post
    oi

    da certo utilizar o proxy paralelo no projeto abaixo
    Dá sim.
    Mas me diga uma coisa:
    O MK A e B estão com seus ips independentes?
    MK A = 192.168.1.x/x
    MK B = 192.168.2.x/x

    IPS estes vindo do roteador.

    Se tiver assim dá para fazer isto sim.



  19. #59

    Padrão

    Amigos, por favor me tirem uma dúvida sobre a velocidade do download:

    Se eu colocar o squid da forma passada pelos colegas, quando um usuário que tem queue de 128k baixar um arquivo de 40 megas por http (porta 80, ou seja, pelo squid), o que vai acontecer:

    - o squid vai baixar a 128k e mandar a 128k para o usuário ou
    - o squid vai baixar no máximo que der e mandar a 128k para o usuário?

    Obrigado!
    Fabricio
    Última edição por FabricioViana; 23-07-2008 às 03:32.

  20. #60

    Padrão

    ola amigos, estou com uma duvida aqui...
    vou explicar a estrutura que em penso...

    pc mk, recebendo link adsl, com hotspot, controle de banda, etc

    pc linux squid, como cliente do mk, passando por ip blinding no hotspot 'sem altenticar'

    e clientes com proxy transparante,,, usando o proxy do linux..
    e nos relatorios do proxy, serem gerados com os ips dos clientes,,, e nao com o ip do gw 'mk'
    desde ja agradeço a todos!
    vlw