+ Responder ao Tópico



  1. #81

    Padrão

    Amigo,

    pra esse tuto, qual a configuração de hardware vc utilizou pra montar esse squid ?
    Se eu colocar um nagios nessa máq. q já estar c/ squid roda s/ problemas ?

    Grato

  2. #82

    Padrão

    Citação Postado originalmente por anelmos Ver Post
    Amigo,

    pra esse tuto, qual a configuração de hardware vc utilizou pra montar esse squid ?
    Se eu colocar um nagios nessa máq. q já estar c/ squid roda s/ problemas ?

    Grato
    1GB de ram ddr
    80 GB HDD
    Intel Celeron D 2.13 Ghz



  3. #83

    Padrão

    olá amigo,

    estou com uma dúvida:

    tenho o debian linux com squid 2.7 funcionando com autenticação e acls por usuário+firewall iptables...mas estou querendo colocar com o mikrotik em paralelo para usar o cache full, como posso fazer isso e continuar com a autenticação pois o firewall eu poderia transferir para o mikrotik.

  4. #84

    Padrão

    Neste caso você terá que usar um DNAT e o squid ser um cliente do mikrotik, mesmo em redes separadas.



  5. #85

    Padrão

    no mikrotik eu rodaria oq? pensei tb em colocar o proxy autenticado para o mikorik+firewall ai nesse caso no linux teria só o cache full, sabe dizer se o mikrotik faz esse mesmo trabalho do linux de proxy autenticado com acls por usuário?

  6. #86

    Padrão

    Citação Postado originalmente por lfernandosg Ver Post
    no mikrotik eu rodaria oq? pensei tb em colocar o proxy autenticado para o mikorik+firewall ai nesse caso no linux teria só o cache full, sabe dizer se o mikrotik faz esse mesmo trabalho do linux de proxy autenticado com acls por usuário?
    Dá uma olhada neste material:

    Linux: Web proxy Mikrotik V3.XX com controle de acesso [Artigo]



  7. #87

    Padrão

    mas lá acho que não autenticação do usuário+senha e sim do scr IP.quero que o usuário logue e acesse só o que estive na sua ACL?

  8. #88

    Padrão

    Então terá que fazer um dnat para o servidor linux mesmo.



  9. #89

    Padrão

    usando o mikrotik com o hotspot não é possivel fazer esse tipo de autenticação? se não..fora o dnat para o linux o que mais vou precisar fazer já que quero ativar o cache full? nesse caso o cache full será no linux ou no mikrotik?


    vc manja bem do squid tb? se sim me tira uma dúvida, porque nos logs do meu squid não aparece o TCP_HIT que é o acesso as páginas pegando do cache? só aparece o TCP_MISS que é o acesso direto ou TCP_IMS_HITas vezes?

    tem sites como o baixaki.com.br que acesso direto e ele não tá pegando do cache e sim acessando direto sabe dizer porque? tenho 45 diretórios com diskd somando 14GB de cache mas parece que não estão sendo usado. e o log store.log que mostra os objetos em cache está limpo.
    Última edição por lfernandosg; 25-08-2008 às 17:37.

  10. #90

    Padrão

    Neste caso terá que fazer no mikrotik no mangle. Se usar o dnat, não poderá usar o web-proxy.



  11. #91

    Padrão

    certo então eu usando o squid autenticado+iptables como posso fazer o cache full nele?

  12. #92



  13. #93

    Padrão

    certo eu já tinha dado uma olhada no video do alexandre mas estou com algumas dúvidas:

    esse vídeo é para fazer marcação de pacote para fazer cache full com o proxy estando no linux?o cache full fica no linux ou no mikrotik?nao vi nada ligando o mikrotik a porta do squid.

    Acho que esse vídeo dele é para fazer cache full usando o squid sem autenticação e usando a máquina linux para fazer cache e o firewall é todo no mikrotik nao? ou posso usar o firewall do mikrotik só para marcação de pacotes+QoS para fazer o cache full no linux?
    Outra coisa, posso fazer o que tenho no htb+tc hoje que é a priorização da voz(servidor asterisk voip)dento o mikrotik ou continuo fazendo no linux?

    o tutorial do squid+htb tools é para o squid 2.6 no meu caso estou com o 2.7 e não tem o path para ele e o debian a partir do 4.0 etch já está na versão 2.7.
    Última edição por lfernandosg; 25-08-2008 às 20:53.

  14. #94

    Padrão

    Amigo Mr.RG, fis detalhadamente desta maneira de seu tuto, porém não funcionou ak.
    minha rede a seguinte:

    NET2MB >> MK >MK BRIDGE > HOTSPOT > ANTENAS > CLIENTES
    |
    DEBIAN 4 + SQUID 2.6 STABLE

    Faço tudo direitinho mas no dsnat que faz o redirect não tem trafego e mesmo tudo feito no mk a rede trabalha como se n tivesse estas regras.



  15. #95

    Padrão

    Amigo,
    Poste suas http_acccess do squid ae para olharmos, e a config do web-proxy.

  16. #96

    Padrão

    Olá galera,

    Mr. RG. por gentileza, até agora não entendi no passo 7 quem vem a ser o IP: 192.168.1.4 ???
    Poderia me dar uma luz?

    No meu caso coloquei assim:

    Passo2:

    /ip address add address=200.xxx.xxx.x55/28 interface=internet
    /ip address add address=192.168.200.1/24 interface=rede
    /ip address add address=192.168.16.1/30 interface=linux

    Dúvida:

    Passo 3: Ajustando o Gateway

    /ip route add gateway=200.221.4.1

    Minha Faixa de Ip começa em 200.xxx.xxx.48
    Meu Gateway do link Embratel (roteador cisco) é 200.xxx.xxx.49
    escolhi o IP 200.xxx.xxx.055 para link Internet.
    A saída do Squid no mikrotik é 192.168.16.1 e o endereço do Squid é 192.168.16.2

    Aonde vou aplicar 192.168.1.4 ?

    E Esse gateway 200.221.4.1 seria o do cisco 200.xxx.xxx.49 ????

    Já fiz vários testes e quando aplico o parent proxy no IP/Web Proxy/Settings, ninguém navega!

    Agradeço desde já pela sua paciência,

    Obrigado.
    Última edição por falcaobr; 30-11-2008 às 12:44.



  17. #97

    Padrão

    Amigo,
    Voce deve observar as interfaces, por elas voce pode identificar a quem pertence que rede.

    internet
    rede
    linux

  18. #98

    Padrão

    Em relacao ao passo 7
    Diz ali que o ip que eh do linux nao sera redirecionado. Se nao for feito isto, voce nao conseguirah acessar a internet.



  19. #99

    Padrão

    Eu montei o Proxy com Cache Full
    na seguinte estrutura:
    Mikrotik 3.x
    Debian 4 com Squid 2.7
    pois o squid 2.7 ele ja tem suporte à "zph"

    está funcionando 100% tanto cache normal quanto cache full

    no linux vc baixa o pacote do squid

    baixando o pacote
    [email protected]# cd /usr/src/

    wget http://mirror.aarnet.edu.au/pub/squi...STABLE5.tar.gz
    tar -zxvf squid-2.7.STABLE5.tar.gz
    cd squid-2.7.STABLE5
    ./configure
    make all
    make install

    vou preparar um material e vou postar aki depois para os amigos.... entenderem melhor

  20. #100

    Padrão

    Ola pessoal, to entrando agora no topico, desculpa qualquer ignorancia, ou preguiçar de ler...
    Mas fazendo cache full nao é so usar o Simple Queue do MK, setar la o Limits ??, ou é preciso mesmo instalr o ZPH??