+ Responder ao Tópico



  1. #1

    Padrão Ajuda urgente

    Bom dia pessoal. Esse final de semana caiu meu dns e agora preciso redirecionar todos os clientes para outro servidor dns até que eu arrume meu servidor.

    clientes--------->torre (mikrotik) ------------->dns (200.181.xxx.xxx)

    A configuração de DNS é feita no cliente com o ip 200.181.xxx.xxx

    essa é a configuração hj. Precisaria que todos os clientes que tentam consultar o dns no 200.181.xxx.xxx a torre(mikrotik) redirecionasse para ex. 192.168.0.254

    To com todo minha rede parada por causa disso.

  2. #2

    Padrão

    Olá!

    Coloque o ip do MK (gateway) como DNS primário de seus clientes, dessa forma você usará o cache de DNS do MK e quando tiver que mudar qualquer coisa no DNS não precisará mexer em nada nos seus clientes.



  3. #3

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Olá!

    Coloque o ip do MK (gateway) como DNS primário de seus clientes, dessa forma você usará o cache de DNS do MK e quando tiver que mudar qualquer coisa no DNS não precisará mexer em nada nos seus clientes.
    Roberto eu tinha entendido que o amigo queria uma solução de redirecionamento de dns interno no MK, que não fosse necessário ir na casa do cliente fazer essa alteração.

  4. #4

    Padrão

    Ele pode fazer isto adicionando um dns static no mikrotik, tipo: se ele usava tal dns ele pode colocar o mesmo como dns static mesmo que ele mude o dns primary:
    /ip dns static
    add name=192.168.0.254 address=192.168.0.254

    Sendo que o 192.168.0.254 é o que ele tem nos clientes.



  5. #5

    Padrão

    O que eu queria fazer é o que o Iron disse, ou seja redirecionar o meu dns interno sem ter que ir na casa dos clientes.

  6. #6

    Padrão

    Citação Postado originalmente por renatopissinati Ver Post
    O que eu queria fazer é o que o Iron disse, ou seja redirecionar o meu dns interno sem ter que ir na casa dos clientes.
    É isto mesmo, adicione o dns que está nos clientes como um dns static no seu servidor.



  7. #7

    Padrão

    Mr. RG não entendi como que funcionario o DNS.
    Como que eu teria que fazer para arrumar isto sem precisar ir passar cliente por cliente.

    Hoje é assim: DNS: 200.181.xxx.xxx (dns configurado no cliente)
    precisaria mudar esse dns para 192.168.0.254 sem que haja a necessidade de passar nos clientes. Ou seja lá continuaria o 200.181.xxx.xxx (mas que naverdade estaria acessando o 192.168.0.254). Resumindo o que eu queria fazer é que quando o cliente for tentar acessar o 200.181.xxx.xxx ele fosse redirecionado para 192.168.0.254.

    Ex: O cara da um ping em 200.181.xxx.xxx e quando o ping fosse passar pelo mikrotik, este o redirecionava para 192.168.0.254. Então o cliente pingava no 200.181.xxx.xxx mas quem realmente respondia era o 192.168.0.254.

  8. #8

    Padrão

    Citação Postado originalmente por renatopissinati Ver Post
    Mr. RG não entendi como que funcionario o DNS.
    Como que eu teria que fazer para arrumar isto sem precisar ir passar cliente por cliente.

    Hoje é assim: DNS: 200.181.xxx.xxx (dns configurado no cliente)
    precisaria mudar esse dns para 192.168.0.254 sem que haja a necessidade de passar nos clientes. Ou seja lá continuaria o 200.181.xxx.xxx (mas que naverdade estaria acessando o 192.168.0.254). Resumindo o que eu queria fazer é que quando o cliente for tentar acessar o 200.181.xxx.xxx ele fosse redirecionado para 192.168.0.254.

    Ex: O cara da um ping em 200.181.xxx.xxx e quando o ping fosse passar pelo mikrotik, este o redirecionava para 192.168.0.254. Então o cliente pingava no 200.181.xxx.xxx mas quem realmente respondia era o 192.168.0.254.
    Depois de configurar o primary-dns em settings:

    /ip dns static add name=200.181.xxx.xxx address=200.181.xxx.xxx

    Se não funcionar, você terá que ir de cliente a cliente, a não ser que mais alguém tenha uma solução, sem que seja fazer um servidor dns no linux.



  9. #9

    Padrão

    Eu tinha pensado em fazer algo assim.

    Criar uma regra no firewall falando o seguinte:

    Tudo que for feito um forward(repassado) da "REDE-WIRELESS" para "200.181.xxx.xxx" ele redireciona para o ip 192.168.0.254.

    Mas como fazer isso?????

  10. #10

    Padrão

    Citação Postado originalmente por renatopissinati Ver Post
    Eu tinha pensado em fazer algo assim.

    Criar uma regra no firewall falando o seguinte:

    Tudo que for feito um forward(repassado) da "REDE-WIRELESS" para "200.181.xxx.xxx" ele redireciona para o ip 192.168.0.254.

    Mas como fazer isso?????
    Olá amigo,
    Tente desta forma:

    /ip firewall nat add chain=dstnat dst-address=200.181.x.x protocol=tcp action=jump jump-target=repassar

    /ip firewall nat add chain=repassar action=dst-nat to-addresses=192.168.0.254 to-ports=x-xxx

    Lembre-se: Isto fará com que tudo destinado ao dst-address seja redirecionado para o to-address.
    Última edição por Raniel; 08-07-2008 às 19:48.



  11. #11

    Padrão

    Olá pessoal,

    Pensei bastante e a melhor solução que achei foi montar um servidor de DNS e passar na casa de todo mundo.
    Valeu pela atenção do pessoal!!!!