+ Responder ao Tópico



  1. #1

    Padrão Avast não atualiza através de squid transparente

    olha só pessoal:

    1215614161.525 3 189.10.203.25 TCP_OFFLINE_HIT/200 459 GET http://download966.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215614167.713 18 189.10.203.25 TCP_OFFLINE_HIT/200 459 GET http://download631.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215614168.292 509 189.10.203.25 TCP_MISS/200 993 GET http://download631.avast.com/iavs4x/prod-av_pro.vpu - DIRECT/74.55.74.106 application/octet-stream
    1215614190.682 24 189.10.203.25 TCP_OFFLINE_HIT/200 459 GET http://download970.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215614200.951 2 189.10.203.25 TCP_OFFLINE_HIT/200 457 GET http://download616.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215614201.026 38 189.10.203.25 TCP_OFFLINE_HIT/200 1098 GET http://download616.avast.com/iavs4x/prod-av_pro.vpu - NONE/- application/octet-stream
    1215614201.145 1 189.10.203.25 TCP_OFFLINE_HIT/200 1115 GET http://download616.avast.com/iavs4x/...ps-8062601.vpu - NONE/- application/octet-stream
    1215614202.007 714 189.10.203.25 TCP_MISS/404 587 GET http://download616.avast.com/iavs4x/vps-8062600.vpu - DIRECT/75.125.246.130 text/html
    1215614203.034 765 189.10.203.25 TCP_MISS/404 587 GET http://download504.avast.com/iavs4x/vps-8062600.vpu - DIRECT/75.126.53.170 text/html
    1215614203.782 469 189.10.203.25 TCP_MISS/404 587 GET http://download959.avast.com/iavs4x/vps-8062600.vpu - DIRECT/74.86.232.39 text/html
    1215614235.293 750 189.10.203.25 TCP_MISS/204 243 POST http://download676.avast.com/cgi-bin/iavs4stats.cgi - DIRECT/74.52.200.130 text/plain




    nada de atualizar!!!
    dah erro 403, 404 tudo que é tipo!


    unico trem que to usando é esse:
    refresh_pattern avast.com/.*\.(def|vpu|vpaa|stamp|cgi) 43200 100% 43200 reload-into-ims


    ideias?

    já fiz teste com always_direct tbm nao brilhou

  2. #2

    Padrão

    Nessas horas vale apena "tirar esse IP de destino do squid".
    Põe uma regra de iptables pro destino como accept, dessa forma o tráfego não passa pelo squid...
    Última edição por Magnun; 09-07-2008 às 15:57.



  3. #3

    Padrão

    mais ai nao cacheia tbm heheheh

  4. #4

    Padrão

    Esse é um problema... Não tinha percebido que seu objetivo era o chache... foi mal...

    Às vezes é melhor não ter cache do que não ter atualização

    Já verificou se ele abre somente a porta 80 pra isso?? Talvez esteja faltando redirecionar mais alguma coisa...



  5. #5

    Padrão

    só 80 e nao tenho nada bloqueado :/

  6. #6

    Padrão

    Arium,

    não sei como está sua configuração no avast, mas você pode tentar configurar manualmente para ele utilizar o proxy.

    Quanto ao cache, a não ser que você tenha um "maximum_object_size" grande o squid não vai gravar o arquivo no cache.



  7. #7

    Padrão

    é transparente nao precisa configurar

    to com um maximum objectsize de 64mb

    mais toda via...
    mesmo que fosse 1mb ele soh não faria cache mais teria de atualizar igual! isso que to achando estranho

  8. #8

    Padrão

    aaaagoraaa fico mais bunitoo!!!

    wireless:/home/arium# tail -f /dados/logs/squid/access.log |grep avast
    1215692614.206 12 189.10.203.20 TCP_HIT/200 4170 GET http://download653.avast.com/iavs4x/vpsm-8070901.vpu - NONE/- application/octet-stream
    1215692615.157 478 127.0.0.1 TCP_MISS/204 238 POST http://download653.avast.com/cgi-bin/iavs4stats.cgi - DIRECT/74.55.74.130 text/plain
    1215692615.157 480 189.10.203.20 TCP_MISS/204 337 POST http://download653.avast.com/cgi-bin/iavs4stats.cgi - DEFAULT_PARENT/127.0.0.1 text/plain
    1215692622.376 49 189.10.203.13 TCP_HIT/200 459 GET http://download932.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215692622.456 6 189.10.203.13 TCP_HIT/200 1097 GET http://download932.avast.com/iavs4x/prod-av_pro.vpu - NONE/- application/octet-stream
    1215692650.505 3 189.10.203.13 TCP_HIT/200 460 GET http://download970.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215692653.236 25 189.10.203.13 TCP_HIT/200 365 GET http://download956.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215692653.441 65 189.10.203.13 TCP_HIT/200 1003 GET http://download956.avast.com/iavs4x/prod-av_pro.vpu - NONE/- application/octet-stream
    1215692669.444 20 189.10.203.13 TCP_HIT/200 460 GET http://download900.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215692671.401 0 189.10.203.13 TCP_HIT/200 459 GET http://download961.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215692671.452 0 189.10.203.13 TCP_HIT/200 1003 GET http://download961.avast.com/iavs4x/prod-av_pro.vpu - NONE/- application/octet-stream
    1215692684.571 21 189.10.203.32 TCP_HIT/200 360 GET http://download675.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215692688.294 22 189.10.203.32 TCP_HIT/200 454 GET http://download901.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215692693.939 38 189.10.203.32 TCP_HIT/200 361 GET http://download205.avast.com/iavs4x/....def.vpu.stamp - NONE/- application/octet-stream
    1215692696.806 32 189.10.203.32 TCP_OFFLINE_HIT/200 456 GET http://download929.avast.com/iavs4x/..._pro.vpu.stamp - NONE/- application/octet-stream
    1215692696.935 42 189.10.203.32 TCP_OFFLINE_HIT/200 1094 GET http://download929.avast.com/iavs4x/prod-av_pro.vpu - NONE/- application/octet-stream


    hehehe

    soluciones:
    refresh_pattern avast.com/.*\.(def|vpu|vpaa|stamp|cgi) 43200 100% 43200 override-lastmod reload-into-ims


    o problema tava que eu tava usando o
    override-expire

    hehehe .. ainda tah chatinho pra atualizar! tipo tenho que tenta umas 4 vez ai ele atualiza mais acho que eh só questão de ele dah refresh em todos!

    Valeu!
    Última edição por arium; 10-07-2008 às 09:49.



  9. #9

    Padrão

    bom que tenha achado a solução!

    Mas hein... que tal você fazer um tutorial ou postar uma dica no wiki do under-linux depois com essas suas experiências com o Squid?

    Acredito que vá ser de grande ajuda para muita gente!

  10. #10

    Padrão

    com certeza maninho! assim que tiver um squid realmente bombástico irei postar.... meu squid esta legal mais preciso de alguns ajustes =D vo abusar um pokinho do teu conhecimento em perl heheheheh mais agente ageita tudo ;D ae montamos um tuto!