Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Bom, pela experiência que tenho com SQUID (8 anos) é até normal ele utilizar essa carga de processamento com muitos clientes (digo pelo menos uns 100 simultâneos).
    Aqui tenho duas máquinas Dell com 2 processadores Xeon MP 3.6 cada uma e 2GB de RAM com 4 discos SCSI de 10Krpm em 2 raids diferentes. Utilizo dois caches para utilizar corretamente os dois canais da controladora...
    Estou utilizando Red Hat AS4

    As máquinas estão balanceando o tráfego

    Tenho simultâneamente algo em torno de 2500 conexões, e o processamento tá sempre no máximo.

    Quando o tráfego cai para algo em torno de 100 usuários simultâneos, aí o processamento cai para mais ou menos 50%. Essa diferença entre o seu sistema e o meu se dá pela velocidade do processador que você utiliza em relação ao meu.

    Então sempre ví isso acontecer, tanto em debian quanto em red hat. A carga está sempre alta em cima dos processadores.

    Uma coisa que eu ajustaria, é o parâmetro
    cache_mem 64 MB (devido a sua quantidade de memória que é pouca. Esse parâmetro diz qual o cache em memória RAM que o squid fará com objetos em trânsito, então 64MB julgo que estaria ótimo)

    O seu cache em disco está marcado para 28Gigas. É isso mesmo que você quer?

  2. pode corrigir ai entao seu squid fredy,

    1.200 sessoes abertas (1200 acessos/clientes) ... processamento fica por volta dos 10%

    2 dual-opteron ... freebsd 6.3

    se co 100 users fica 50% .. teu cache ta errado

    mas.... voltando ao assunto do topico..

    o colega ai deve estar com problema de i/o no hd.. fazendo o squid trabalhar mais



  3. Citação Postado originalmente por alexandrecorrea Ver Post
    pode corrigir ai entao seu squid fredy,

    1.200 sessoes abertas (1200 acessos/clientes) ... processamento fica por volta dos 10%

    2 dual-opteron ... freebsd 6.3

    se co 100 users fica 50% .. teu cache ta errado

    mas.... voltando ao assunto do topico..

    o colega ai deve estar com problema de i/o no hd.. fazendo o squid trabalhar mais
    Não é assim não, Alexandre... O FreeBSD pode até trabalhar de forma diferente do Linux... aí já não sei.

    Mas a respeito do processamento, é super normal isso acontecer. Não só em minhas máquinas, mas na de muitos governos e empresas grandes, a qual tenho contato com os analistas.

    Minha instalação está toda homologada, inclusive pelo pessoal da RedHat USA, que foi uma obrigação na hora de instalar o Datacenter.

    Quanto aos usuários, Tenho 8.000 máquinas, mas claro que todas não acessam a internet simultaneamente. E quanto a questão de requisições que você levantou, uma mesma máquina pode (e abre) abrir várias requisições simultâneamente. Então se eu tenho 2500 requisições simultâneas, não quer dizer que eu tenha 2500 clientes navegando.

    Agora você imagina o squid passando essas 2500 requisições pela ACL a cada segundo... não acha que os 10% de processamento que você falou que ele iria utilizar é pouco?

    Não entendi direito o que você queria dizer com a frase: " se co 100 users fica 50% .. teu cache ta errado"

    O que tem a ver meu cache com o load do processador?

    A respeito dos processadores, tanto sua máquina quanto a minha, não ganham muita vantagem por ter 2 processadores e/ou vários núcleos, já que o squid é monothread. Já entrei em contato a um tempo atrás com o pessoal de desenvolvimento do SQUID e disseram que a versão 3 sairia com suporte a multithread, mas ainda não fiz os testes...



    Quanto ao assunto do tópico, pode ser um problema no HD sim... ele pode também não estar utilizando o DMA, que pode ser checado através do comando hdparm.

    Abraços
    Fredy
    Última edição por fredy10; 16-07-2008 às 16:31.






Tópicos Similares

  1. Squid Trabalhando com CPU 99%
    Por ehs171 no fórum Servidores de Rede
    Respostas: 5
    Último Post: 18-03-2010, 08:08
  2. squid usando 99% da cpu
    Por andreylch no fórum Servidores de Rede
    Respostas: 4
    Último Post: 26-09-2005, 08:05
  3. Squid consumindo muito processamento da CPU
    Por nikolas no fórum Servidores de Rede
    Respostas: 8
    Último Post: 31-03-2005, 17:50
  4. Squid não dá acesso
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 08-06-2004, 21:10
  5. histórico de uso da cpu
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-12-2002, 15:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L