Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Esse é o script que tem no forum.

    # Defina abaixo o valor mínimo de ACK
    :global ack 90;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 1;
    # Defina abaixo 1 para reiniciar a Interface quando um cliente estiver acima do valor mínimo e 0 para não fazer nada
    # Obs.: Ative apenas no último dos casos, pois derruba todos clientes enlaçados na Interface
    :global intdis 0;
    # Defina abaixo a Interface
    :global interf "wlan2";
    #-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info ("Listando Clientes com ACK acima de " . $ack . " ms:");
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :log info ("COMENTARIO: " . [/interface wireless access-list get $cliente comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    /interface wireless access-list enable $cliente;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info ("Nenhum Cliente com ACK acima de " . $ack . " ms encontrado.");
    } else {
    :if ($intdis = 1) do={
    /interface wireless disable $interf;
    /interface wireless enable $interf;
    };
    };


    Citação Postado originalmente por Gosulator Ver Post
    tem outro tópico correndo a respeito disso já, e tem um monte de informações. Tô procurando aqui no fórum do mikrotik um scrpit que eu ví, pra resetar a conexão dos clientes com ack maior do que o valor desejado, mas era um tópico antigo, e parece que foi removido

  2. heh, entendi nada.

    nessa linha:

    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={

    Eu substituo o termo "$ack" pelo valor limite de ack que eu quero que os clientes tenham?

    E no "do={", creio que seja pra designar a ação caso o script ache clientes com acks maiores do que o desejado. O que eu ponho lá?"



  3. Só altere os valores das linhas que tem #

    Citação Postado originalmente por Gosulator Ver Post
    heh, entendi nada.

    nessa linha:

    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={

    Eu substituo o termo "$ack" pelo valor limite de ack que eu quero que os clientes tenham?

    E no "do={", creio que seja pra designar a ação caso o script ache clientes com acks maiores do que o desejado. O que eu ponho lá?"

  4. Citação Postado originalmente por magal Ver Post
    Só altere os valores das linhas que tem #
    isso eu sei né...
    Dei uma olhada no script de novo, e ví que não precisa mexer em nada no script, apenas setar o valor limite de acktimeout (e talvez setar a interface pra qual o script valha). Minha questão é, na linha

    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    onde eu coloco o valor de acktimeout que eu quero? no lugar do "ack" que tem depois do > $ack
    :if ([/interface wireless registration-table get $i ack-timeout] > $60) do={
    ou eu coloco sem apagar o "ack"
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack60) do={
    Ou não é de nenhum dos dois modos?

    eu + scripts = fracasso total.



  5. Citação Postado originalmente por 1929 Ver Post
    Sim Magal, quanto ao objetivo da configuração não há a menor dúvida.

    Mas só porque me bateu a curiosidade sobre a opção dinâmica e a fixa. Na dinâmica eu entendi que sempre vai ser negociado o melhor tempo e na fixa nós iremos testando até onde der o melhor resultado.
    Então vamos a um exemplo: depois de testar vários ACK chegamos a conclusão que o melhor seria 65 por exemplo. Mas isso para aquele momento. Muitos colegas tem relatado que o desempenho da rede tem variado durante o dia em relação a noite.
    Este ajuste então seria válido para um link perfeitamente estável que é o que não parece acontecer com frequencia. Com alguma variação no link este valor poderia em outro momento estar em 50 ou em 80 vamos supor. Neste caso então o dinâmico seria o ideal.
    E para um ponto de distribuição, como dinâmico também teria mais vantagem porque assim estaria satisfazendo tanto usuários próximos como distantes.
    Então a minha dúvida é porque tem as duas opções se a dinâmica já seria suficiente para todas as situações? Isto eu não achei na pag. 1
    Se eu estiver "viajando" me corrija por favor!

    Perfeitamente entendido sobre o mecanismo do comando.
    Mas porque existe a opção de fixa e dinâmica se a dinâmica resolveria tudo?

    Para um PTP até que seria compreensível fixar o ACK, mas para distribuição o ideal é que a base esteja dinâmica e negociasse com cada usuário, perto ou distânte.
    Mas tem alguns firmwares que nem tem a opção de ACK dinâmico.






Tópicos Similares

  1. Respostas: 4
    Último Post: 27-11-2008, 15:32
  2. Respostas: 7
    Último Post: 14-11-2008, 14:33
  3. Script Controle de usuario
    Por Bruno no fórum Servidores de Rede
    Respostas: 33
    Último Post: 09-01-2003, 17:47
  4. Controle de arquivos compartilhados
    Por mirror no fórum Servidores de Rede
    Respostas: 4
    Último Post: 30-12-2002, 12:37
  5. Controle de banda
    Por ediguedes no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-06-2002, 13:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L