Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por alemao06 Ver Post
    Caro Powernet, peguei algumas informaçoes no wiki da mk, e agora ta funcionando, so não sei até quando vai funcionar, pois nao estabeleci o tamanho do meu cache, pra estabelecer o tamanho é so ir em ip>webproxy> MAX CACHE SIZE e estabelecer uma quantidade né? cara to apanhando agora pra configurar o cache na 2.9.27 hehe, ta dando dns server missing ja ouviu falar isso??? obrigado ai brother!
    Exatamente, MAX CACHE SIZE, é o tamanho do espaço em disco q o cache usará.

    A marcaçao no 2.9.27 é diferente da versao 3.xx
    testa aí pra ver

    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=proxyfull passthrough=yes \
    comment="PROXY FULL" disabled=no
    add chain=output connection-mark=proxyfull action=mark-packet \
    new-packet-mark=proxyfull passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyfull action=return comment="" \
    disabled=no



    Espero ter ajudado!!!

  2. #42

    Padrão

    Powernet!!!

    Ainda esta dando o tal do dns server missing, hehe tu tem como me passar as tuas regras do ip>webproxy?? obrigado cara!!!
    bom fim de semana!



  3. #43

    Padrão

    Citação Postado originalmente por alemao06 Ver Post
    Powernet!!!

    Ainda esta dando o tal do dns server missing, hehe tu tem como me passar as tuas regras do ip>webproxy?? obrigado cara!!!
    bom fim de semana!
    Tá aí o webproxy:
    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=40960KiB \
    cache-drive=secondary-master max-cache-size=1073741824KiB \
    max-ram-cache-size=819200KiB

    mas tente antes setar o DNS:
    / ip dns
    set primary-dns=208.67.222.222 secondary-dns=208.67.220.220 \
    allow-remote-requests=no cache-size=4096KiB cache-max-ttl=1w

  4. #44

    Padrão

    e ai parcero, com as regras de dns q vc me passou funcionou na versao 2.9.27, mas olha só, vou te passar as minhas regras das 2 versoes pra tu dar uma olhada, eu nao sei se eles estao fazendo cache do videos de youtube, eu preciso por umas regras especificas pra isso?? eu sei q ele ta funcionando pq faço o teste dos downloads.
    Aih vai as regras da 3.13:

    ip>firewall>mangle

    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; PROXY FULL
    chain=output action=mark-connection new-connection-mark=proxyfull
    passthrough=yes src-port=3128 protocol=tcp dscp=4

    1 chain=output action=mark-packet new-packet-mark=proxyfull passthrough=yes
    connection-mark=proxyfull

    interface
    2 chain=output action=return connection-mark=proxyfull
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU
    0 R ether1 ether 1500
    1 R ether2 ether 1500
    2 R wlan1 wlan 1500
    3 R BridgeWIFI bridge 1500
    4 R BridgeLAN-OUT bridge 1500

    Queue tree
    Flags: X - disabled, I - invalid
    0 name="cache full" parent=global-out packet-mark=proxyfull limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    Webproxy
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: system
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4

    muito obrigado pela atençao irmao!!

    abraço



  5. #45

    Padrão

    Citação Postado originalmente por alemao06 Ver Post
    e ai parcero, com as regras de dns q vc me passou funcionou na versao 2.9.27, mas olha só, vou te passar as minhas regras das 2 versoes pra tu dar uma olhada, eu nao sei se eles estao fazendo cache do videos de youtube, eu preciso por umas regras especificas pra isso?? eu sei q ele ta funcionando pq faço o teste dos downloads.
    Aih vai as regras da 3.13:

    ip>firewall>mangle

    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; PROXY FULL
    chain=output action=mark-connection new-connection-mark=proxyfull
    passthrough=yes src-port=3128 protocol=tcp dscp=4

    1 chain=output action=mark-packet new-packet-mark=proxyfull passthrough=yes
    connection-mark=proxyfull

    interface
    2 chain=output action=return connection-mark=proxyfull
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU
    0 R ether1 ether 1500
    1 R ether2 ether 1500
    2 R wlan1 wlan 1500
    3 R BridgeWIFI bridge 1500
    4 R BridgeLAN-OUT bridge 1500

    Queue tree
    Flags: X - disabled, I - invalid
    0 name="cache full" parent=global-out packet-mark=proxyfull limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    Webproxy
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: system
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4

    muito obrigado pela atençao irmao!!

    abraço
    Olá
    Suas regras estão corretas, como vc mesmo disse: "com as regras de dns q vc me passou funcionou"
    Sobre o youtube, até consegui armazenalo em cache mas qdo vc assiste o mesmo video novamente, ele busca na net de novo e assim tava enchendo o HD sem nenhum beneficio!
    Pelo q li, isso acontece porque o youtube tem inumeros servidores fazendo redundancia e/ou balanceamento e cada vez q vc acessa um video ele vem de um local diferente eo MK entende q este arquivo ainda naum está em cache, e o armazena novamente!!! pelo q já li aki no Under, e observando o funcionamento do Mk foi essa a conclusão q cheguei!

    Se eu estiver errado, por favor me corrijam!!!

  6. #46

    Padrão

    muito obrigado power net, ainda hj se der tempo te mando as minhas regras do 2.9.27. obrigado ai!



  7. #47

    Padrão

    Cara, mais uma duvida hehe, as regras do queue tree, da versao 2.9.27 e da 3.X sao iguais?? se tu tiver o exemplo das duas tu pode postar para mim? obrigado!

  8. #48

    Padrão

    gabriel, blz cara? tu sabe se é so uma regra do queue tree?? achei q era 3!!! so tira essa duvida pra mim



  9. #49

    Padrão

    Citação Postado originalmente por alemao06 Ver Post
    gabriel, blz cara? tu sabe se é so uma regra do queue tree?? achei q era 3!!! so tira essa duvida pra mim

    No QUEUE TREE, uso somente uma regra, que é a mesma na 2.9.xx e na 3.xx.
    Essas 3 q vc achou, devem ser em mangle!
    Mangle são 3 regras pra marcar o cache.

  10. #50

    Padrão

    Boa tarde Pessoal

    Qual a função dessa regra de return ? ele precisa ser posta junto com as outras do proxyfull ?
    tenho essas mesmas regras aqui so que sem o return e vejo que quando o pessoal baixa algum arquivo do cache o link tbem aumenta o consumo.


    Valeww



  11. #51
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Tópico

    Realmente este tópico está engraçado.......
    Bom Feliz Natal a Todos e Prospero Ano Novo.

  12. #52

    Padrão

    Pessoal pra que serve as duas opçoes q tem no web-proxy, sao elas:
    Serialize connections e Always from cache, elas tem de fica ativadas ou naum?



  13. #53

    Padrão

    uma rapida lida no manual do mikrotik ajuda...

    always-from-cache (yes | no; default: no) - ignore client refresh requests if the content is considered fresh

    ele vai ignorar um "reload forçado" pelo cliente se o proxy considerar que o(s) objeto(s) sem header 'expire' sao 'fresh' (novos)


    serialize-connections (yes | no; default: no) - Do not make multiple connections to server for multiple client connections, if possible (i.e. server supports persistent HTTP connections). Clients will be served on FIFO principle; next client is processed when response transfer to the previous one is completed. If a client is idle for too long (max 5 seconds by default), it will give up waiting and open another connection to the server

    faz as conexoes em series ... nao paralelamente (economiza recursos) porem um proxy muito movimentado (algo em torno de uns 8mb de trafego http) .. pode ter problemas de "delay" .. vale a pena testar esta funcao com um sistema de benchmark ....

  14. #54

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    uma rapida lida no manual do mikrotik ajuda...

    always-from-cache (yes | no; default: no) - ignore client refresh requests if the content is considered fresh

    ele vai ignorar um "reload forçado" pelo cliente se o proxy considerar que o(s) objeto(s) sem header 'expire' sao 'fresh' (novos)


    serialize-connections (yes | no; default: no) - Do not make multiple connections to server for multiple client connections, if possible (i.e. server supports persistent HTTP connections). Clients will be served on FIFO principle; next client is processed when response transfer to the previous one is completed. If a client is idle for too long (max 5 seconds by default), it will give up waiting and open another connection to the server

    faz as conexoes em series ... nao paralelamente (economiza recursos) porem um proxy muito movimentado (algo em torno de uns 8mb de trafego http) .. pode ter problemas de "delay" .. vale a pena testar esta funcao com um sistema de benchmark ....
    Valeu pela informção, mais nesse caso o correto é deixá-las desmarcadas ne amigo?



  15. #55

    Padrão

    amigos uso a versao 3.20 e gostaria que vcs verificassem se está correto minha configuração do meu webproxy...pelo menos aqui os pacotes estao rodando legal nao sei se vai ter algum problema de travamento pois acabei de colocar pra rodar com as regras de redirecionamento deixei to jeito que está nas configurações do amigos..

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=200000KiB max-client-connections=\
    600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=3128 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25
    add action=deny comment="" disabled=no dst-host=gateway.dll src-address=10.12.0.2
    /ip proxy cache
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"

  16. #56

    Padrão tamanho do arquivo em cache

    Eu uso aqui a versão 3.13 e essas regras do nosso amigo Gabriel funciona, só que fiquei com um dúvida sobre determinar o tamanho do arquivo a ser armazenado em cache nessa versão... pois em web proxy não tem a opção Maximum Object Size como nas versões 2.x. Teria que colocar alguma regra pra não encher rápido demais o cache? Pq deixando assim qq arquivo baixado seria armazenado no sv e gostaria de deixar no máximo 50mb. Se alguém puder ajudar desde já agradeço.
    Última edição por bodoquenanet; 26-03-2009 às 09:41.



  17. #57

    Padrão

    Ola estou usando o web proxy do mkt 3.23 por enquanto esta tudo ok.

  18. #58

    Padrão

    Citação Postado originalmente por felipim Ver Post
    Ola estou usando o web proxy do mkt 3.23 por enquanto esta tudo ok.

    Ola, Felipim
    Se possivel poste suas configurações completas pra nos por favor.
    = Mangle
    = Filters
    = Queue Tree
    = Cache
    = Proxy
    e se tiver mais alguma coisa que esqueci, favor acrecente estará tirando a duvida de muitos pois também estou com essa versão e ainda não está 100% tem horas que fica full mas tem horas que não então não sei se tem alguma regra bloqueando no filters.