+ Responder ao Tópico



  1. #1

    Padrão Fazer loadbalance com 2 modens adsl em bridge

    Olá Amigos!
    Tenho aqui dois modens com 2 adsl's em bridge, estava funcionando por rotas no meu mk tranquilo.. meu amigo tinha vindo aqui para fazer isso e ele fez pegando o gw e colocando lá em route.
    Agora que mudei os planos das duas adsl passando para 2 mb, o load não está mais funcionando, apenas a adsl 1 tá passando, e onde era o ip da adsl 2 no route ficou como unknown...
    Gostaria de saber com vocês a melhor maneira de fazer esse balanceamento com os 2 modens em bridge...

    Valeu, abração!

  2. #2

    Padrão

    Olá, seguinte ....
    Se os dois modens ( linhas ) forem da mesma operadora, será impossóvel vc fazer o load balance como seu amigo fez pra vc, pois com os modens em modo bridge o mk irá autentica-los e dae terão o mesmo gateway para o mk gerenciar o que impossibilita seu load funcionar. Você pode deixar um em modo bridge e outro roteado , dae funciona perfeito. Se vc ja tem o load ae é ir em ip address e setar o ip pra interface certa e pronto.



  3. #3

    Padrão load balance

    Companheiro eu fiz a seguinte regra:
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=255 target-scope=10 \
    routing-mark=link1 comment="Pacotes marcados redirecionados para o link1" \
    disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.251.254 scope=255 target-scope=10 \
    routing-mark=link2 comment="Pacotes marcados redirecionados para o link2" \
    disabled=no

    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Portas redirecionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=1863 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=6891 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados do Link2" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link1 passthrough=yes \
    comment="Pacotes marcados do Link1" disabled=no
    add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="Portas redirecionada para o link1" disabled=no
    add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=1080 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp p2p=all-p2p action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="p2p 1 redirecionado link1" disabled=no

    dai ele ficou bakana e tudo mais mas eh o seguinte ele tah funcionando como marcador de pacotes....
    ele funciona certinho sem dar problemas....
    e tem um ele tbm esta com cache full
    aki eu uso 2 links adsl de 4mb cada um e o troço tah bombando....
    e tem mais 4 torres e tah sussi.....
    sei lah c pra vc vai interessar mais tah ai....
    faloww
    abraços

  4. #4

    Padrão

    Então amigos, aqui parece que a BrT tem 3 gateways, eu mudei hoje cedo a rota pro gateway que estava e funcionou até atarde, e agora tá com um gateway que nunca tinha visto, estranho que quando ativo a ppp2 fica muito lento.. ta com uma adsl por enquanto. Mas amigo ramm, essa regra funciona com modem em bridge? e essa parte 'gateway=192.168.15.254' , é o ip configurado do modem, certo? Desculpe, mas não entendo muito dessa parte de LB..
    estarei testando amanha essa regra..

    Obrigado!



  5. #5

    Padrão

    sim
    essa regra eh pra modem em brigde....
    dai vc deixa ele com o dhcp desativado...
    dai ele funciona sim
    tipo deixe ele assim 10.1.1.1 e o outro 10.1.2.1 da funciona sussi
    pq dai vc vai usar o seguinte lah no adress vc coloca assim 10.1.1.0/24 e aplica e o outro vc coloca 10.1.2.0/24 dai roda sussi mas da certo sim pq o meu tah assim qlqr duvida me avise q dai eu posso ajudar
    teh mais

  6. #6

    Padrão

    Ah sim, a regra vai direcionar apenas os links né.. muitíssimo obrigado amigo, irei tentar amanha cedo..

    qualquer coisa meu msn eh [email protected]
    mto obrigado mesmo, depois posto o resultado..



  7. #7

    Padrão

    aham isso msm eu fiz terça pra quarta e funfo sim qlqr coisa me add ai [email protected]
    valeu.... qlqr coisa eu configuro o adsl pra vc

  8. #8

    Padrão

    balanceamento por NTH com 3 modens em bridge... tem como???



  9. #9

    Padrão

    Se os modens forem de gateway ( operadoras ) diferentes sim. Senão for, so um em bridge e os outros em modo router.

  10. #10

    Padrão

    Citação Postado originalmente por GEISSONHUGO Ver Post
    balanceamento por NTH com 3 modens em bridge... tem como???
    Se os gateways forem direferentes, sim.



  11. #11

    Padrão

    muito obrigado... eh q eu tenho gateways iguais.... entaum vou ter que colocar alguma coisa roteando... pq modem roteando perde um pouco de desempenho..