+ Responder ao Tópico



  1. #1

    Padrão Redirecionar Cliente para outra rota;;;

    Pessoal eu tenho um mikrotik com webproxy e adquiri um link eu gostaria de saber como eu faço pra redirecionar TODO o tráfego de um cliente para esta rota nova ... nao quero que ele passe pelo webproxy !

  2. #2

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Pessoal eu tenho um mikrotik com webproxy e adquiri um link eu gostaria de saber como eu faço pra redirecionar TODO o tráfego de um cliente para esta rota nova ... nao quero que ele passe pelo webproxy !
    Poderá usar a mesma teoria, fazendo apenas o grupo para o ip desejado.

    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]



  3. #3

    Padrão

    Consegui redirecionar o trafego, exceto o do Webproxy ... tudo que eh proxy tah passando pelo link principal ... mas eu gostaria que naum passasse ... que fosse tudo direto no link secundario !

  4. #4

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Consegui redirecionar o trafego, exceto o do Webproxy ... tudo que eh proxy tah passando pelo link principal ... mas eu gostaria que naum passasse ... que fosse tudo direto no link secundario !
    cara essa solução faz tempo q to precisando!
    caso um expertao saiba manda pra min ai tbem



  5. #5

    Padrão

    eh fiz uns testes aki umas duas horas ... regras e bla bla bla e naum consegui nada !

  6. #6

    Padrão

    Faça de tal forma:

    /ip firewall mangle chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=nova passthrough=yes

    / ip route add dst-address=0.0.0.0/0 gateway=novarotaip check-gateway=ping scope=255 target-scope=10 routing-mark=nova disabled=no



  7. #7

    Padrão

    Amigo vou testar ... de qualquer jeito muito obrigado ... por ter se interessado em me ajudar !

  8. #8

    Padrão

    Nao funcionou !

    Obrigado !

    Tipo ... quero que todo o tráfego desse link novo saia pelo ip 192.168.254.250 .... sacou ???



    Fiz as seguintes regras ...

    / ip route
    add dst-address=192.168.254.248/30 pref-src=192.168.254.249 gateway=192.168.0.1 check-gateway=ping distance=0 scope=255 \
    target-scope=10 routing-mark=nova comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=nova passthrough=yes comment="" \
    disabled=no


    Nao funcionou !
    Última edição por admskill; 25-08-2008 às 11:33.



  9. #9

    Padrão

    Poxa, será que eu vou ter que colocar outro servidor só pra atender esses dois clientes pra esse link novo ??

  10. #10



  11. #11

    Padrão

    vou dar uma olhadinha !


    Abraços !

  12. #12

    Padrão

    Amigo, não consegui ! Acho que esse tutorial nao tem o conteudo que eu preciso !



  13. #13

    Padrão

    Alguém se prontifica a me dar uma luz ???

  14. #14

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Pessoal eu tenho um mikrotik com webproxy e adquiri um link eu gostaria de saber como eu faço pra redirecionar TODO o tráfego de um cliente para esta rota nova ... nao quero que ele passe pelo webproxy !
    admskill, dê mais detalhes das suas configurações, num primeiro momento, isso que vc quer me parece bem simples, tenho 3 links aki e faço isso aqui de uma forma bem simples e fácil...
    Mas não uso proxy separado, só tenho um server MK sem hotspot e pppoe, só mesmo MAC/IP.

    Abç,



  15. #15

    Padrão

    Bom ... deixa eu te explicar direitinhu ...

    Tenho dois LInks dedicados ...

    Um que eh o principal vem pelo range de ips : 192.168.2.100 e o secundário vem pelo range de ips 192.168.1.1 ... esses são meus Gateways ...

    O link principal que é a rota 192.168.2.100, eh o que atende todo mundo está rodando redondinho com o Web-Proxy e Parent proxy ... esse link secundário que eu contratei são para três empresas e eu queria que essas três empresas recebecem esse link puro ... sem passar pelo webproxy ... entendeu ??? Esse grupo de três usuários teriam que receber essa conexão purissima ... sem passar pelo webproxy para não sobrecarregar minha rota principal que eh a 192.168.2.100 ... jah fiz um porradão de regra e naum tem me dado resultado !

  16. #16

    Padrão

    Cara, não sei se vai te ajudar, mas aki tenho 2 adsl numa interface e 1 dedicado em outra interface, aqui só deixo passar pelo web-proxy os clientes de uma rede que usam o link principal, mas esse detalhe não importa...

    As info que pedí a vc eram as de marcação e de rota, mas vamos lá: O que fiz é bastante trivial e pra mim tá redondo.

    Nesse seu segundo link, suponho que vc esteja marcando a rota em mangle e apontando para o gw específico lá em /IP routes, aqui pra mim bastou abrir a regra de NAT que redireciona a porta 80 para a porta 3128 (web-proxy), em General, lá em baixo tem Routing Mak, você seleciona a rota que vc NÃO quer que passe pelo proxy e assinala com ( ! ) no quadrinho ao lado. Pronto, apartir daí todas as conexões marcadas com essa rota sairá pelo gw designado em /ip routes e sem passar pelo proxy.

    Ainda tem outra forma de fazer que testei hoje de manhã, que é assinalando em src address os ip´s ou a rede que eu quero q passe pelo web-proxy e pronto tb funcionou blz.

    Mas testaí e conta pra gente se deu certo, qquer dúvida....

    Abç,



  17. #17

    Padrão um problema parecido

    ola iron cara me ajuda com o seguinte se vc souber ...... e bem parecido com que vem sendo discutido nesse topico

    o seguintre nao quero load balance nem nada do tipo o que pressiso e o seguite

    fazer um roteamento pela origem
    ex:
    sempre que a rede do meu cliente 192.168.0.X/24 quizer ir para ( internet 0.0.0.0 ) deve sair pelo gw 200.253.251.1
    agora se a red efor 10.10.0.X/24 e quizer para ( internet 0.0.0.0) deve sair pelo gw 189.90.16.20


    e asim por diante eu fazia isso usando ipfw no freebsd agora que to querendo colocar mikrotik to nessa pendenga ........



    vlw quem puder ajudar .............

  18. #18

    Padrão

    OK leo,

    O que vc precisa está aki nesse tópico:

    https://under-linux.org/forums/mikro...as-eficaz.html

    Abç,