Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. amigo, faça esse script q dará certo ok!

    :log info "DDNS: Begin"
    :global ddns-user "nome do seu usuário no change ip"
    :global ddns-pass "senha do seu usuário no change ip"
    :global ddns-host "seu endereço no changeip"
    :global ddns-interface "pppoe-out1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] keyname=$
    ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    bbs: onde tem ddns vc coloca seu nome do redirecionamento
    Última edição por multlink; 22-08-2008 às 11:10.

  2. Citação Postado originalmente por multlink Ver Post
    amigo, faça esse script q dará certo ok!

    :log info "DDNS: Begin"
    :global ddns-user "nome do seu usuário no change ip"
    :global ddns-pass "senha do seu usuário no change ip"
    :global ddns-host "seu endereço no changeip"
    :global ddns-interface "nome da sua interface de conexão com o modem"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] keyname=$
    ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    bbs: onde tem ddns vc coloca seu nome do redirecionamento
    Olá amigo marcelopomtox! Confira aquela marcação em vermelho, pois quando fiz a primeira vez tambem não conectou, mais o meu problemainha era somente este. Pois como vc me disse vc esta usando o modem em modo bridge, e havera a seguinte logica (algumas vezes nos nomes da interfaces):

    lan ou clientes - nome da interface dos clientes
    link (no meu casa net-wan) - Onde esta ligado o cabo do modem
    pppoe-out1 (no meu caso net) - nome da interface quando vc quer usar o modem em modo bridge (interface para conexão)

    Espero que tenha resolvido sem isto, mais espero ter ajudado um pouco.
    Abraços!



  3. Pessoal já to ficando doido, tentei os scripts que vocês passaram mais sem sucesso.
    O script do amigo alencar2 aparece no log "ddns errot Authentication Failure", tentei com as contas que criei do no-ip, dyndns e changeip.
    E do amigo roberto21 e multlink no log aparece "DDNS: Begin" e tambem não consigo.
    na figura abaixo que postei aparece o erro no winbox, e no dyndns eu notei que naum atualiza o ip, só atualiza quando eu clico
    "Use auto detected IP address 189.110.231.246", ai eu consigo, mais isso pra mim não é interessante eu ficar clicando nesse link.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         dyndns2.JPG
Visualizações:	163
Tamanho: 	29,0 KB
ID:      	2617   Clique na imagem para uma versão maior

Nome:	         dyndns.JPG
Visualizações:	181
Tamanho: 	56,5 KB
ID:      	2618  

  4. Companheiros, consegui com changeip, após muita tentativa, mais naum sei o que tava acontecendo olha ai como ficou meu script.

    :log info "DDNS: Begin"

    :global ddns-user "minha conta"
    :global ddns-pass "minha senha"
    :global ddns-host "exemplo.4dq.com"
    :global ddns-interface "LINK INTERNET"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    Aproveitei e fiz até o agendamento do script que o amigo ai passou.
    Mais agora preciso de outra ajuda, quero acessa uma maquina na rede pelo vnc eu uso essa regra no nat
    " chain=dstnat dst-address=189.110.250.98 protocol=tcp dst-port=5900 action=dst-nat to-addresses=192.168.0.10 to-ports=5900 "
    Será que da pra criar um script pra alterar o ip.

    Pessoal agradeço todos pela ajuda.



  5. Citação Postado originalmente por marcelopontox Ver Post
    Companheiros, consegui com changeip, após muita tentativa, mais naum sei o que tava acontecendo olha ai como ficou meu script.

    :log info "DDNS: Begin"

    :global ddns-user "minha conta"
    :global ddns-pass "minha senha"
    :global ddns-host "exemplo.4dq.com"
    :global ddns-interface "LINK INTERNET"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    Aproveitei e fiz até o agendamento do script que o amigo ai passou.
    Mais agora preciso de outra ajuda, quero acessa uma maquina na rede pelo vnc eu uso essa regra no nat
    " chain=dstnat dst-address=189.110.250.98 protocol=tcp dst-port=5900 action=dst-nat to-addresses=192.168.0.10 to-ports=5900 "
    Será que da pra criar um script pra alterar o ip.

    Pessoal agradeço todos pela ajuda.
    Olá marcelopontox! Pelo que eu entendi vc quer acesso remoto para o vnc dentro do pc com o ip "192.168.0.10"!?!?!
    Pelo que eu me lembro passei esse configui para um colega ak, mais na realidade ele me ligou e pediu uma ideia de como faria e eu só respondi por telefone, mais vou lhe passar + ou - do jeito que eu me lembro:

    add chain=dstnat in-interface=net dst-address=192.168.0.10 protocol=tcp \
    src-port=5900 dst-port=5900 action=accept comment="" disabled=n


    Espero ter ajudado, e eu acho que assim vai dar certo, qualquer coisa diz ae pra nois que nois da um jeito, hehehehehehe!
    Abraços!






Tópicos Similares

  1. Mikrotik não pinga no ip válido do meu Gateway
    Por wandosantosrc no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-02-2014, 10:16
  2. Respostas: 6
    Último Post: 03-06-2010, 20:46
  3. Respostas: 14
    Último Post: 18-06-2008, 10:34
  4. Não envia e-mail para IG, BRTURBO, Etc ...
    Por buribai no fórum Servidores de Rede
    Respostas: 8
    Último Post: 18-04-2005, 11:29
  5. Meu servidor não envia e-mail para o IG
    Por no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 18-11-2003, 09:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L