+ Responder ao Tópico

  1. amigo minha RB450g com balance PCC nao funciona o script DDNS .
    segue minhas regras abaixo.
    Código :
    # Define User Variables
    :global ddnsuser "dimensao.ddnsxxxx"
    :global ddnspass "conselho"
    :global ddnshost "dimensao.ddnsxxxxx"
     
    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )
    # Define Local Variables
    :local int
    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={ 
      :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
         :global ddnsinterface [/ip route get $int interface]
      } 
    }
    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
       :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
      :if ($ddnsip != $ddnslastip) do={
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
      } else={ 
        :log info "DDNS: No update required."
      }
    }
    # End of script


    por favor mim ajudem peciso muito estou deixando um printe em anexo.
    Anexo 9906
    Última edição por osmano807; 20-05-2010 às 10:31.

  2. Bom dia a todos.
    Meu script não funciona de jeito nenhum, abaixo a minha configuração.
    Mikrotik versão 4.9 (pc)
    4 Adsl com IP fixo.
    modem em bridge.
    Clientes acessam determinada adsl devido a marcação de pacotes.
    não uso proxy.
    as 4 adsl estão mascaradas.

    Resumindo, meu script nem executa, não tenho nem como saber onde está o erro.

    usei o script aqui do site e também tentei o que está no site do mikrotik mesmo, nenhum deles executa.
    Se alguem tiver uma idéia do que pode ser agradeço.

    Abraço a todos.

  3. Fala aí amigão! ( ISOLIVEIRA ) Obrigado pela sua resposta, mas o redirecionamento com o NAT ñ funcionou, vc teria outra solução ou poderia postar essas regras para mim. Valeu!!!
    Última edição por shinobi; 20-05-2010 às 17:22.



  4. Muito obrigado estava procurando este tutorial em português já faz algum tempo...
    Vou aplicar em meu server e retorno com o resultado.

  5. Muito boa a iniciativa, show de bola.

    Parabéns!!!

  6. ola amigo o SCRIPT deve estar erado porq nao funfa... agora o scheduler eu consegui faser funfa esta contando normal agora o script nao conta de geito nenhum da um helpe ai amigo vlw abraço



  7. Criando acesso ao Mk pelo ChangeIp - Enhanced Dynamic DNS Solutions

    /system script
    add name=DDNS policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
    #int-DDNS.Info\r\
    \n/tool dns-update name=ACESSO_CRIADO_CHANGEIP address=127.0.0.255 key-n\
    ame=USUARIO_CHANGEIP key=\"SENHA\""

    /system scheduler
    add comment="" disabled=no interval=1m name=DDNS on-event=\
    "system script run DDNS" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00

  8. porq essa configuração ai nao é para sua rb tenq ser essa aqui olha

    :log info "DDNS: Begin"

    :global ddnsuser "seuusuario"
    :global ddnspass "suasenha"
    :global ddnshost "o_host_que _vc_criou"
    :global ddnsinterface "pppoe-out1"
    :global ddnslastip "0"

    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]

    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddnshost address=[http://static3.under-linux.net/image...ies/tongue.pngick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"



    Agora o Scheduler

    /system scheduler
    add comment="" disabled=no interval=10m name=schedule1 on-event=DDNS \
    start-time=startup

    []'s

    Citação Postado originalmente por dimensaonet Ver Post
    amigo minha RB450g com balance PCC nao funciona o script DDNS .
    segue minhas regras abaixo.
    Código :
    # Define User Variables
    :global ddnsuser "dimensao.ddnsxxxx"
    :global ddnspass "conselho"
    :global ddnshost "dimensao.ddnsxxxxx"
     
    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )
    # Define Local Variables
    :local int
    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={ 
    :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
    :global ddnsinterface [/ip route get $int interface]
    } 
    }
    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={ 
    :log info "DDNS: No update required."
    }
    }
    # End of script


    por favor mim ajudem peciso muito estou deixando um printe em anexo.
    Anexo 9906

  9. Não existe diferença entre Pc e Rb para acesso externo. Mikrotik é mikrotik. Há diferença esta entre as versões. Essa que postei são para as versões 3x e 4x. A que esta acima, é para a versão 2x.



  10. amigo ja tentei todas essas ai nem uma conta unico q esta contando éo Scheduler porq o script nao conta eu cliko no Run Script e so fica no 1 oque sera q eu fis errado ? valew pela atenção
    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to Support@ChangeIP.com
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW: %
    # This script will update a ChangeIP.com dynamic dns hostname
    # with an ip address located directly on an interface.
    # %
    # NOTES: %
    # IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    # AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    # have created this script and tested that it works by running it
    # manually you can schedule it to run every few minutes.
    # %
    # CONFIGURATION FIELD DEFINITIONS:
    # ddnsuser: Enter your ChangeIP.com user id.
    # ddnspass: Enter your ChangeIP.com password.
    # ddnshost: Enter the hostname (www.example.com) to update.
    # ddnsinterface: Enter an interface name - case sensative.
    # %
    # %
    # %
    # %
    # % % %
    # % % %
    # % % %
    # %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "meu user"
    :global ddnspass "minha senha"
    :global ddnshost "meu host"
    :global ddnsinterface "PPPoE-out1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    :log info "DDNS: No changes necessary."
    }
    }
    # END OF SCRIPT

    Citação Postado originalmente por interhome Ver Post
    Não existe diferença entre Pc e Rb para acesso externo. Mikrotik é mikrotik. Há diferença esta entre as versões. Essa que postei são para as versões 3x e 4x. A que esta acima, é para a versão 2x.

  11. Citação Postado originalmente por interhome Ver Post
    Não existe diferença entre Pc e Rb para acesso externo. Mikrotik é mikrotik. Há diferença esta entre as versões. Essa que postei são para as versões 3x e 4x. A que esta acima, é para a versão 2x.
    eu coloquei tudo issu ai tambem e nao deu serto ja tentei de todo jeito :s

  12. Somente nesse caso. Me adciona no msn que farei para voce gratuitamente.



  13. Citação Postado originalmente por interhome Ver Post
    Somente nesse caso. Me adciona no msn que farei para voce gratuitamente.
    Poxa amigo valw mesmo hein quem sabe sabe ne hehehe ficou xou

  14. Fala ai galera to desde segunda-feira tentando fazer esse acesso remoto e nada já fiz inúmeras tentativas alias fiz todas e não deu certo ainda meu ultimo script foi este aki
    # Set needed variables
    :local username "claudinhohw"
    :local password "********"
    :local hostname "claudinhohw.ddns.info"
    :global systemname [/system identity get name]

    :if ($systemname = "Site1" ) do= {
    :set hostname "yourdomain1.dyndns.org"
    }
    :if ($systemname = "Site2" ) do= {
    :set hostname "yourdomain2.dyndns.org"
    }
    :if ($systemname = "Site3" ) do= {
    :set hostname "yourdomain3.dyndns.org"
    }

    :global dyndnsForce
    :global previousIP

    # print some debug info
    :log info ("UpdateDynDNS: username = $username")
    :log info ("UpdateDynDNS: password = $password")
    :log info ("UpdateDynDNS: hostname = $hostname")
    :log info ("UpdateDynDNS: previousIP = $previousIP")

    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]

    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :log info "UpdateDynDNS: currentIP = $currentIP"

    # Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
    #:set dyndnsForce true

    # Determine if dyndns update is needed
    # more dyndns updater request details available at DynDNS.com - Support -- Developers' Connection -- Update Specifications: Perform Update
    :if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src- path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
    ut ("Dyndns Update Result: ".$result)
    } else={
    :log info ("UpdateDynDNS: No dyndns update needed")
    }
    Meu MK é V.3.25, já alterei até o modem mais não consegui nada ainda gostaria da ajuda de vcs meu modem e um Dlink 500b ADSL 2+, roteado tenho internet de 8mb nele....
    obs: eu estou na mesma rede que estou testando o acesso remoto tem alguma coisa a ver?
    Segue a imagem de como esta os erros...
    http://thumbnails32.imagebam.com/926...a692604968.jpg http://thumbnails31.imagebam.com/926...c792604974.jpg http://thumbnails28.imagebam.com/926...6392604985.jpg http://thumbnails32.imagebam.com/926...c392604996.jpg

    desde já agradeço ajuda de todos
    Última edição por claudinhohw; 11-08-2010 às 15:28.

  15. Estou tendo um problema com meu acesso remoto...
    Fiz tudo direitinho, mais quando tento acessar da uma mensagem "port 80 no response" outra coisa, a apçao Scheduler não esta executando o script....o scheduler fica executando, mais o contador do script não muda!!! Tem alguma soluçao, a versao que estou usando e a 3.30, preciso instalar o tools???Aguardo respostas.



  16. Salve galera.

    Aqui consegui, deu tudo certo.
    Uso um link da Oi em um modem adsl Thomson TG508 configurado como router, para funcionar no modo Router basta criar o redirecionamento da porta, fiz 2 redirecionamentos, da porta 8291 e 23.

    Dica: Se vc estiver testando o acesso remoto da mesma internet em que o modem usa como LINK (Ou seja, o IP valido) não Acessa. Vc somente acessa de outra Internet (Outro IP valido).

    Valew!

  17. #157
    heliovilarino
    Valeu irmao! Otimo tutorial

  18. Ola Magrock!

    este tutorial serve para qualquer vesão do mikrotik?
    tem algum problema pra quem usa balance com 3 link adsl?
    desde de ja eu agradeço.



  19. Citação Postado originalmente por MICROCHIPNET Ver Post
    Ola Magrock!

    este tutorial serve para qualquer vesão do mikrotik?
    tem algum problema pra quem usa balance com 3 link adsl?
    desde de ja eu agradeço.
    eu uso um loadbalance com 3 links
    e fiz seguindo o primeiro tutorial do tópico
    funcionou blz no mk 3.x

  20. Muito bom script vlw pela força






Tópicos Similares

  1. Respostas: 225
    Último Post: 17-09-2013, 11:13
  2. Acesso remoto ao mikrotik
    Por Aredeprovedor no fórum Redes
    Respostas: 5
    Último Post: 21-05-2012, 09:54
  3. Acesso remoto ao mikrotik - solucao
    Por Raniel no fórum Redes
    Respostas: 43
    Último Post: 09-09-2008, 13:08
  4. Acesso remoto ao mikrotik - avançado
    Por Raniel no fórum Redes
    Respostas: 9
    Último Post: 25-07-2008, 11:09
  5. Porta para acesso remoto ao Apache
    Por debora no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-09-2002, 17:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L