Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    Deixa eu ver se entendir,
    Utilizando essas regras eu continuaria tendo controle de velocidade do Hotspot?
    Se a resposta for sim, de onde vem essa velocidade extra?
    vou tentar aliviar as mentes de vocês rsrsrs
    é o seguinte com certeza aqui todo mundo ja implementou o famoso cache-full imagino, funciona da seguinte forma, as requisiçoes das paginas e downloads feito ao servidor mk é redirecionada para seu modem consumindo a banda ex.:100k setado por você no mk para o cliente que esta requisitando o serviço, se outro cliente com velocidade ex.:56k for requisitar as mesmas paginas e downloads que o anterior requisitou entao ele iria demorar o dobro para re-baixar tudo novamente, só que as regras cache-full implementadas diz ao mk que aquela pagina ou arquivo já foi solicitado anteriormente e esta disponivel no cache do servidor mk e que pode ir a full (depende da velovidade setada na regra) entao o cliente que pode baixar ate 90% mais rapido que o primeiro de 100k.
    Agora com relação as regras do amigo é a mesma lógica, o que ja esta no servidor nao aloca banda da internet e sim banda do rádio/ap/rb etc... como os equipamentos tem banda de sobra (2.4Ghz 11 a 54Mb de banda/5.8Ghz 54 a 108Mb de banda) as regras do amigo esta falando ao mk que aquela informação já esta no servidor e não na internet e que pode enviar a solicitação a full no equipamento.
    finalizando...
    tudo que esta no servidor não tem nescessidade de passar pelo controle de banda pois não ir saturar o link.
    acho que deu pra entender, duvidas tamos ai!
    RANIEL desculpe a entromissão no seu post, mas foi só pra ajudar enrriquece-lo
    Última edição por underwanderson; 28-02-2009 às 11:11. Razão: correções

  2. #22

    Padrão

    Eu que agradeço amigo.



  3. #23

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Bem pessoal, fiz algumas regras para tornar as paginas do hotspot mais rápidas. Vou postá-las para que todos possam testar e dá a opinião.

    /ip firewall mangle
    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=udp comment="hotspot - full"

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64872 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64873 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64874 protocol=tcp

    chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=ether2 src-port=64875 protocol=tcp

    chain=output action=mark-packet new-packet-mark=hotspot passthrough=no connection-mark=hotspot-out


    /queue tree
    name="hotspot" parent=global-out packet-mark=hotspot limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    Testado na versão 2.9.51

    Qual a diferença entre essa regra e essa

    ip firewall mangle
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no
    queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="cache full" packet-mark=proxyfull parent=global-out priority=8 queue=default

    Muito grato...

  4. #24

    Padrão

    A diferença a na aplicação de cada uma, pois uma é para o hotspot e a outra para o proxy. Uma tudo que pertence ao hotspot irá sair com uma velocidade, definida, maior e a outra tudo que está no cache irá sair, também, com uma velocidade, definida, maior.
    Espero que tenha compreendido.



  5. #25

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    A diferença a na aplicação de cada uma, pois uma é para o hotspot e a outra para o proxy. Uma tudo que pertence ao hotspot irá sair com uma velocidade, definida, maior e a outra tudo que está no cache irá sair, também, com uma velocidade, definida, maior.
    Espero que tenha compreendido.
    Muito obrigado,
    uma duvida o q pertence ao hotspot? no caso eu estou uzando a v3.22 hotspot + dhcp e o cache web, eu poderia usar essa outra? si sim quais outras opções eu teria q ativar ou desativar para funfa???
    Muito grato.

  6. #26

    Padrão

    Pode-se usar as duas sem problemas nenhum, em relação a ativar opções tem que haver o tipo de necessidade, tipo se estiver usando o hotspot, desmarcar a opção Transparent Proxy dos profiles, excetos os usados para enviar avisos e tals(isto para o cache full).



  7. #27

    Padrão

    Citação Postado originalmente por renangomes Ver Post
    Bem,

    Aqui eu estou usando assim:


    Código :
    /ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64872 protocol=udp comment="Hotspot - Full"
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64872 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64873 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64874 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64875 protocol=tcp
     
    add  chain=output action=mark-packet new-packet-mark=hotspot passthrough=no connection-mark=hotspot-out 
     
    /queue tree
    add  name="hotspot" parent=global-out packet-mark=hotspot limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s
    Está perfeito. Minha página de login tem um plano de fundo "pesado" cerca de 200K. Assim, quando eu coloco essas regras as páginas abrem instantaneamente (login, status, etc.)

    Além de acelerar um pouco a velocidade de navegação dos clientes visto ques as requisições dns (muito pequenas) nao entram na fila de download do cliente, assim, a NAVEGAÇÃO dele fica um pouco mais rápida.

    Amigo qual versao do mk?

  8. #28

    Padrão

    Estas regras podem ser usadas em qualquer versão*.



  9. #29

    Padrão

    Citação Postado originalmente por renangomes Ver Post
    Bem,

    Aqui eu estou usando assim:


    Código :
    /ip firewall mangle
    add chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64872 protocol=udp comment="Hotspot - Full"
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64872 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64873 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64874 protocol=tcp
     
    add  chain=output action=mark-connection new-connection-mark=hotspot-out passthrough=yes out-interface=CLIENTES src-port=64875 protocol=tcp
     
    add  chain=output action=mark-packet new-packet-mark=hotspot passthrough=no connection-mark=hotspot-out 
     
    /queue tree
    add  name="hotspot" parent=global-out packet-mark=hotspot limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s
    Está perfeito. Minha página de login tem um plano de fundo "pesado" cerca de 200K. Assim, quando eu coloco essas regras as páginas abrem instantaneamente (login, status, etc.)

    Além de acelerar um pouco a velocidade de navegação dos clientes visto ques as requisições dns (muito pequenas) nao entram na fila de download do cliente, assim, a NAVEGAÇÃO dele fica um pouco mais rápida.




    Aki esta funcionando filé

  10. #30

    Padrão

    Olá amigo Raniel

    Configurei as regras e a página de login do hotspot ficou full...
    porém... perdi o controle de banda dos clientes limitados no simple queue

    Ficou full para todos os sites...

    alguem pode me dar uma luz?

    vou mandar as configs

    CODE:

    SIMPLE QUEUE

    0 name="Tiago" target-addresses=192.168.0.62/32 dst-address=0.0.0.0/0
    interface=Local parent=none direction=both priority=8
    queue=default/default limit-at=0/0 max-limit=128000/128000
    total-queue=default-small
    1 D name="<hotspot1>" dst-address=0.0.0.0/0 interface=Local parent=none
    direction=both priority=8 queue=hotspot-default/hotspot-default
    limit-at=0/0 max-limit=0/0 total-queue=default-small

    TREE QUEUE

    0 name="squid" parent=global-out packet-mark=squid-packet-HIT limit-at=0
    queue=ethernet-default priority=8 max-limit=1000000 burst-limit=0
    burst-threshold=0 burst-time=0s
    1 name="hotspot" parent=global-out packet-mark=hotspot limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    NAT

    0 chain=srcnat out-interface=Internet src-address=192.168.0.0/26
    action=masquerade
    1 ;;; web proxy
    chain=dstnat src-address=192.168.0.0/26 protocol=tcp dst-port=80
    action=redirect to-ports=3128

    MANGLE

    0 chain=output protocol=tcp src-port=3128 content=X-Cache: HIT
    action=mark-connection new-connection-mark=squid-connection-HIT
    passthrough=yes
    1 chain=output connection-mark=squid-connection-HIT action=mark-packet
    new-packet-mark=squid-packet-HIT passthrough=yes
    2 chain=output out-interface=Local protocol=udp src-port=64872
    action=mark-connection new-connection-mark=hotspot-out passthrough=yes
    3 chain=output out-interface=Local protocol=tcp src-port=64872
    action=mark-connection new-connection-mark=hotspot-out passthrough=yes
    4 chain=output out-interface=Local protocol=tcp src-port=64873
    action=mark-connection new-connection-mark=hotspot-out passthrough=yes
    5 chain=output out-interface=Local protocol=tcp src-port=64874
    action=mark-connection new-connection-mark=hotspot-out passthrough=yes
    6 chain=output out-interface=Local protocol=tcp src-port=64875
    action=mark-connection new-connection-mark=hotspot-out passthrough=yes

    web proxy

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "webmaster"
    max-object-size: 4096KiB
    cache-drive: system
    max-cache-size: 10000000KiB
    max-ram-cache-size: unlimited
    status: running
    reserved-for-cache: 9999360KiB
    reserved-for-ram-cache: 162816KiB



  11. #31

    Padrão

    No seu mangle está faltanda a action=mark-packet. Outra seria tentar apenas com a porta 64874.

  12. #32

    Padrão

    Desculpe.. na hora de copiar as regras nao copiei o mangle do market packet....

    chain=output connection-mark=hotspot-out action=mark-packet
    new-packet-mark=hotspot passthrough=no

    deixei só a 64874 e nao funcionou.. é como se nao tivesse as regras do simple queue...
    pelo que li a tree queue é executada antes da simple..
    o que será que está errado?



  13. #33

    Padrão

    Olá amigo, procure fazer o controle usando a simple queue.

  14. #34

    Padrão

    mais o controle está sendo feito pela simple queue....

    exemplo:

    usuário01 limitado na simple queue - 128k download / 128k upload

    tree queue adicionei a sua regra....

    o acesso a tela de login do hotspot é a full
    mais depois que o Usuário01 loga o controle de banda da simple queue nao funciona.. ele loga a full tb

    entendeu?

    adorei suas regras.. o problema aqui é só o usuário logando a full tb... ignorando a regra adicionada na simple queue...

    se tiver alguma dica.. fico agradecido..

    abraço!



  15. #35

    Padrão

    Faça o controle do hotspot full na simple queue também.

  16. #36

    Padrão Passa pelo Proxy transparente do Mikrotik?

    Citação Postado originalmente por Raniel Ver Post
    Olá amigo,
    A ether2 se refere a interface que libera acesso aos clientes.
    Amigo Raniel,
    Essa regra passa pelo Proxy transparente do Mikrotik? Faz cache?

    Grato.



  17. #37

    Padrão

    O ideal é que as páginas de login não fiquem no cache. Estas regras não passam pelo cache.

  18. #38

    Padrão

    Amigo, to com o seguinte problema não sei se vc pode me ajudar. Meu hotspot ta aparecendo aqui pra mim quando coloco o cabo do pc que controlo o server Mikrotik, direto na placa do cliente, ai pede senha e login, mas não ta entregando aos clientes, no caso após a rb 433 ah. O cliente conecta mas não recebe o ip certo, nem abre o hotspot e nem navega. Fica dando conexção limitada. Acha que o problema está na RB? Uso ela como Bridge ou ap-bridge, intenção é so repassar tudo para os clientes. Grato por qualquer ajuda amigo.



  19. #39

    Padrão

    Tem quase certeza que o problema seja na configuração de RB, tendo em mãos que o servidor esteja funcionando perfeitamente.
    Revise aí sua RB.