+ Responder ao Tópico



  1. #1

    Question Depois de marcar rota redes não se enxergam

    Bem galera to com um probleminha...

    Tenho 2 conexoes adsl uma de 10/1mbps e outra de 4/1mbps, o patrao meio egoista quer usar essa de 10mbps e deixar a de 4mbps pro resto da loja, umas 10 maquinas apenas.

    Bem, no mikrotik tenho o seguinte:

    [[email protected]] > ip address print
    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK BROADCAST INTERFACE
    3 ;;; REDE
    172.16.0.254/24 172.16.0.0 172.16.0.255 REDE
    4 ;;; REDE
    192.168.20.254/24 192.168.20.0 192.168.20.255 REDE
    5 ;;; LINK BR
    172.16.0.4/29 172.16.0.0 172.16.0.7 LINK
    6 ;;; REDE
    192.168.0.254/24 192.168.0.0 192.168.0.255 REDE
    7 ;;; LINK BR VOIP
    172.16.0.5/29 172.16.0.0 172.16.0.7 LINK
    9 ;;; LINK NOVO 10/1
    192.168.1.6/29 192.168.1.0 192.168.1.7 LINK

    Tenho apenas 2 placas de rede como podem ver,,, REDE e LINK
    - No LINK tenho 3 ips,,, um pro link de 4 megas outro pro link de 10 megas e um pra voip de 200k garantido
    - Na REDE tenho 3 redes 192.168.0.0/24 minha rede liberada para internet, 192.168.20.0/24 rede com acesso restrito para alguns sites sem msn,,, e 172.16.0.0/16 rede com internet restrita apenas com msn onde rodam meus servidores de sistema comercial..

    Bem minhas rotas sao essas:

    [[email protected]] > ip route print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf
    # DST-ADDRESS PREF-SRC G GATEWAY DIS INT..
    1 ADC 172.16.0.0/29 172.16.0.4 LINK
    2 ADC 172.16.0.0/24 172.16.0.254 REDE
    3 ADC 192.168.0.0/24 192.168.0.254 REDE
    4 ADC 192.168.1.0/29 192.168.1.6 LINK
    5 ADC 192.168.20.0/24 192.168.20.254 REDE
    9 A S ;;; Rota VOIP
    0.0.0.0/0 172.16.0.5 r 172.16.0.1 LINK
    10 A S ;;; Rota NAVEG
    0.0.0.0/0 r 172.16.0.1 LINK
    11 A S ;;; LINK NOVO 10/1
    0.0.0.0/0 r 192.168.1.1 LINK

    Bem,,, tenho marcaçoes para a rota VOIP = LINK_VOIP em Routing Mark e Rota NAVEG = LINK_NOVO

    ateh aih blz,, eu marco os ips para sair pelo link do voip no firewall assim:

    [[email protected]] > ip firewall mangle print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; LINK_VOIP
    chain=prerouting src-address=192.168.0.56 action=mark-routing new-routing-mark=LINK_VOIP
    passthrough=no

    e esse ip sai pelo link do voip


    e quando eu marco:
    4 X ;;; LINK_NOVO
    chain=prerouting src-address=192.168.0.23 action=mark-routing new-routing-mark=LINK_NOVO
    passthrough=no

    o ip 192.168.0.23 sai pelo link novo,,, porem os que eu marco para sair por determinado link nao conseguem mais acessar o resto da rede na mesma placa de rede,,,,
    esse ip 192.168.0.23 nao acessa o sistema comercial q esta em 172.16.0.110 por exemplo,,,, sem chance,,, alguem sabe como eu fazer eles se enchergarem depois de marcar o ip....

    ps. se eu nao marco os ips,,, funciona normal..

  2. #2



  3. #3

    Padrão

    Amigo, se você está dizendo que a rede do seu patrão tem que sair "só" pelo LINK10/1 como que ele vai sair pra rotas das outras redes de aplicativos, etc
    ;-)

    []'s

  4. #4

    Padrão

    Bem,,, ele quer usar o link de 10/1 e tambem precisa usar a rede de aplicativos onde tem o sistema comercial,, esse eh o pipino...



  5. #5

    Padrão

    Crie uma rede pra ele tipo, 10.10.10.1/29 saindo pelo link 10/1. Coloque o ip na interface dele 10.10.10.1 255.255.255.248 10.10.10.1
    Bom ele terá internet.
    Quanto aos aplicativos, vc vai ter que criar um "alias" 10.10.10.3 255.255.255.248 na placa de rede do servidor
    de rede que ele precisa acessar.
    Testei em bancada, aki funcionou.
    []'s

  6. #6

    Padrão

    Pois eh,,, faz sentido,, tambem ja fiz isso e funcionou,,, mas entao sera q nao tem outra saida???
    tambem daria pra fazer o seguinte,,, deixar tudo na mesma rede,,,, tambem funcionaria,,, mas no fundo seria a mesma soluçao e colocar o alias na placa de rede do servidor de aplicativo!!!

    O fato eh,,, sera q nao tem algum jeito das redes se enxergarem depois de marcar uma rota??


    obrigado pela ajuda!!



  7. #7

    Padrão

    O problema é a rota padrão. As rotas são criadas para acessar redes desconhecidas. Por exemplo, vc tem o ip 192.168.10.1 e gateway 192.168.10.254. Quando você quer acessar o 192.168.200.20 ele vair sair pelo gateway,
    no gateway (seu Mikrotik) tem a rota padrão do seu patrão saindo pro link 10/1... portanto ele não vai chegar em outra rede.
    Entende?

    []'s