Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Magnum, amigão, vou poder ver isso amanhã, segunda-feira, porque o PC em questão é do meu serviço.
    Só uma pergunta: como sei se o servidor só está aceitando conexões de um IP somente?
    E outra coisinha: dessa forma as máquinas com IP 192.168.20.xxx acessarão normalmente os sites pelo domínio? (www.site.com.br)
    Valeu mesmo a ajuda!!!

  2. Citação Postado originalmente por felixleonardo Ver Post
    Magnum, amigão, vou poder ver isso amanhã, segunda-feira, porque o PC em questão é do meu serviço.
    Só uma pergunta: como sei se o servidor só está aceitando conexões de um IP somente?
    E outra coisinha: dessa forma as máquinas com IP 192.168.20.xxx acessarão normalmente os sites pelo domínio? (www.site.com.br)
    Valeu mesmo a ajuda!!!

    Pelo nome não, a não ser que você possa colocar uma entrada DNS de www.site.com.br pro IP da rede interna? Você tem algum servidor DNS pra rede interna?? Outra opção é fazer um redirecionamento... Tudo com destino a www.site.com.br vindo da rede interna com porta de destino igual a 80 vc redireciona pro 192.168.20.4.

    Pra saber se está bloqueando olha o iptables... Não tenho certeza, mas acho que o apache também pode restringir o acesso a somente um IP. Dá uma olhada na config do Apache...

    Até mais...



  3. Consegui resolver, mas ainda fiquei com um pequeno problema. Na rede externa, tudo está perfeito. Na rede interna as máquinas estão enxergando os sites que estão no servidor web normalmente agora, inclusive por domínio, porém não enxergam os sites externos. No lugar deles abre a página do Apache. Seguem as regras como estão no momento:

    $IPTABLES -t filter -I FORWARD -d 192.168.20.4 -p tcp --dport 80 -j ACCEPT
    $IPTABLES -t filter -I FORWARD -s 192.168.20.4 -p tcp --sport 80 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -p tcp -i $EXTIF --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A PREROUTING -p tcp -i $INTIF --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to 192.168.20.1
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to $EXTIF

    O que pode estar faltando ou errado?
    Última edição por felixleonardo; 20-10-2008 às 09:12.

  4. Citação Postado originalmente por felixleonardo Ver Post
    Consegui resolver, mas ainda fiquei com um pequeno problema. Na rede externa, tudo está perfeito. Na rede interna as máquinas estão enxergando os sites que estão no servidor web normalmente agora, inclusive por domínio, porém não enxergam os sites externos. No lugar deles abre a página do Apache. Seguem as regras como estão no momento:

    $IPTABLES -t filter -I FORWARD -d 192.168.20.4 -p tcp --dport 80 -j ACCEPT
    $IPTABLES -t filter -I FORWARD -s 192.168.20.4 -p tcp --sport 80 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -p tcp -i $EXTIF --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A PREROUTING -p tcp -i $INTIF --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to 192.168.20.1
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to $EXTIF

    O que pode estar faltando ou errado?
    O problema é que você está redirecionando tudo que entra pela $INTIF com dport 80 para o servidor web. O IP que você usa pra acessar o site é o 192.168.20.1??? Se for, torne essa regra menos abrangente da seguinte forma:

    $IPTABLES -t filter -I FORWARD -d 192.168.20.4 -p tcp --dport 80 -j ACCEPT
    $IPTABLES -t filter -I FORWARD -s 192.168.20.4 -p tcp --sport 80 -j ACCEPT
    $IPTABLES -t nat -A PREROUTING -p tcp -i $EXTIF --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A PREROUTING -p tcp -i $INTIF -d 192.168.20.1 --dport 80 -j DNAT --to 192.168.20.4
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to 192.168.20.1
    $IPTABLES -t nat -A POSTROUTING -d 192.168.20.4 -j SNAT --to $EXTIF

    Só mais uma coisa. Acho que essa última regra não está tendo efeito algum... Confirma se tem algum pacote batendo nessa regra com o comando 'iptables -nvL'.



  5. Com essa alteração que você me passou volta ao problema anterior. Abre a Internet, mas os sites do servidor web não abrem.
    Só estou conseguindo uma das duas coisas. As duas juntas não está dando certo.
    Tem mais alguma regra ou algo diferente que eu possa tentar?






Tópicos Similares

  1. Bloquear end ip para que acessar somente um site...
    Por leugimfilho no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-09-2005, 15:55
  2. Esqueci o endereço para acessar o mysql pelo browser
    Por Catharinametal no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-04-2005, 09:06
  3. Liberar um Ip para acessar apenas uma pagina
    Por sbjunior no fórum Servidores de Rede
    Respostas: 2
    Último Post: 14-04-2005, 08:10
  4. Configurar Conect.9 para acessar a Internet através da rede
    Por Beethoven2000 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-09-2004, 07:40
  5. Liberando acesso apenas para um ip.
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-06-2003, 10:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L