+ Responder ao Tópico



  1. #1

    Padrão Dois links ADSL Duas saídas

    Pessoal, continuo com dificuldades em resolver meu problema, coloquei escrens para vcs entenderem melhor meu problema.
    Tenho dois links ADSL (mas onde moro não chega ADSL por isso envio para mim por direcional) e quero que cada link saia por uma ether não quero misturar, quero apenas que cada um saia por uma ether. No esquema vcs verão que recebo meus dois links por uma placa wireless (G520) Antes que mandem eu colocar um ap pra receber eu aviso que já fiz isso e deu na mesma. Quero trabalhar com os links separados, consigo receber os dois numa boa, mas não consigo fazer o link 2 funcionar ou seja ser usado pela ether2 a ether2 continua buscando link na ether1. Postei meu esquema atual (esquema1 e mikrotik1) e o esquema que quero fazer funcionar (esquema2 mikrotik2) acho que falta alguma regra no firewall ou rota, não sei, por favor me ajudem. agradeço a todos.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         esquema1.jpg
Visualizações:	199
Tamanho: 	29,9 KB
ID:      	2892   Clique na imagem para uma versão maior

Nome:	         mikrotik1.jpg
Visualizações:	191
Tamanho: 	179,0 KB
ID:      	2893  

    Clique na imagem para uma versão maior

Nome:	         esquema2.jpg
Visualizações:	161
Tamanho: 	34,8 KB
ID:      	2894   Clique na imagem para uma versão maior

Nome:	         mikrotik2.jpg
Visualizações:	144
Tamanho: 	201,4 KB
ID:      	2895  


  2. #2

    Padrão

    O negócio eh vc marcar a no firewall a rota pro determinado range de ip's e em ip route vc divide a rota !



  3. #3

    Padrão

    Citação Postado originalmente por SgtoMarlthon Ver Post
    Pessoal, continuo com dificuldades em resolver meu problema, coloquei escrens para vcs entenderem melhor meu problema.
    Tenho dois links ADSL (mas onde moro não chega ADSL por isso envio para mim por direcional) e quero que cada link saia por uma ether não quero misturar, quero apenas que cada um saia por uma ether. No esquema vcs verão que recebo meus dois links por uma placa wireless (G520) Antes que mandem eu colocar um ap pra receber eu aviso que já fiz isso e deu na mesma. Quero trabalhar com os links separados, consigo receber os dois numa boa, mas não consigo fazer o link 2 funcionar ou seja ser usado pela ether2 a ether2 continua buscando link na ether1. Postei meu esquema atual (esquema1 e mikrotik1) e o esquema que quero fazer funcionar (esquema2 mikrotik2) acho que falta alguma regra no firewall ou rota, não sei, por favor me ajudem. agradeço a todos.

    Sargento, suas regras estão muito confusas, vc definiu como seu segundo gateway o próprio endereço da sua interface, vc não marcou as rotas e tb não falou nada de como está configurado seu AP que envia os links.

    Vc já testou aí na sua casa se as duas adsl estão funcionando antes de entrar no MK ?

    Vc criou um hotspot para as duas ethers fazendo uma bridge, ou dois hotspos independentes ?

    Só por curiosidade: vc vai trabalhar realmente com duas antenas omni ligadas em dois AP´s ??

    Abç,

  4. #4

    Padrão

    Você deve fazer a marcação de cada faixa de rede, tipo: 192.168.0.0/24 sair por um modem e 192.168.1.0/24 sair por outra.
    Para fazer isto você deve usar o submenu: /ip firewall mangle
    e marcar os routes para cada marcação feita no firewall:
    Usar o submenu /ip route.



  5. #5

    Padrão

    Citação Postado originalmente por iron Ver Post
    Sargento, suas regras estão muito confusas, vc definiu como seu segundo gateway o próprio endereço da sua interface, vc não marcou as rotas e tb não falou nada de como está configurado seu AP que envia os links.

    Vc já testou aí na sua casa se as duas adsl estão funcionando antes de entrar no MK ?

    Vc criou um hotspot para as duas ethers fazendo uma bridge, ou dois hotspos independentes ?

    Só por curiosidade: vc vai trabalhar realmente com duas antenas omni ligadas em dois AP´s ??

    Abç,
    Os exemplos esquema1 e mikrotik1 são da minha configuração atual, com um link e os exemplos esquema2 e mikrotik2 são de quando eu coloco o outro link e não funciona.

    Sobre as regras, não entendo praticamente nada delas, as adsl funcionam perfeitamente, não uso bridge, dois hotspots independentes, Amigo eu já trabalho a um ano com uma OMNI Aquárius de 15DB e por mais que todos aqui digam que ela é ruim, pra mim está funcionando perfeito, agora estou levantando mais uma OMNI de 21DB que por sinal as Duas OMNIs já estão funcionando na mesma torre a uns 2 meses sem problemas nenhum, mas eu tinha apenas uma ADSL, agora preciso por mais link, e eu queria que cada link fosse direcionado para uma OMNI. Muito obrigado a todos que estão me ajudando, queria pedir mais uma coisa, que quando mandarem eu fazer uma regra ou etc, que se possível colocassem a regra aqui pra mim, pois não entendo praticamente nada se regras. Abração.
    Última edição por SgtoMarlthon; 21-10-2008 às 22:27.

  6. #6

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Você deve fazer a marcação de cada faixa de rede, tipo: 192.168.0.0/24 sair por um modem e 192.168.1.0/24 sair por outra.
    Para fazer isto você deve usar o submenu: /ip firewall mangle
    e marcar os routes para cada marcação feita no firewall:
    Usar o submenu /ip route.
    Amigo vc pode mandar a regra? pq não entendo nada de regras.



  7. #7

    Padrão

    Citação Postado originalmente por SgtoMarlthon Ver Post
    Os exemplos esquema1 e mikrotik1 são da minha configuração atual, com um link e os exemplos esquema2 e mikrotik2 são de quando eu coloco o outro link e não funciona.

    Sobre as regras, não entendo praticamente nada delas, as adsl funcionam perfeitamente, não uso bridge, dois hotspots independentes, Amigo eu já trabalho a um ano com uma OMNI Aquárius de 15DB e por mais que todos aqui digam que ela é ruim, pra mim está funcionando perfeito, agora estou levantando mais uma OMNI de 21DB que por sinal as Duas OMNIs já estão funcionando na mesma torre a uns 2 meses sem problemas nenhum, mas eu tinha apenas uma ADSL, agora preciso por mais link, e eu queria que cada link fosse direcionado para uma OMNI. Muito obrigado a todos que estão me ajudando, queria pedir mais uma coisa, que quando mandarem eu fazer uma regra ou etc, que se possível colocassem a regra aqui pra mim, pois não entendo praticamente nada se regras. Abração.
    OK sargento, só perguntei sobre as omni´s, pra entender sua real necessidade.
    Eu uso aki também uma aquario de 15 e não tenho nenhuma queixa dela.... ( ainda não coloquei duas juntas )
    Perguntei também pq, pra vc dividir seus clientes em dois grupos, cada um com um link, vc NÃO precisa necessáriamente dividí-los em dois rádios com duas antenas independentes, ou seja vc pode fazer essa divisão apenas através das regras de firewall.
    Agora , se seu caso é quantidade de clientes por cada rádio, aí sim, nesse caso tem aumentar a estrutura mesmo...

    Já quanto às regras que vc precisa, isso já vai ser meio complicado, pelo que ví, vc vai ter que dar uma reestruturada geral nas configurações do seu server, e eu recomendaria que vc faça os testes num server de testes na bancada, antes de implantar definitivamente no que está em uso por razões óbvias.

    Abç,

  8. #8

    Padrão

    Citação Postado originalmente por SgtoMarlthon Ver Post
    Amigo vc pode mandar a regra? pq não entendo nada de regras.
    As regras são as seguintes:
    /ip firewall mangle add src-address=192.168.0.0/24 action=mark-routing new-routing-mark=rede_A
    /ip firewall mangle add src-address=192.168.1.0/24 action=mark-routing new-routing-mark=rede_B

    /ip route add gateway=192.16.2.2/30 routing-mark=redeA
    /ip route add gateway=172.20.3.2/24 routing-mark=rede_B

    Caso tenha alguma dúvida, a teoria disso é a mesma do link abaixo:

    http://www.vivaolinux.com.br/artigo/...s_no_MikroTik/



  9. #9

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    As regras são as seguintes:
    /ip firewall mangle add src-address=192.168.0.0/24 action=mark-routing new-routing-mark=rede_A
    /ip firewall mangle add src-address=192.168.1.0/24 action=mark-routing new-routing-mark=rede_B

    /ip route add gateway=192.16.2.2/30 routing-mark=redeA
    /ip route add gateway=172.20.3.2/24 routing-mark=rede_B

    Caso tenha alguma dúvida, a teoria disso é a mesma do link abaixo:

    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]
    amigo tem algo errado com essas regras... pois em /ip route add gateway=192.16.2.2/30 (não aceita / no meu mk)
    e em ip firewall mangle oque a gente bota em chain?
    pq em /ip route add gateway=192.16.2.2/30 (pq é /30?)

    tem como vc postar o exemplo usando minha faixa de IP, pois fica mais fácil eu entender. Muito obrigado por estar me ajudando.

  10. #10

    Padrão

    Citação Postado originalmente por SgtoMarlthon Ver Post
    amigo tem algo errado com essas regras... pois em /ip route add gateway=192.16.2.2/30 (não aceita / no meu mk)
    e em ip firewall mangle oque a gente bota em chain?
    pq em /ip route add gateway=192.16.2.2/30 (pq é /30?)

    tem como vc postar o exemplo usando minha faixa de IP, pois fica mais fácil eu entender. Muito obrigado por estar me ajudando.
    Ops amigo, houve uma confusão de minha parte:
    Na chain ficaria o prerouting e no gateway não teria o /30 e /24.
    Leia o topico que irá entender melhor.

    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]



  11. #11

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Ops amigo, houve uma confusão de minha parte:
    Na chain ficaria o prerouting e no gateway não teria o /30 e /24.
    Leia o topico que irá entender melhor.

    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]
    Amigo, esse link que vc passou aí em cima é difícil pra mim, lá o cara manda por um IP que tem no começo do tutorial, mas nem sei que ip é esse, é aquele mesmo que ele manda ou o IP do meu modem? Meus modens estão roteados, e não tem IP fixo. Ta complicado isso.
    Fiz tudo que ele mandou mas não funcionou, configurei minha ether2 mas quando vou no myip ele mostra o IP do modem que está na ether1. e o teste que ele manda fazer aqui deu errado, mostrou um ip que não tem nada haver.
    Acho que esse tutorial não me ajuda muito pois lá ele fala em dividir uma ether em duas faixas, oq não é o meu caso, eu quero um modem por ether, uso /24 já imaginou eu mudar isso em todos os meus clientes? Mais uma vez obrigado.
    Última edição por SgtoMarlthon; 22-10-2008 às 22:34.

  12. #12

    Padrão

    O link foi apenas um tira-dúvidas, você deve fazer da maneira que eu expliquei acima.



  13. #13

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    O link foi apenas um tira-dúvidas, você deve fazer da maneira que eu expliquei acima.
    Já fiz, mas não deu certo. e quando coloco as regras na ether1 que é meu link q estou usando atualmente, para tudo.

  14. #14



  15. #15

    Padrão

    Obrigado Mr. RG, mas é a mesma coisa que vc mandou antes e ainda por cima em inglês :-) Meu caso não é de uma faixa de IPs dividida em dois... meu caso é Dois links e Duas ether com duas faixas... mesmo assim obrigado por tentar. Nem sei se meu caso é load balance... Tudo oque eu quero é colocar um link em cada saída só isso, mas pelo visto meu problema é o gateway, os dois links são da telemar com gateway igual.