Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. Olá atodos, eu também montei um proxy Debian em paralelo com o Mk 3.10, mas ocorre o mesmo erro de gateway comigo, já fiz um check no código, mas não consigo abastecer o proxy com o link.
    Peço ajuda. Obrigado.

  2. Então posta ai as regras do mk pra conversar com seu linux

    são apenas duas regras pra abastecer o proxy com link ilimitado sem controle de banda

    manda ai que posto a solução

    abraços



  3. Muito obrigado pelo interesse, consegui resolver o problema. Abraços !!!

  4. olá amigo
    como conseguiu resolver o problema do gateway timeout??
    estou a tentar e até agora nao resolvi....
    tbm fiz de acordo com o tutorial
    espero q possa ajudar



  5. Eu tambem tive esse problema com MK+Linux e acabei solucionando.
    eu uso no MK= Hotspot com Transparent Proxy Ativado, Ver:. 2.9.27, pra quem utiliza a mesma versão que eu tem que configurar na opção IP > PROXY, nas outras versões eu desconheço.
    esse problema é devido a configuração do NAT, não sei o porque, mas eu ditei as regras e o proxy funciona que é uma beleza, mas a regra não contabiliza os pacotes e os bytes.
    Utilizo o Squid 2 e funciona bem, sem zph e Iptables (apesar de não saber configurar o ZPH e nem o IPtables) e o squid.conf está no modo Basicão, só armazenando e enviando, quando eu jah tem algo armazenado ele envia na velocidade da rede e não de banda, ainda tem um lance manero de armazenar cache do youtube, windows update, e update de alguns antivirus, mas esse vai ser o assunto do proximo post. 1º irei postar as minha regras NAT, IP Proxy.

    Esse é a do IP PROXY
    Código :
    / ip proxy 
    set enabled=yes port=8080 parent-proxy=192.168.10.2:5128 \
        maximal-client-connecions=1000 maximal-server-connectons=1000 
    / ip proxy access 
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
        disabled=yes 
    add dst-host=443 action=deny comment="" disabled=yes 
    add dst-host=443 action=deny comment="" disabled=yes

    Esse é a do NAT
    Código :
    / ip firewall nat 
    add chain=srcnat dst-address=!200.201.166.0/24 protocol=tcp dst-port=80 \
        routing-mark=odd action=accept comment="NAT Caixa" disabled=no 
    add chain=dstnat in-interface=Proxy src-address=!192.168.10.2 protocol=tcp \
        dst-port=80 action=redirect to-ports=8080 comment="NAT Redir Proxy \
        Externo" disabled=no 
    add chain=dstnat dst-address=200.221.0.0/16 action=accept comment="RADIOUOL" \
        disabled=no 
    add chain=srcnat src-address=192.168.10.0/24 dst-address=10.80.1.0/24 \
        protocol=tcp action=masquerade comment="Nat Proxy" disabled=no 
    add chain=srcnat action=masquerade comment="NAT de Mascaramento" disabled=no

    Esse é o meu Squid.Conf (Copiado e Colado Aqui)
    Código :
    #Script gerado para configuração simples com mikrotik em paralelo com
    # regras de segurança, iptables, etc. executadas no mikrotik.
    http_port 5128
    visible_hostname proxy
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS
    #permissão de acesso ao proxy, troque 0.0.0.0/0 pela sua 
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal
    #bloquear todos outros acessos.
    http_access deny all
    #memoria reservada para o cache, coloque um valor de preferencia 40% 
    # do total da sua maquina, e não mais.
    cache_mem 1200 MB
    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 128 KB
    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 100 MB
    minimum_object_size 0 KB
    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 90
    cache_swap_high 95
    #indicação de localização da pasta de arquivos cache e em sequência valor 
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid 409600 256 512
    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560
    #Geração de Logs de Acesso
    access_log /var/log/squid/access.log

    Bom Espero ter ajudado com alguma coisa, mas pra ser mais preciso, eu segui o seguinte tutorial e está funcionando.

    Linux: Proxy em paralelo com o mikrotik [Artigo]







Tópicos Similares

  1. Respostas: 3
    Último Post: 12-05-2007, 19:39
  2. Web-proxy Mikrotik Ou Squid Em Linux
    Por MPFER no fórum Redes
    Respostas: 2
    Último Post: 18-04-2007, 22:05
  3. Respostas: 1
    Último Post: 11-03-2007, 20:31
  4. Iniciante no Linux e mikrotik
    Por nklaveren no fórum Redes
    Respostas: 0
    Último Post: 05-12-2006, 01:41
  5. Linux AP Mikrotik com Dwl-512, 520 ou ag530?
    Por Portela no fórum Redes
    Respostas: 10
    Último Post: 19-01-2006, 21:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L