+ Responder ao Tópico



  1. #1

    Padrão SAGU-PRO falha na interação com Banco de Dados PostgreSQL

    Gerar boleto Banco do Brasil - Layout sem dado algum.


    Olá a todos!
    Instalei e configurei o sagu-pro conforme os procedimentos de instalação contidos na documentação. Aparentemenente, o sistema está operando com todas as suas funcionadiades. Consegui fazer todos as inclusões necessárias (cadastros genéricos) no banco de dados postgreSQL através do sagu-pro, isso indica que a integração php e banco de dados postgreSQL está Ok, inclusive na geração de titulos, dentro do financeiro... Aí vem o meu problema: não estou conseguindo imprimir o boleto bancário referente ao titulo emitido. Logo que confirmo a impressão do boleto o sagu-pro redireciona para a página de impressão do mesmo, porém o boleto gerado não contém nenhum dado, aparece somente o layout de impressão vazio, com as seguintes mensagens de erro:
    Warning: pg_exec() [function.pg-exec]: Query failed: ERRO: erro de sintaxe no fim da entrada at character 182 in /etc/sagu-pro/sagu/html/lib/common.php3 on line 49
    Warning: pg_numrows(): supplied argument is not a valid PostgreSQL result resource in /etc/sagu-pro/sagu/html/lib/common.php3 on line 91
    Warning: pg_exec() [function.pg-exec]: Query failed: ERRO: erro de sintaxe no fim da entrada at character 155 in /etc/sagu-pro/sagu/html/lib/common.php3 on line 49
    Warning: pg_numrows(): supplied argument is not a valid PostgreSQL result resource in /etc/sagu-pro/sagu/html/lib/common.php3 on line 91
    Warning: pg_exec() [function.pg-exec]: Query failed: ERRO: erro de sintaxe no fim da entrada at character 226 in /etc/sagu-pro/sagu/html/lib/common.php3 on line 49
    Warning: pg_numrows(): supplied argument is not a valid PostgreSQL result resource in /etc/sagu-pro/sagu/html/lib/common.php3 on line 91
    Peço uma luz para solucionar o problema, que me parece que o sagu-pro não está jogando os dados de emissão do boleto para o arquivo /$host/financeiro/boleto/bb/boleto_bb.php. O que pode estar acontecendo?
    Muito obrigado a todos.

  2. #2
    Platinum High Blonde Avatar de lemke
    Ingresso
    Sep 2008
    Localização
    Brasília-DF
    Posts
    8.555
    Posts de Blog
    85

    Padrão

    Oi Vipnet,

    Qual versão do PostgreSQL vc está usando ?

    É a versão 7.0 ? Acredito que no 7.0 seja mais comum essa ocorrência, teria que usar no mínimo 8.2 nesse caso...
    Última edição por lemke; 11-11-2008 às 00:22.



  3. #3

    Padrão

    Versão do PostgreSQL é a 8.1. Obrigado por responder!

  4. #4

    Padrão

    aqui tive o mesmo problema, (trabalho com caixa economica) e foi resolvido colocando-se em nome da sequencia isto:
    seq_titulos_cr_id8 tenta ae se da certo.
    Um abraço

    Rogerio Eduardo Silva



  5. #5

    Padrão

    Citação Postado originalmente por supweb Ver Post
    aqui tive o mesmo problema, (trabalho com caixa economica) e foi resolvido colocando-se em nome da sequencia isto:
    seq_titulos_cr_id8 tenta ae se da certo.
    Um abraço

    Rogerio Eduardo Silva
    Obrigado por responder ao tópico. No seu caso, você alterou o nome da coluna 'seq_titulo' dentro da tabela 'titulos_cr' no banco de dados do postgreSQL ou foi no arquivo '$host/financeiro/post/novo_titulo.php3' ?

  6. #6

    Padrão

    nem em um lugar nem outro, dentro do sagu na pagina financeiro - local de pagamento nesta pagina em "Nome da Sequência" insira seq_titulos_cr_id8 os outros campos complete com os dados de sua conta. aqui (caixa, carteira 80 sem registro) deu certo



  7. #7

    Padrão

    Citação Postado originalmente por supweb Ver Post
    nem em um lugar nem outro, dentro do sagu na pagina financeiro - local de pagamento nesta pagina em "Nome da Sequência" insira seq_titulos_cr_id8 os outros campos complete com os dados de sua conta. aqui (caixa, carteira 80 sem registro) deu certo

    Nossa!!! Caiu como uma luva!

    Muito obrigado pela interação. Resolveu meu problema também. Fica aí a dica para quem tiver essa mesma dificuldade! Abraços!

  8. #8

    Padrão

    Fico satisfeito em ter ajudado.
    Um abraço



  9. #9

    Padrão

    vipnet, vc instalou em qual distribuição? Já tentei no Debian Etch e não consegui. Vc tem algum tutorial?

    Marcelo

  10. #10

    Padrão

    Debian instala sim, e funciona muito bem.



  11. #11

    Padrão

    os pacotes necessário (php, apache, postgresql, etc) pelo apt-get ou na mão mesmo? vc tem algum tutorial?

    valeu pela ajuda.

  12. #12

    Padrão

    tudo apt-get, vejo muitas vantagens de instalar pelo apt. facilidade, atualização, etc. Qual sua dificuldade? tutorial tem o que esta no site do desenvolvedor GUIA PARA INSTALAÇÃO DO SAGU-PRO | GULBF mas se quiser posso escrever um passo-a-passo para instala-lo no debian.
    Um abraço



  13. #13

    Padrão

    poderias me fazer esse favor?

    ja tentei fazer pelo site, mas todas as vezes aparecem pendencias e a instalação não é concluída.

    valeu mesmo pela ajuda!!!

  14. #14

    Padrão

    ok, la vai um passo-a-passo feito com o que me lembro, eventuais problemas me informe, lembrando que essa forma de instalação nao e a do desenvolvedor, tambem nao sei o estado que vc deixou seu debian ae, escrevo isto pensando que seu debian foi instalado de forma minimalista. Tambem espero que ja tenha em sua rede um dns configurado, ja com o nome do site que vc irar usar para acessar o sagu-pro apontando corretamente para o debian com sagu-pro

    TUTORIAL DE INSTALAÇÃO SAGU-PRO EM DEBIAN ETCH
    por Rogerio eduardo Silva

    inicialmente instale os seguintes pacotes:
    apt-get install apache2
    apt-get install libapache2-mod-php5 libapache2-mod-perl2
    apt-get install php5-gd php5-pgsql
    apt-get install php5 php-fpdf
    apt-get install php5-cli
    apt-get install postgresql

    Preparando o postgres:
    su postgres
    createdb sagu
    createlang plpgsql sagu
    psql sagu -Upostgres -c "\i /sagu-pro/sagu/db/sagu-pro.sql"
    psql sagu
    createuser nome_do_utilizador
    alter user administrador with password 'senha';
    alter user postgres with password 'senha';
    SELECT pgx_grant('ALL','','nome_do_utilizador');
    SELECT pgx_grant('ALL','','postgres');
    \q
    exit
    nano /etc/postgresql/7.4/main/postgresql.conf
    alterar tcpip_soquet=true
    nano /etc/postgresql/7.4/main/pg_hba.conf
    nas linhas que tiver identsumeuser altere para md5 em todas linhas
    /etc/init.d/postgresql-7.4 restart
    Prontinho, postgres configurado.
    Existe um erro em se configurar o postgres deste jeito, o backup nao ira funcionar corretamente. Instalo desta forma porque sou "purista" e este passo-a-passo foi escrito as pressas para ajudar o amigo, depois com seu sagu rodando ae a gente faz o backup funcionar.

    Configurando o debian
    nano /etc/hosts
    acrescentar linha ip_da_maquina nome_do_site

    configurando sagu-pro:
    faço download e descompacto ele na pasta /var/www (lembrando novamente que nao e assim que o desenvolvedor recomenda a instalação, depois posso fazer um passo a passo conforme ele pede.)
    chown -R www-data:www-data /var/www/sagu-pro
    nano /var/www/sagu-pro/html/lib/common.php3
    alterar:
    $SAGU_PATH = "/var/www/sagu-pro/";
    $LoginDB = "sagu";
    $LoginUID = "postgres";
    $LoginPWD = "senha_cadastrada_no_sagu";
    $SAGU_HOST = "nome_do_site_cadastrado_no_bind"

    Configurando o apache:
    nano /etc/apache2/mods-available/dir.conf acrescentar index.php3 index.phtml ao final da linha.
    nano /etc/apache2/apache2.conf
    na linha DefaultLanguage descomentar e colocar pt-BR
    na linha AddDefaultCharset descomentar e colocar ISO-8859-1
    nano /etc/php5/apache2/php.ini
    register_globals = On
    magic_quotes_gpc = On
    magic_quotes_runtime = On

    Fazendo o virtual host:
    nano /etc/apache2/sites-enabled/000-default

    NameVirtualHost ip_do_pc
    <VirtualHost nome_do_site>
    ServerAdmin [email protected]
    ServerName nome_do_site

    DocumentRoot /var/www/sagu-pro/html
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/sagu-pro/html>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    ErrorLog /var/log/apache2/error-sagu-pro.log
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access-sagu-pro.log combined
    ServerSignature On
    </VirtualHost>

    /etc/init.d/apache2 restart

    pronto, seu sagu-pro ja deve funcionar para vc fazer seus cadastros, todos os scripts que estao na pasta autenticador nao irao funcionar, pois o bash php no debian fica em outro local, mais tarde posto aqui o que deve ser mudado nos cripts.
    Um abraço



  15. #15

    Padrão

    valeu!!!

    vou fazer os procedimentos e te aviso.

    abraço!

  16. #16

    Padrão

    Citação Postado originalmente por macvitor Ver Post
    vipnet, vc instalou em qual distribuição? Já tentei no Debian Etch e não consegui. Vc tem algum tutorial?

    Marcelo

    Opa! Eu instalei na mesma distro que vc usa. Debian Etch, e tá funfando legal agora!...


    abraços.