+ Responder ao Tópico



  1. #1

    Padrão Problema WebProxy no MK 3.17

    Olá pessoal, instalei o mk versao 3.17, mas o proxy insiste em não funcionar...o trafego da rede de nat do redirect contabiliza o trafego, no status no proxy tambem vejo que ele faz cache dos arquivos, mas a pagina fica carregando infinitamente no browser. As configurações segue abaixo:

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "Posto"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: master

    Redirecionamento Proxy
    chain=dstnat action=redirect to-ports=3128 protocol=tcp
    in-interface=LOCAL dst-port=80

    Por favor se alguem puder ajudar.


    Vlw

  2. #2

    Padrão Problema WebProxy no MK 3.17

    Citação Postado originalmente por standart Ver Post
    Olá pessoal, instalei o mk versao 3.17, mas o proxy insiste em não funcionar...o trafego da rede de nat do redirect contabiliza o trafego, no status no proxy tambem vejo que ele faz cache dos arquivos, mas a pagina fica carregando infinitamente no browser. As configurações segue abaixo:

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "Posto"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: master

    Redirecionamento Proxy
    chain=dstnat action=redirect to-ports=3128 protocol=tcp
    in-interface=LOCAL dst-port=80

    Por favor se alguem puder ajudar.


    Vlw

    espero poder te ajudar " standart "

    Acho q so falto vc colocar o "src adress" (sua faixa de rede ex:192.168.2.0/24 ) no direcionamento !

    action=redirect chain=dstnat comment="Web Proxy" disabled=no dst-port=\
    80 protocol=tcp src-address=192.168.2.0/24 to-ports=8080

    So trocar por 3128 no meu caso meu direcionamento e pra porta 8080

    Espero q seja util pra vc ...

    at+...



  3. #3

    Padrão

    action=redirect chain=dstnat comment="" disabled=no dst-port=\
    80 protocol=tcp src-address=xxx.xxx.xxx.0/24 to-ports=3128

  4. #4

    Padrão

    Tranparent Proxy está ativado???se nao, ative!!
    vlww...



  5. #5

    Padrão

    ola, não tem a transparent proxy nas versões 3.x, não pelo menos na minha 3.20. mais o que eu queria visar mesmo é que o proxy da versão 3.x veio pra repentar essa função mesmo, por não se tratar mais de squid tem poucas funções, como limitar o tamanho max do arquivo cacheado, isso faz com que a memória ou espaço em disco seja detonado em poucas horas, fazendo o proxy ficar lento aou inves de agilizar. se algém tiver mais algum comentario por favor enriqueça o post.

  6. #6

    Padrão

    AMIGOS ESTOU COM O MESMO PROBLEMA DO "standart" ALGUEM ENCONTROU SOLUÇÃO...POIS FIZ TUDO CONFORME OS ARTIGOS E EXEMPLOS MUDANDO APENAS PARA O END DA MINHA REDE E PORTA...MAS AS PAGINAS CONTINUAM COMO SENAO TIVESSE PROXY ATIVO... MAS NO PROXY VEJO QUE OS PACOTES RODAM NA REGRA TB TUDO NORMAL SO NAO ENTENDO O PORQ NAO CARREGA AS PAGINAS DO CACHE...



  7. #7

    Padrão

    Ae galera, uso a versao 3.20; e nao tem a opção proxy transparente... como faço?

    Abraços

  8. #8

    Padrão

    ola amigos não sei se meu web proxy esta funcionado pois em cache size fica 0 e também em reserved for cache faca 0 olhem as fotos e me digam por favor se está funcionandohttp://img21.imageshack.us/img21/8113/webproxy.png

    Minhas configurações são estas
    http://img19.imageshack.us/img19/6903/webproxy1.png


    http://img8.imageshack.us/img8/2316/webproxy2.png

    http://img12.imageshack.us/img12/8645/webproxy3.png


    http://img148.imageshack.us/img148/7730/webproxy4.png


    http://img21.imageshack.us/img21/2215/webproxy5.png




    Amigos por favor ajudem ja faz dois dias que fiz uma pergunta e niguem para responder por favor vcs que tem mais experiencia no assunto ajudem ok
    Última edição por andrelns; 24-03-2009 às 22:50.



  9. #9

    Padrão

    amigos vcs que sabem mais ajudem esta resposta para quem sabe e muitp simples só quero saber se esta funcionando meu web proxy

  10. #10

    Padrão

    Citação Postado originalmente por andrelns Ver Post
    amigos vcs que sabem mais ajudem esta resposta para quem sabe e muitp simples só quero saber se esta funcionando meu web proxy

    Olá!

    O webproxy obteve importantes atualizações no mk 3.22, recomendo seriamente vc atualizar sua versão e seguir as configurações abaixo:

    PS: Atente para as opções em vermelho, e mude-as conforme as configurações de sua rede e servidor.

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=130702000KiB max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=deny comment="allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no dst-port=!443,563 method=CONNECT
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25
    add action=allow comment="" disabled=no src-address=192.168.1.0/24
    add action=deny comment="" disabled=no

    /ip proxy cache
    add action=deny comment="don't cache dynamic cgi pages" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="don't cache dynamic http pages" disabled=no dst-host=https://


    /ip firewall nat
    add action=redirect chain=dstnat comment="" disabled=no dst-address=!192.168.1.100
    dst-port=80 in-interface=LOCAL
    protocol=tcp src-address=192.168.1.0/24 to-ports=3128


    Abraços



  11. #11

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    Olá!

    O webproxy obteve importantes atualizações no mk 3.22, recomendo seriamente vc atualizar sua versão e seguir as configurações abaixo:

    PS: Atente para as opções em vermelho, e mude-as conforme as configurações de sua rede e servidor.

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=130702000KiB max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=deny comment="allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no dst-port=!443,563 method=CONNECT
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25
    add action=allow comment="" disabled=no src-address=192.168.1.0/24
    add action=deny comment="" disabled=no

    /ip proxy cache
    add action=deny comment="don't cache dynamic cgi pages" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="don't cache dynamic http pages" disabled=no dst-host=https://


    /ip firewall nat
    add action=redirect chain=dstnat comment="" disabled=no dst-address=!192.168.1.100 dst-port=80 in-interface=LOCAL
    protocol=tcp src-address=192.168.1.0/24 to-ports=3128

    Abraços


    mais amigo minha versão e a 2.9.27 e funciona tudo so queria que vc me tira-se uma duvida meu web proxy esta configurado só que não sei dizer se está pegando pos tudo se meche
    uptime 00:03:00
    clients: 16
    requests: 1233
    hits:42

    agora em cache size fica 0 zero
    e em reserved for cache tambem fica em 0 zero
    o resto tudo se meche será que esta pegando só quero saber isto se esta pegando ou não no post acima tem fotos por favor me ajudem

  12. #12

    Padrão Tambem preciso de ajuda com o proxy no 3.22

    Se alguem puder me ajudar também, estou com problema para configurar o cache na versão 3.22 já fiz e refis quase todas as configurações que postarão no forum, acho que estou deixando alguma coisa passar e não estou percebendo.



  13. #13

    Padrão Espero ajudar...

    Essas imagens são para versão 2.9.xx
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Bloquear acesso externo ao proxy.bmp
Visualizações:	117
Tamanho: 	1,00 MB
ID:      	4215   Clique na imagem para uma versão maior

Nome:	         Redirecionar porta 80 para 3128.bmp
Visualizações:	106
Tamanho: 	946,4 KB
ID:      	4216  

    Clique na imagem para uma versão maior

Nome:	         webproxy.bmp
Visualizações:	113
Tamanho: 	433,8 KB
ID:      	4217   Clique na imagem para uma versão maior

Nome:	         mark connection - output.bmp
Visualizações:	84
Tamanho: 	1,00 MB
ID:      	4218  

    Clique na imagem para uma versão maior

Nome:	         mark connection - prerouting.bmp
Visualizações:	85
Tamanho: 	1,00 MB
ID:      	4219   Clique na imagem para uma versão maior

Nome:	         mark packet - output.bmp
Visualizações:	76
Tamanho: 	1.023,7 KB
ID:      	4220  

    Clique na imagem para uma versão maior

Nome:	         mark packet - prerouting.bmp
Visualizações:	75
Tamanho: 	1.023,7 KB
ID:      	4221   Clique na imagem para uma versão maior

Nome:	         Global-in.bmp
Visualizações:	86
Tamanho: 	374,1 KB
ID:      	4222  

    Clique na imagem para uma versão maior

Nome:	         Global-out.bmp
Visualizações:	75
Tamanho: 	374,1 KB
ID:      	4223  

  14. #14

    Padrão

    Obrigado Charles, com certeza ajudou bastante.



  15. #15

    Padrão ....

    Precisando estaremos todos aqui.
    Valeu equipe under-linux. Muito do que aprendi partiu daqui, e é sempre bom partilhar de nossos conhecimentos.
    Agradeço a todos...

  16. #16

    Smile Consegui resolver proxy paralelo mk 3.20

    Boa tarde

    consegui resolver o problema do proxy paralelo ao mk utilizo o mk 3.20 mas vou fazer upgrade pra 3.22 nos proximos dias e trabalho com debian em paralelo, ralei bastante nos ultimos dias tentando resolver o problema em cima de um erro especifico que não permitia o funcionamento do proxy se alguem tem dificuldade poste suas regras e mensagem de erro pra que possamos ajudar especificamente nas versões de 2.9.50 a 3.20

    abraços



  17. #17

    Padrão

    Caro colega, vou aproveitar o post do amigo, pois estou com o mesmo problema, montei uma maquina boa + licença do mk 3.13 para deixar o servidor legal, joguei o backup do mk 2.9.27 q tá em funcionamento e o proxy não quer funcionar de forma alguma. apaguei todas as regras do antigo, usei as suas somente editando os ips e a parta q uso a 3126, mas parece não passar nada pelo proxi, fica tdo em 0 menos os requests e a memória usada q tá em 64k.
    O amigo teria alguma ideia?
    Desde já agradeço..

  18. #18

    Padrão

    Alguem tem o web-proxy 3.x funcionando legal ????
    que possa postar as configs ??