+ Responder ao Tópico



  1. Galerinha sou iniciante no MK, gostaria de saber qual dos modelos de load balance eu poderia usar ja que eu quero apenas direcionar o trafego P2P pra um link e o resto do trafego deixar em outro link. Eu tenho 2 links de 1 mega da OI (TCHAU). Tambem consegui configurar o webproxy com cache full, teria alguma incompatibilidade com o load balance??? e como saber se a cache full esta funcionando?
    Gentileza me indica um passo a passo pra q eu consiga o q quero.
    Grato.

  2. Citação Postado originalmente por isacloko Ver Post
    galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

    LOAD BALANCE 3

    esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.

    Mikrotik Versão 2.9

    exemplo:

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    Regras

    / ip firewall mangle
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no


    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no

    add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes

    Mikrotik 3.10 contendo 5 Links

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24
    Link5 ip - 50.50.50.1/24

    Regras

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link1 nth=4,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link1 \
    disabled=no in-interface=Rede new-routing-mark=link1 passthrough=no
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link2 nth=4,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link2 \
    disabled=no in-interface=Rede new-routing-mark=link2 passthrough=yes
    add action=mark-connection chain=prerouting comment=Link3 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link3 nth=4,2 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link3 \
    disabled=no in-interface=Rede new-routing-mark=link3 passthrough=no
    add action=mark-connection chain=prerouting comment=Link4 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link4 nth=4,3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link4 \
    disabled=no in-interface=Rede new-routing-mark=link4 passthrough=no
    add action=mark-connection chain=prerouting comment=Link5 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link5 nth=4,4 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link5 \
    disabled=no in-interface=Rede new-routing-mark=link5 passthrough=no
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=link2 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=link2 passthrough=yes routing-mark=link2
    add action=add-src-to-address-list address-list=ips address-list-timeout=0s \
    chain=prerouting comment="" disabled=no in-interface=Rede

    /ip firewall nat
    add action=src-nat chain=srcnat comment="" connection-mark=link1 disabled=no \
    to-addresses=10.10.10.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link2 disabled=no \
    to-addresses=20.20.20.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link3 disabled=no \
    to-addresses=30.30.30.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link4 disabled=no \
    to-addresses=40.40.40.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link5 disabled=no \
    to-addresses=50.50.50.1 to-ports=0-65535

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=link1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=link2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=link3 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=link4 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    50.50.50.1 routing-mark=link5 scope=30 target-scope=10


    Espero que ajude muita gente, qualquer duvida e so postar obrigado

    Já fiz Loadbalance por Pacotes como esse modelo que estou citando, mas só conseguir fazer funcionar com 2 links, até a parte de colocar pra balancear conseguir com 3 links, mas na hora de fazer as regras pra desabilitar a regra pra determinada qnt de links ativo, num funcionava, teria como vc me passar como seria pra esse exemplo de 5 links, pois aí eu irei colocar aqui 3 links e qnd aí como vai tá sem link nas outras as regras ficam ativadas... qnd for colocando link aqui já tá feito a configuração!!! Outra Duvida... Funcionária um Mikrotik só pra fazer esse LoadBalance, se usar o VMware para virtualizar esse loadbalance e outra virtualização algum linux pra usar algum sistemas de gerencia?
    Grato se puder ajudar!!! Vlw



  3. Citação Postado originalmente por isacloko Ver Post
    vc me poderia me passar suas regras no mikrotik pra mim da uma analizada do seu proxy paralelo?
    Amigo estou com dois link ADSL de 1mg cada ip fixo,, montei um pc com mikrotik 2.9.27, dele entra os dois link e sai para o 1º radio gi-link 2404, depois desse radio para para mais 11 radios tudo em bridge. bom tentei descrever um pouco minha rede. trata-se de um condominio de predio, blz. FIZ um LOAD BALANCE, mais toda vez que coloco para fumcionar a net fica lenta, fiz controle de banda para os clientes em 64k/128k a paguina do hotspot demora umas 2 horas para aparecer então coloquei 128k/128k piorou ainda mais, todos clientes começa a nevegar nessa banda puxa ainda mais meus link´s, será o LOAD BALANCE? que esta complicando minha vida!!!!! me ajude, ha 9 meses que estou no mikrotik sem dormir. tudo o que eu sei foi aprendendo com voces, fui enganado por uma firma que me vendeu equipamentos e disse que tinha suporte é que me ajudaria a aprender usar o sistema-----cade eles?$#@.rsrsrsrs

  4. Olá Amigo Boa Noite.....

    Olha só quero usar este seu LOAD BALANCE 2
    Mais aqui uso Web-Proxy no Mirotik então tenho uma regra de redireconamento para o Web-Proxy
    então quando usei este seu Load Balance por grupos todos sairão pelo mesmo link ainda
    tenho que criar ou mudar algo no redirecionameto para isto



  5. [QUOTE=isacloko;367255]galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas


    LOAD BALANCE 2

    Esse vc separa por grupos de usuarios da sua rede.

    Exemplo:

    Interface

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:


    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

    galera agora vou colocar uns sripts para se for o caso de algum link cair:

    Regras:

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


    exemplo 2

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24

    Regras

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.64
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.65-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupC" \
    disabled=no new-routing-mark=GrupC passthrough=no src-address=\
    192.168.0.129-192.168.0.192
    add action=mark-routing chain=prerouting comment="GrupD" \
    disabled=no new-routing-mark=GrupD passthrough=no src-address=\
    192.168.0.193-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10





    Ola amigo tudo bem...
    Parabéns pela iniciativa ...

    só q estou com uma duvida e se vc puder me ajudar eu agradeço.

    em meu mk tenho um link full 4 MG e ele esta ficando sobrecarregado em certos horarios
    então apliquei esse load balance 2 q vc postou ai o do exemplo 2...
    apenas em mangle criei a regra ip-192.168.0.1 a 192.168.0.50 - GrupoA
    mas parece não estar funcionando pq se eu dar tracert -d 8.8.8.8
    ele vai me mostrar a rota ...
    ip do meu mk
    ip do modem adsl
    e outros ip da BRT

    isso quer dizer q estou saindo pela adsl
    mas se medir minha velocidade ou fazer um donwload eu estou pelo link ....

    ip route
    add dst-address=0.0.0.0/0 gateway=xxx.link.xxx scope=255 target-scope=10 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=GrupA comment="" disabled=no


    add chain=prerouting src-address=192.168.0.2-192.168.0.50 action=mark-routing new-routing-mark=GrupA passthrough=no \
    comment="GrupA" disabled=no


    teria algo errado ...
    obrigado pela atenção..






Tópicos Similares

  1. Roteador de Load Balance TP Link Tl-er5120
    Por raumaster no fórum Redes
    Respostas: 8
    Último Post: 12-12-2013, 10:08
  2. Respostas: 3
    Último Post: 18-12-2011, 12:55
  3. entendimento da regra de Load Balance.
    Por hamir no fórum Redes
    Respostas: 15
    Último Post: 13-02-2011, 15:22
  4. Respostas: 0
    Último Post: 18-10-2008, 13:56
  5. Melhor forma de Load Balance p 3 links
    Por fabianojean no fórum Redes
    Respostas: 11
    Último Post: 29-08-2007, 18:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L