Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. obrigado mano...agredeco muito!

  2. Vou Postar aqui a configuração com as regras para colocar no MK já com o cache FULL (lembrando que com essas regras o cache full só funciona na versão 3.x, se algum de vcs souber uma regra para 2.9.27 que funcione o cache full posta ae que ficarei muito agradecido, e vou postar o meu squid.conf. Vamos lá...
    Lembrando que o debian e o mikrotik tem que estar na mesma faixa de ip
    No mikrotik vc fará uma outra interface e colocara a faixa de ip dos clientes ok.

    Topologia: LINK=è SUITE =è do suíte sai um cabo para o servidor debian e outro para o Mikrotik. Ok
    Sevidor debian 01 placa de rede
    Servidor mikrotik 02 placas de rede

    Primeiro instale o debian
    Depois do debian instalado execute esses comandos para instalar os programas que vc ira usar.
    Aptitude upgrade
    Aptitude install ssh (precisa do cd do debian para conluir a instalação)
    Aptitude install squid

    Depois coloque o squid.conf desse jeito alterando o ip, cachê mem, e o resto do seu jeito.

    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128 transparent
    visible_hostname webproxy


    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.2.1/24
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid/access.log

    #cache.log
    cache_log /var/log/squid/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 512 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 20 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0


    Regras no MIKROTIK

    192.168.2.3 ip do servidor debian
    O ip do mikrotik sera 192.168.2.2

    /Ip firewall nat

    add chain=dstnat src-address=192.168.2.3 dst-address=192.168.2.3 protocol=tcp dst-port=80 action=accept comment="Cache Full" disabled=no

    add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.3 to-ports=5128 comment="" disabled=no



    fazer masquerade
    masquerade em out interface coloca a do link e só



    / ip firewall mangle
    add chain=forward content="X-Cache: HIT" action=mark-connection new-connection-mark=forward-hits passthrough=yes comment="Cache Full" disabled=no
    add chain=forward connection-mark=forward-hits src-address-list="" action=mark-packet new-packet-mark=cache-hits passthrough=no comment="" disabled=no

    add chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes comment="" disabled=no


    /ip firewall mangle
    add action=mark-connection chain=forward comment="Cache Full" content="X-Cache: HIT" disabled=no new-connection-mark=forward-hits passthrough=yes
    add action=mark-packet chain=forward comment="" connection-mark=forward-hits disabled=no new-packet-mark=cache-hits passthrough=no src-address-list=""
    add action=mark-connection chain=postrouting comment="" disabled=no dscp=48 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=no

    Bom pra funcionar o básico é isso o resto vc já sabe, firewall etc...
    Primeiro faça testes veja se esta ok pra depois colocar pros clientes pois cada caso é um caso funcionou filé aki. Vlw...



  3. Quer fazer o squid voar !?!?! heheheh
    o squid não utiliza tanto do processador, o que ele gosta é de memoria RAM muita mesmo, quanto mais melhor.
    te aconselho colocar esse P4 ai pra rodar e utilizar esses 4GB de memoria e esse HD de 500

    *maximum_object_size para 100 MB (tamanho dos arquivos cache no HD)

    *aumenta o cache_mem 3072 (deixando 1 GB livre para o sistema)

    *cache_dir ufs /var/spool/squid 460800 256 512 (Capacidade de Armazenamento para 450GB deixando 50GB para sistema)

    fica aqui a minha opnião
    Última edição por magrock; 17-03-2009 às 02:05.

  4. Opa, valeu pela dica irmão me ajudou muito vlw mesmo....



  5. poh cara legal... mas pensando assim... com tanta memoria e processador ,,,, nao seria melhor fazer o squid rodar em duas ou tres instancias???.... eu estou fazendo o mk com o thunder-cache que faz cache de youtube globo windowsupdate redtube terra uol globo, ele eh mto bom mas queria rodar um segundo squid2 na mesma maquina mas fazendo cache comum de paginas... eu to com um makina core 2 duo com 4gb de memoria, vou ver se consigo testar ela nas torres amanha a sua config do mk vai me ajudar mto pois ainda tava perdido nessa parte...






Tópicos Similares

  1. Qual ap usar no cliente
    Por miguel22rj no fórum Redes
    Respostas: 1
    Último Post: 11-12-2007, 23:18
  2. Qual AP usar no MK?
    Por faieppi no fórum Redes
    Respostas: 4
    Último Post: 07-10-2007, 08:40
  3. Respostas: 16
    Último Post: 12-06-2007, 10:11
  4. Qual webcam usar no linux?
    Por luisoft no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-03-2006, 12:23
  5. QUAL DISTRIBUIÇÃO USAR PARA PROXY + DHCP
    Por cloud no fórum Servidores de Rede
    Respostas: 4
    Último Post: 10-10-2004, 14:18

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L