Página 7 de 8 PrimeiroPrimeiro ... 2345678 ÚltimoÚltimo
+ Responder ao Tópico



  1. #37

    Padrão

    Voltando para comentar.
    Estava errando a regra de iptables para compartilhar a internet. Agora eu consigo navegar, porém o servidor debian nao faz o cache...
    Vou tentar mexer aqui um pouco para ver o que fazer.
    A regra de nat para redirecionamento pro servidor debian deve vir antes da regra de nat global? Tentei fazer isso, mas sem sucesso. Ele navega um pouco mais lento, mas ainda assim não faz o cache. Isso me leva a crer que o problema possa ser o squid.
    Vou rever as regras aqui, mas se algum colega do fórum passou por isso e quiser compartilhar a experiencia, fico imensamente agradecido...

    Abraços

  2. #38

    Padrão

    Uma dúvida: Como não tem regra de redirecionamento para o IP+porta do proxy como as requisições dos clientes vão para o IP + porta 3128 do proxy?



  3. #39

    Padrão

    Como fazer a regra de mascaramento para 3 faixas de ips, pois uso 3 faixas nos clientes...

  4. #40

    Padrão

    Citação Postado originalmente por lfernandosg Ver Post
    Uma dúvida: Como não tem regra de redirecionamento para o IP+porta do proxy como as requisições dos clientes vão para o IP + porta 3128 do proxy?
    Olá!!! Como não tem? Proxy Transparente amigo!
    "Vide regras 4 e 5"



  5. #41

    Padrão

    Citação Postado originalmente por horusosbourne Ver Post
    Voltando para comentar.
    Estava errando a regra de iptables para compartilhar a internet. Agora eu consigo navegar, porém o servidor debian nao faz o cache...
    Vou tentar mexer aqui um pouco para ver o que fazer.
    A regra de nat para redirecionamento pro servidor debian deve vir antes da regra de nat global? Tentei fazer isso, mas sem sucesso. Ele navega um pouco mais lento, mas ainda assim não faz o cache. Isso me leva a crer que o problema possa ser o squid.
    Vou rever as regras aqui, mas se algum colega do fórum passou por isso e quiser compartilhar a experiencia, fico imensamente agradecido...

    Abraços
    Olá amigo, já verificou se seu squid está como transparente?? criou essa regra(iptables)??? vc deve redirecionar todas as requisições vindas da porta 80 para a porta 3128(tcp) e configurar seu squid.conf para trabalhar como proxy transparente, já o fez? esse deve ser o problema de não estar fazendo o cache, e se não o fez faça e quando fizer monitore as requisições dos clientes no access.log com um:
    tail -f /var/log/squid/access.log
    e veja se está tendo cache, aguardo retorno!

  6. #42

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Como fazer a regra de mascaramento para 3 faixas de ips, pois uso 3 faixas nos clientes...
    Opa, vc quer fazer mascaramento de NAT no linux ou no mk?

    Exemplo - Linux
    iptables -t nat -A POSTROUTING -o ethx -s 10.0.0.0/8 -j MASQUERADE
    iptables -t nat -A POSTROUTING -o ethx -s 172.16.0.0/12 -j MASQUERADE
    iptables -t nat -A POSTROUTING -o ethx -s 192.168.0.0/16 -j MASQUERADE

    Exemplo - MikroTik
    /ip firewall nat add chain=srcnat action=masquerade src-address=10.0.0.0/8 out-interface=internet
    /ip firewall nat add chain=srcnat action=masquerade src-address=172.16.0.0/12 out-interface=internet
    /ip firewall nat add chain=srcnat action=masquerade src-address=192.168.0.0/16 out-interface=internet